Bug 1186612 - (CVE-2020-22030) VUL-1: CVE-2020-22030: ffmpeg: A heap-based Buffer Overflow vulnerability exists at libavfilter/af_afade.c in crossfade_samples_fltp()
(CVE-2020-22030)
VUL-1: CVE-2020-22030: ffmpeg: A heap-based Buffer Overflow vulnerability exi...
Status: RESOLVED INVALID
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P5 - None : Minor
: ---
Assigned To: E-mail List
Security Team bot
https://smash.suse.de/issue/300946/
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2021-05-28 13:50 UTC by Robert Frohl
Modified: 2021-05-28 13:58 UTC (History)
1 user (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Frohl 2021-05-28 13:50:49 UTC
CVE-2020-22030

A heap-based Buffer Overflow vulnerability exists in FFmpeg 4.2 at
libavfilter/af_afade.c in crossfade_samples_fltp, which might lead to memory
corruption and other potential consequences.

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2020-22030
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-22030
https://trac.ffmpeg.org/ticket/8276
Comment 1 Robert Frohl 2021-05-28 13:58:49 UTC
asan does not trigger- > tracking as not affected, closing