Bug 1186616 - (CVE-2020-22034) VUL-1: CVE-2020-22034: ffmpeg: A heap-based Buffer Overflow vulnerability exists at libavfilter/vf_floodfill.c
(CVE-2020-22034)
VUL-1: CVE-2020-22034: ffmpeg: A heap-based Buffer Overflow vulnerability exi...
Status: IN_PROGRESS
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P4 - Low : Minor
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/300935/
CVSSv3.1:SUSE:CVE-2020-22034:5.5:(AV:...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2021-05-28 14:12 UTC by Robert Frohl
Modified: 2021-11-04 08:01 UTC (History)
3 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Frohl 2021-05-28 14:12:48 UTC
CVE-2020-22034

A heap-based Buffer Overflow vulnerability exists FFmpeg 4.2
atlibavfilter/vf_floodfill.c, which might lead to memory corruption and other
potential consequences.

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2020-22034
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-22034
https://trac.ffmpeg.org/ticket/8236
Comment 1 Robert Frohl 2021-05-28 14:14:48 UTC
ffmpeg 3.4.2 asan:

==29328==ERROR: AddressSanitizer: heap-buffer-overflow on address 0x63000000e500 at pc 0x0000006ef35c bp 0x7fffc94610c0 sp 0x7fffc94610b8
WRITE of size 2 at 0x63000000e500 thread T0                
    #0 0x6ef35b in filter_frame libavfilter/vf_floodfill.c:333
    #1 0x61f4d5 in ff_filter_frame_framed libavfilter/avfilter.c:1142
    #2 0x61f4d5 in ff_filter_frame_to_filter libavfilter/avfilter.c:1290
    #3 0x61f4d5 in ff_filter_activate_default libavfilter/avfilter.c:1339
    #4 0x61f4d5 in ff_filter_activate libavfilter/avfilter.c:1500
    #5 0x62f1d7 in push_frame libavfilter/buffersrc.c:181
    #6 0x62f1d7 in av_buffersrc_add_frame_internal libavfilter/buffersrc.c:255
    #7 0x62f1d7 in av_buffersrc_add_frame_flags libavfilter/buffersrc.c:164
    #8 0x5c25f4 in ifilter_send_frame fftools/ffmpeg.c:2216 
    #9 0x5c25f4 in send_frame_to_filters fftools/ffmpeg.c:2295
    #10 0x5c433c in decode_video fftools/ffmpeg.c:2496
    #11 0x5c81ff in process_input_packet fftools/ffmpeg.c:2650
    #12 0x557a52 in process_input fftools/ffmpeg.c:4450
    #13 0x557a52 in transcode_step fftools/ffmpeg.c:4570
    #14 0x557a52 in transcode fftools/ffmpeg.c:4624
    #15 0x557a52 in main fftools/ffmpeg.c:4830
    #16 0x7fe22349d349 in __libc_start_main (/lib64/libc.so.6+0x24349)
    #17 0x5703d9 in _start (/build/ffmpeg-3.4.2/ffmpeg_g+0x5703d9)

0x63000000e500 is located 0 bytes to the right of 57600-byte region [0x630000000400,0x63000000e500)
allocated by thread T0 here:                               
    #0 0x7fe224283038 in posix_memalign (/usr/lib64/libasan.so.4+0xdd038)
    #1 0x263b394 in av_malloc libavutil/mem.c:87
    #2 0x263b394 in av_mallocz libavutil/mem.c:224
    #3 0x263b394 in av_calloc libavutil/mem.c:234
Comment 2 Robert Frohl 2021-05-28 14:21:12 UTC
tracking as affected:

- SUSE:SLE-15:Update/ffmpeg
- SUSE:SLE-15-SP2:Update/ffmpeg
Comment 3 Alynx Zhou 2021-06-11 08:27:19 UTC
https://build.suse.de/request/show/243003
Comment 7 Swamp Workflow Management 2021-07-14 19:54:01 UTC
openSUSE-SU-2021:2322-1: An update that fixes 23 vulnerabilities is now available.

Category: security (important)
Bug References: 1172640,1186406,1186583,1186586,1186587,1186596,1186597,1186598,1186600,1186603,1186604,1186605,1186613,1186614,1186615,1186616,1186658,1186660,1186757,1186758,1186762,1186763
CVE References: CVE-2019-17539,CVE-2020-13904,CVE-2020-20448,CVE-2020-20451,CVE-2020-21041,CVE-2020-22015,CVE-2020-22016,CVE-2020-22017,CVE-2020-22019,CVE-2020-22020,CVE-2020-22021,CVE-2020-22022,CVE-2020-22023,CVE-2020-22025,CVE-2020-22026,CVE-2020-22031,CVE-2020-22032,CVE-2020-22033,CVE-2020-22034,CVE-2020-22038,CVE-2020-22039,CVE-2020-22043,CVE-2020-22044
JIRA References: 
Sources used:
openSUSE Leap 15.3 (src):    ffmpeg-3.4.2-11.3.1
Comment 8 Swamp Workflow Management 2021-07-14 20:15:42 UTC
SUSE-SU-2021:2322-1: An update that fixes 23 vulnerabilities is now available.

Category: security (important)
Bug References: 1172640,1186406,1186583,1186586,1186587,1186596,1186597,1186598,1186600,1186603,1186604,1186605,1186613,1186614,1186615,1186616,1186658,1186660,1186757,1186758,1186762,1186763
CVE References: CVE-2019-17539,CVE-2020-13904,CVE-2020-20448,CVE-2020-20451,CVE-2020-21041,CVE-2020-22015,CVE-2020-22016,CVE-2020-22017,CVE-2020-22019,CVE-2020-22020,CVE-2020-22021,CVE-2020-22022,CVE-2020-22023,CVE-2020-22025,CVE-2020-22026,CVE-2020-22031,CVE-2020-22032,CVE-2020-22033,CVE-2020-22034,CVE-2020-22038,CVE-2020-22039,CVE-2020-22043,CVE-2020-22044
JIRA References: 
Sources used:
SUSE Linux Enterprise Workstation Extension 15-SP3 (src):    ffmpeg-3.4.2-11.3.1
SUSE Linux Enterprise Workstation Extension 15-SP2 (src):    ffmpeg-3.4.2-11.3.1
SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP3 (src):    ffmpeg-3.4.2-11.3.1
SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP2 (src):    ffmpeg-3.4.2-11.3.1
SUSE Linux Enterprise Module for Desktop Applications 15-SP3 (src):    ffmpeg-3.4.2-11.3.1
SUSE Linux Enterprise Module for Desktop Applications 15-SP2 (src):    ffmpeg-3.4.2-11.3.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 11 Swamp Workflow Management 2021-09-02 16:18:55 UTC
# maintenance_jira_update_notice
SUSE-SU-2021:2929-1: An update that fixes 31 vulnerabilities is now available.

Category: security (important)
Bug References: 1129714,1172640,1186406,1186583,1186586,1186587,1186596,1186597,1186598,1186600,1186603,1186604,1186605,1186613,1186614,1186615,1186616,1186658,1186660,1186757,1186758,1186762,1186763,1186849,1186859,1186861,1186863,1189142,1189348,1189350
CVE References: CVE-2019-17539,CVE-2019-9721,CVE-2020-13904,CVE-2020-20448,CVE-2020-20451,CVE-2020-21041,CVE-2020-21688,CVE-2020-21697,CVE-2020-22015,CVE-2020-22016,CVE-2020-22017,CVE-2020-22019,CVE-2020-22020,CVE-2020-22021,CVE-2020-22022,CVE-2020-22023,CVE-2020-22025,CVE-2020-22026,CVE-2020-22031,CVE-2020-22032,CVE-2020-22033,CVE-2020-22034,CVE-2020-22038,CVE-2020-22039,CVE-2020-22043,CVE-2020-22044,CVE-2020-22046,CVE-2020-22048,CVE-2020-22049,CVE-2020-22054,CVE-2021-38114
JIRA References: 
Sources used:
SUSE Manager Server 4.0 (src):    ffmpeg-3.4.2-4.34.2
SUSE Manager Retail Branch Server 4.0 (src):    ffmpeg-3.4.2-4.34.2
SUSE Manager Proxy 4.0 (src):    ffmpeg-3.4.2-4.34.2
SUSE Linux Enterprise Server for SAP 15-SP1 (src):    ffmpeg-3.4.2-4.34.2
SUSE Linux Enterprise Server for SAP 15 (src):    ffmpeg-3.4.2-4.34.2
SUSE Linux Enterprise Server 15-SP1-LTSS (src):    ffmpeg-3.4.2-4.34.2
SUSE Linux Enterprise Server 15-SP1-BCL (src):    ffmpeg-3.4.2-4.34.2
SUSE Linux Enterprise Server 15-LTSS (src):    ffmpeg-3.4.2-4.34.2
SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS (src):    ffmpeg-3.4.2-4.34.2
SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS (src):    ffmpeg-3.4.2-4.34.2
SUSE Linux Enterprise High Performance Computing 15-LTSS (src):    ffmpeg-3.4.2-4.34.2
SUSE Linux Enterprise High Performance Computing 15-ESPOS (src):    ffmpeg-3.4.2-4.34.2
SUSE Enterprise Storage 6 (src):    ffmpeg-3.4.2-4.34.2
SUSE CaaS Platform 4.0 (src):    ffmpeg-3.4.2-4.34.2

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.