Bug 1186617 - (CVE-2021-3567) VUL-0: CVE-2021-3567: caribou: segfault could be triggered and used to bypass screen-locking applications that support using Caribou as an input mechanism.
(CVE-2021-3567)
VUL-0: CVE-2021-3567: caribou: segfault could be triggered and used to bypass...
Status: RESOLVED FIXED
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Major
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/300958/
CVSSv3.1:SUSE:CVE-2021-3567:7.5:(AV:N...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2021-05-28 14:24 UTC by Gianluca Gabrielli
Modified: 2021-09-13 10:29 UTC (History)
2 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gianluca Gabrielli 2021-05-28 14:24:33 UTC
It was discovered that the Caribou onscreen keyboard could be made to crash when given certain input values. An attacker could use this to bypass screen-locking applications that support using Caribou as an input mechanism.

Reference:
https://bugs.launchpad.net/ubuntu/+source/caribou/+bug/1912060

References:
https://bugzilla.redhat.com/show_bug.cgi?id=1962836
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2021-3567
Comment 1 Gianluca Gabrielli 2021-05-28 14:25:21 UTC
Affected packages:

 - SUSE:SLE-12-SP2:Update/caribou  0.4.21
 - SUSE:SLE-15-SP2:Update/caribou  0.4.21
 - SUSE:SLE-15:Update/caribou      0.4.21
 - openSUSE:Factory/caribou        0.4.21

Upstream patch: https://gitlab.gnome.org/GNOME/caribou/-/commit/d41c8e44b12222a290eaca16703406b113a630c6.patch
Comment 3 Swamp Workflow Management 2021-06-10 13:36:18 UTC
SUSE-SU-2021:1943-1: An update that fixes one vulnerability is now available.

Category: security (important)
Bug References: 1186617
CVE References: CVE-2021-3567
JIRA References: 
Sources used:
SUSE OpenStack Cloud Crowbar 9 (src):    caribou-0.4.21-8.3.1
SUSE OpenStack Cloud Crowbar 8 (src):    caribou-0.4.21-8.3.1
SUSE OpenStack Cloud 9 (src):    caribou-0.4.21-8.3.1
SUSE OpenStack Cloud 8 (src):    caribou-0.4.21-8.3.1
SUSE Linux Enterprise Workstation Extension 12-SP5 (src):    caribou-0.4.21-8.3.1
SUSE Linux Enterprise Software Development Kit 12-SP5 (src):    caribou-0.4.21-8.3.1
SUSE Linux Enterprise Server for SAP 12-SP4 (src):    caribou-0.4.21-8.3.1
SUSE Linux Enterprise Server for SAP 12-SP3 (src):    caribou-0.4.21-8.3.1
SUSE Linux Enterprise Server 12-SP5 (src):    caribou-0.4.21-8.3.1
SUSE Linux Enterprise Server 12-SP4-LTSS (src):    caribou-0.4.21-8.3.1
SUSE Linux Enterprise Server 12-SP3-LTSS (src):    caribou-0.4.21-8.3.1
SUSE Linux Enterprise Server 12-SP3-BCL (src):    caribou-0.4.21-8.3.1
SUSE Linux Enterprise Server 12-SP2-BCL (src):    caribou-0.4.21-8.3.1
HPE Helion Openstack 8 (src):    caribou-0.4.21-8.3.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 4 Swamp Workflow Management 2021-06-17 19:30:39 UTC
SUSE-SU-2021:2007-1: An update that fixes one vulnerability is now available.

Category: security (important)
Bug References: 1186617
CVE References: CVE-2021-3567
JIRA References: 
Sources used:
SUSE Manager Server 4.0 (src):    caribou-0.4.21-5.3.1
SUSE Manager Retail Branch Server 4.0 (src):    caribou-0.4.21-5.3.1
SUSE Manager Proxy 4.0 (src):    caribou-0.4.21-5.3.1
SUSE Linux Enterprise Server for SAP 15-SP1 (src):    caribou-0.4.21-5.3.1
SUSE Linux Enterprise Server for SAP 15 (src):    caribou-0.4.21-5.3.1
SUSE Linux Enterprise Server 15-SP1-LTSS (src):    caribou-0.4.21-5.3.1
SUSE Linux Enterprise Server 15-SP1-BCL (src):    caribou-0.4.21-5.3.1
SUSE Linux Enterprise Server 15-LTSS (src):    caribou-0.4.21-5.3.1
SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS (src):    caribou-0.4.21-5.3.1
SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS (src):    caribou-0.4.21-5.3.1
SUSE Linux Enterprise High Performance Computing 15-LTSS (src):    caribou-0.4.21-5.3.1
SUSE Linux Enterprise High Performance Computing 15-ESPOS (src):    caribou-0.4.21-5.3.1
SUSE Enterprise Storage 6 (src):    caribou-0.4.21-5.3.1
SUSE CaaS Platform 4.0 (src):    caribou-0.4.21-5.3.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 6 Swamp Workflow Management 2021-07-20 16:26:58 UTC
SUSE-SU-2021:2414-1: An update that solves one vulnerability and has one errata is now available.

Category: security (important)
Bug References: 1186617,1187112
CVE References: CVE-2021-3567
JIRA References: 
Sources used:
SUSE Linux Enterprise Module for Desktop Applications 15-SP3 (src):    caribou-0.4.21-12.5.1
SUSE Linux Enterprise Module for Desktop Applications 15-SP2 (src):    caribou-0.4.21-12.5.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 7 Swamp Workflow Management 2021-07-20 16:44:44 UTC
openSUSE-SU-2021:2414-1: An update that solves one vulnerability and has one errata is now available.

Category: security (important)
Bug References: 1186617,1187112
CVE References: CVE-2021-3567
JIRA References: 
Sources used:
openSUSE Leap 15.3 (src):    caribou-0.4.21-12.5.1
Comment 8 Swamp Workflow Management 2021-07-21 16:17:43 UTC
openSUSE-SU-2021:1071-1: An update that solves one vulnerability and has one errata is now available.

Category: security (important)
Bug References: 1186617,1187112
CVE References: CVE-2021-3567
JIRA References: 
Sources used:
openSUSE Leap 15.2 (src):    caribou-0.4.21-lp152.7.3.1
Comment 9 Marcus Meissner 2021-09-13 10:29:53 UTC
released