Bug 1187471 - Execution failure for “grub2-editenv” (from snapshot 20210615?)
Execution failure for “grub2-editenv” (from snapshot 20210615?)
Status: NEW
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: YaST2
Current
x86-64 openSUSE Tumbleweed
: P2 - High : Major (vote)
: ---
Assigned To: YaST Team
Jiri Srain
https://trello.com/c/kEzHEtVP/
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2021-06-17 15:22 UTC by Markus Elfring
Modified: 2021-07-19 07:51 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
error logs as background information for another questionable software upgrade attempt (760.14 KB, application/x-xz-compressed-tar)
2021-06-18 09:24 UTC, Markus Elfring
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Elfring 2021-06-17 15:22:07 UTC
I came along the need to try another software repair out by the means of the image “openSUSE-Tumbleweed-NET-x86_64-Snapshot20210615-Media.iso”.
(I got encouraged because of information according to the bug report “YaST2 crashes when analyzing fstab files of systems to upgrade with no entries”.
https://bugzilla.opensuse.org/show_bug.cgi?id=1186895#c16)

Thus I started a network installation upgrade attempt in an UEFI mode.

I could configure my software repositories then.
The screen “Installation Settings” was finally presented with the following hint after a promising automatic software package selection.

“…
Booting

Analysing your system…”


The following information was displayed by a dialogue box.
“YaST2

Error

Execution of command "[["/usr/bin/grub2-editenv", "list"]]" failed.
Exit code: 127
Error output: No such file or directory - /usr/bin/grub2-editenv
”


Now I find such details suspicious.
Comment 1 Imobach Gonzalez Sosa 2021-06-18 05:55:33 UTC
Hi Markus,

Josef, please, can you confirm that we need grub2-editenv at installation time? Because it looks like it is missing from the ISO.

Regards,
Imo
Comment 2 Josef Reidinger 2021-06-18 06:14:44 UTC
(In reply to Imobach Gonzalez Sosa from comment #1)
> Hi Markus,
> 
> Josef, please, can you confirm that we need grub2-editenv at installation
> time? Because it looks like it is missing from the ISO.
> 
> Regards,
> Imo

Well, it is used to read default section. We can handle empty one and also it continues if it failed as can be seen at https://github.com/yast/yast-bootloader/blob/d7e49bd5f8c5d2bbe572c1e200167e9e1b7754f2/src/lib/bootloader/sections.rb#L59

I expect issue is that it is not in insts-sys and also that on_target does not have switched SCR. So it should not affect upgrade, it is just error that is shown and continue without default bootloader section.

Possible fix can be to skip reading default section if stage is initial and SCR is not yet switched?
Comment 3 Imobach Gonzalez Sosa 2021-06-18 07:02:39 UTC
Thank you Josef.

I am moving the bug to our queue so we can plan for fixing it. Anyway, Markus, it would be nice if you could share your YaST2 logs anyway.

Regards,
Imo
Comment 4 Lukas Ocilka 2021-06-18 07:22:33 UTC
As far as I see, we have quite some new bugs saying: package needed for YaST <something> not installed and it worked so far. Looks like TW is minimizing their default installation in a way which explores some missing dependencies in inst-sys or YaST deps.
Comment 5 Markus Elfring 2021-06-18 08:25:08 UTC
(In reply to Imobach Gonzalez Sosa from comment #3)
> I am moving the bug to our queue so we can plan for fixing it.

Would it make sense to try this software update any further despite of the mentioned error message dialogues?

Which dependencies will need additional development and system configuration considerations?


> Anyway, Markus, it would be nice if you could share your YaST2 logs anyway.

I have tried again to add a corresponding attachment from within a Knoppix 9.1 session.
But I stumbled on the following information a moment ago.

“Software error:

Malformed multipart POST: data truncated

For help, please send mail to the webmaster (novbugzilla-dev@forge.provo.novell.com), giving this error message and the time and date of the error.
”
Comment 6 Markus Elfring 2021-06-18 09:24:38 UTC
Created attachment 850381 [details]
error logs as background information for another questionable software upgrade attempt

(In reply to comment #5)
Another adjustment for file permissions and the usage of a current browser should help for adding the desired attachment.

How will further software insights evolve?
Comment 7 Markus Elfring 2021-06-25 11:17:18 UTC
(In reply to Lukas Ocilka from comment #4)
In which time range would software corrections be possible for affected issues?
Comment 8 Markus Elfring 2021-07-19 07:51:35 UTC
How did development considerations evolve for desirable fixes according to this bug report?