Bug 1188539 - (CVE-2020-36430) VUL-0: CVE-2020-36430: libass: heap-based buffer overflow in decode_chars
(CVE-2020-36430)
VUL-0: CVE-2020-36430: libass: heap-based buffer overflow in decode_chars
Status: NEW
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Major
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/304602/
CVSSv3.1:SUSE:CVE-2020-36430:7.5:(AV:...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2021-07-21 06:02 UTC by Alexander Bergmann
Modified: 2021-08-21 04:16 UTC (History)
1 user (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Petr Gajdos 2021-08-02 14:21:38 UTC
I consider:
15/libass: affected
12/libass: not affected, expression does not contain subtraction at all
Comment 2 Petr Gajdos 2021-08-02 14:23:01 UTC
Tumbleweed: already fixed by version update
Comment 3 Petr Gajdos 2021-08-02 14:23:31 UTC
Package submitted: 15/libass

I believe all fixed.
Comment 5 Swamp Workflow Management 2021-08-20 13:24:29 UTC
# maintenance_jira_update_notice
openSUSE-SU-2021:2792-1: An update that fixes one vulnerability is now available.

Category: security (important)
Bug References: 1188539
CVE References: CVE-2020-36430
JIRA References: 
Sources used:
openSUSE Leap 15.3 (src):    libass-0.14.0-3.9.1
Comment 6 Swamp Workflow Management 2021-08-20 13:52:51 UTC
# maintenance_jira_update_notice
SUSE-SU-2021:2792-1: An update that fixes one vulnerability is now available.

Category: security (important)
Bug References: 1188539
CVE References: CVE-2020-36430
JIRA References: 
Sources used:
SUSE Manager Server 4.0 (src):    libass-0.14.0-3.9.1
SUSE Manager Retail Branch Server 4.0 (src):    libass-0.14.0-3.9.1
SUSE Manager Proxy 4.0 (src):    libass-0.14.0-3.9.1
SUSE Linux Enterprise Server for SAP 15-SP1 (src):    libass-0.14.0-3.9.1
SUSE Linux Enterprise Server for SAP 15 (src):    libass-0.14.0-3.9.1
SUSE Linux Enterprise Server 15-SP1-LTSS (src):    libass-0.14.0-3.9.1
SUSE Linux Enterprise Server 15-SP1-BCL (src):    libass-0.14.0-3.9.1
SUSE Linux Enterprise Server 15-LTSS (src):    libass-0.14.0-3.9.1
SUSE Linux Enterprise Module for Desktop Applications 15-SP3 (src):    libass-0.14.0-3.9.1
SUSE Linux Enterprise Module for Desktop Applications 15-SP2 (src):    libass-0.14.0-3.9.1
SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS (src):    libass-0.14.0-3.9.1
SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS (src):    libass-0.14.0-3.9.1
SUSE Linux Enterprise High Performance Computing 15-LTSS (src):    libass-0.14.0-3.9.1
SUSE Linux Enterprise High Performance Computing 15-ESPOS (src):    libass-0.14.0-3.9.1
SUSE Enterprise Storage 6 (src):    libass-0.14.0-3.9.1
SUSE CaaS Platform 4.0 (src):    libass-0.14.0-3.9.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 7 Swamp Workflow Management 2021-08-21 04:16:07 UTC
# maintenance_jira_update_notice
openSUSE-SU-2021:1174-1: An update that fixes one vulnerability is now available.

Category: security (important)
Bug References: 1188539
CVE References: CVE-2020-36430
JIRA References: 
Sources used:
openSUSE Leap 15.2 (src):    libass-0.14.0-lp152.4.9.1