Bug 119012 - wrongly generated home directory name prohibits creating new LDAP user
wrongly generated home directory name prohibits creating new LDAP user
Status: VERIFIED FIXED
Classification: openSUSE
Product: SUSE LINUX 10.0
Classification: openSUSE
Component: YaST2
unspecified
Other All
: P5 - None : Normal
: ---
Assigned To: Jiří Suchomel
Klaus Kämpf
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-27 13:50 UTC by Peter Varkoly
Modified: 2005-10-10 14:12 UTC (History)
1 user (show)

See Also:
Found By: Development
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
y2log (22.55 KB, application/octet-stream)
2005-09-27 14:03 UTC, Peter Varkoly
Details
y2log (22.55 KB, application/octet-stream)
2005-09-27 14:05 UTC, Peter Varkoly
Details
patch for /usr/share/YaST2/include/dialogs.ycp (531 bytes, patch)
2005-09-29 09:07 UTC, Jiří Suchomel
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Varkoly 2005-09-27 13:50:07 UTC
There is no possible to add an LDAP-User. An error message occurs:
"The home directory may only contain the following characters:
a-z, A-Z, 0-9, and _-/
Try again."

I've analysed, and yast2 generates a bad home directory:
e.g. : for the user varkoly -> /home/%uid/varkoly

I've configured an SL10 with LDAP backend  on gsx16.suse.de.
Comment 1 Jiří Suchomel 2005-09-27 13:52:07 UTC
attach the logfiles dir, please
Comment 2 Peter Varkoly 2005-09-27 14:03:10 UTC
Created attachment 50938 [details]
y2log
Comment 3 Peter Varkoly 2005-09-27 14:05:01 UTC
Created attachment 50939 [details]
y2log
Comment 4 Jiří Suchomel 2005-09-29 07:24:25 UTC
Ah, I probably broke it with some previous fix. Workaround: if you go to Details
tab from Edit user tab before clicking Accept, it should work.
Comment 5 Jiří Suchomel 2005-09-29 09:07:09 UTC
Created attachment 51127 [details]
patch for /usr/share/YaST2/include/dialogs.ycp

Could you test again with this patch?
Comment 6 Jiří Suchomel 2005-09-29 11:11:19 UTC
What was the result?
Comment 7 Jiří Suchomel 2005-09-29 14:55:07 UTC
Fixed in yast2-users-2.13.2

Andreas, this issue might deserve a YOU patch. The problem is that with default
setting, name of home directory for new LDAP user is (internaly) wrongly
generated and yast2-users complains. It could be worked around (see comment #4),
but it is annoying (as necessary for every user creation).

Generally, LDAP suport is more SLES-feature, but this part (users and groups)
should work correctly also in the box.

Please, comment.
Comment 8 Andreas Jaeger 2005-09-29 15:16:30 UTC
Ok, let's fix it.

SWAMP-ID: Maintenance-Tracker-2417
Comment 9 Jiří Suchomel 2005-09-29 16:27:10 UTC
OK. Now waiting for Peter if he confirmes that new package works.

New package (for 10.0) could be found here:
http://lide.suse.cz/~~jsuchome/yast2/rpms/yast2-users-2.12.9-0.i586.rpm
Comment 10 Peter Varkoly 2005-09-30 06:31:55 UTC
Yes it works :-)))))))))))))
Thanks a lot!
Comment 11 Anja Stock 2005-10-10 14:09:41 UTC
released