Bug 1190702 - (CVE-2021-36160) VUL-0: CVE-2021-36160: apache2: httpd: mod_proxy_uwsgi: out-of-bounds read via a crafted request uri-path
(CVE-2021-36160)
VUL-0: CVE-2021-36160: apache2: httpd: mod_proxy_uwsgi: out-of-bounds read vi...
Status: NEW
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Major
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/310292/
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2021-09-21 10:38 UTC by Gabriele Sonnu
Modified: 2022-01-05 12:35 UTC (History)
1 user (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Petr Gajdos 2021-09-22 07:25:47 UTC
Taking
https://github.com/apache/httpd/commit/6d9672bf096592fe16c1840f73fa947fd458ee68

mod_proxy_uwsgi is in 15sp2 and 15.
Comment 2 Petr Gajdos 2021-09-22 08:27:48 UTC
Will submit for 15sp2,15/apache2.
Comment 3 Petr Gajdos 2021-09-22 12:07:45 UTC
Packages submitted.

I believe all fixed.
Comment 6 Swamp Workflow Management 2021-10-12 10:17:32 UTC
SUSE-SU-2021:3335-1: An update that fixes 5 vulnerabilities is now available.

Category: security (important)
Bug References: 1189387,1190666,1190669,1190702,1190703
CVE References: CVE-2021-33193,CVE-2021-34798,CVE-2021-36160,CVE-2021-39275,CVE-2021-40438
JIRA References: 
Sources used:
SUSE Linux Enterprise Server for SAP 15-SP1 (src):    apache2-2.4.33-3.55.1
SUSE Linux Enterprise Server for SAP 15 (src):    apache2-2.4.33-3.55.1
SUSE Linux Enterprise Server 15-SP1-LTSS (src):    apache2-2.4.33-3.55.1
SUSE Linux Enterprise Server 15-SP1-BCL (src):    apache2-2.4.33-3.55.1
SUSE Linux Enterprise Server 15-LTSS (src):    apache2-2.4.33-3.55.1
SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS (src):    apache2-2.4.33-3.55.1
SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS (src):    apache2-2.4.33-3.55.1
SUSE Linux Enterprise High Performance Computing 15-LTSS (src):    apache2-2.4.33-3.55.1
SUSE Linux Enterprise High Performance Computing 15-ESPOS (src):    apache2-2.4.33-3.55.1
SUSE Enterprise Storage 6 (src):    apache2-2.4.33-3.55.1
SUSE CaaS Platform 4.0 (src):    apache2-2.4.33-3.55.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 8 Swamp Workflow Management 2021-10-26 19:17:45 UTC
SUSE-SU-2021:3522-1: An update that fixes four vulnerabilities is now available.

Category: security (important)
Bug References: 1190666,1190669,1190702,1190703
CVE References: CVE-2021-34798,CVE-2021-36160,CVE-2021-39275,CVE-2021-40438
JIRA References: 
Sources used:
SUSE Linux Enterprise Module for Server Applications 15-SP3 (src):    apache2-2.4.43-3.32.1
SUSE Linux Enterprise Module for Server Applications 15-SP2 (src):    apache2-2.4.43-3.32.1
SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP3 (src):    apache2-2.4.43-3.32.1
SUSE Linux Enterprise Module for Basesystem 15-SP3 (src):    apache2-2.4.43-3.32.1
SUSE Linux Enterprise Module for Basesystem 15-SP2 (src):    apache2-2.4.43-3.32.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 9 Swamp Workflow Management 2021-10-26 19:20:41 UTC
openSUSE-SU-2021:3522-1: An update that fixes four vulnerabilities is now available.

Category: security (important)
Bug References: 1190666,1190669,1190702,1190703
CVE References: CVE-2021-34798,CVE-2021-36160,CVE-2021-39275,CVE-2021-40438
JIRA References: 
Sources used:
openSUSE Leap 15.3 (src):    apache2-2.4.43-3.32.1
Comment 10 Swamp Workflow Management 2021-11-02 17:29:24 UTC
openSUSE-SU-2021:1438-1: An update that fixes four vulnerabilities is now available.

Category: security (important)
Bug References: 1190666,1190669,1190702,1190703
CVE References: CVE-2021-34798,CVE-2021-36160,CVE-2021-39275,CVE-2021-40438
JIRA References: 
Sources used:
openSUSE Leap 15.2 (src):    apache2-2.4.43-lp152.2.21.1