Bug 1190836 - ERROR:gpu_process_host.cc(1007)] GPU process exited unexpectedly: exit_code=159
ERROR:gpu_process_host.cc(1007)] GPU process exited unexpectedly: exit_code=159
Status: RESOLVED DUPLICATE of bug 1191012
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: X11 3rd Party Driver
Current
Other Other
: P3 - Medium : Normal (vote)
: ---
Assigned To: Gfx Bugs
Stefan Dirsch
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2021-09-23 21:56 UTC by Dev Guy
Modified: 2021-10-18 00:26 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dev Guy 2021-09-23 21:56:31 UTC
I just upgraded my openSUSE TW and now it's causing a crash when I try to open VS Code insider. I believe the NVidia driver was updated and something is broken?

How can I go rollback to the previous version of NVidia driver and also prevent auto updates for the NVidia drive in the future.

$ ./code-insiders --version
[5882:0923/174830.587797:ERROR:gpu_process_host.cc(1007)] GPU process exited unexpectedly: exit_code=159
[5882:0923/174830.654426:ERROR:gpu_process_host.cc(1007)] GPU process exited unexpectedly: exit_code=159
[main 2021-09-23T21:48:30.677Z] update#setState idle
[main 2021-09-23T21:48:30.679Z] update#ctor - manual checks only; automatic updates are disabled by user preference
[5882:0923/174830.756158:ERROR:gpu_process_host.cc(1007)] GPU process exited unexpectedly: exit_code=159
[6020:0923/174830.765692:ERROR:gpu_init.cc(440)] Passthrough is not supported, GL is swiftshader
[5882:0923/174830.771912:ERROR:gpu_process_host.cc(1007)] GPU process exited unexpectedly: exit_code=159
[6055:0923/174830.779615:ERROR:gpu_init.cc(440)] Passthrough is not supported, GL is swiftshader
[5882:0923/174830.785887:ERROR:gpu_process_host.cc(1007)] GPU process exited unexpectedly: exit_code=159
[6085:0923/174830.792524:ERROR:gpu_init.cc(440)] Passthrough is not supported, GL is swiftshader
[5882:0923/174830.799001:ERROR:gpu_process_host.cc(1007)] GPU process exited unexpectedly: exit_code=159
[6111:0923/174830.801715:ERROR:gpu_init.cc(440)] Passthrough is not supported, GL is disabled
[5882:0923/174830.804810:ERROR:gpu_process_host.cc(1007)] GPU process exited unexpectedly: exit_code=159
[6124:0923/174830.807536:ERROR:gpu_init.cc(440)] Passthrough is not supported, GL is disabled
[5882:0923/174830.810060:ERROR:gpu_process_host.cc(1007)] GPU process exited unexpectedly: exit_code=159
[6133:0923/174830.812585:ERROR:gpu_init.cc(440)] Passthrough is not supported, GL is disabled
[5882:0923/174830.815218:ERROR:gpu_process_host.cc(1007)] GPU process exited unexpectedly: exit_code=159
[5882:0923/174830.815233:FATAL:gpu_data_manager_impl_private.cc(415)] GPU process isn't usable. Goodbye.
Server response: 
Server response: 
Illegal instruction (core dumped)


System Info:

Operating System: openSUSE Tumbleweed 20210921
KDE Plasma Version: 5.22.5
KDE Frameworks Version: 5.86.0
Qt Version: 5.15.2
Kernel Version: 5.14.5-1-default (64-bit)
Graphics Platform: X11
Processors: 16 × AMD Ryzen 7 2700X Eight-Core Processor
Memory: 62.7 GiB of RAM
Graphics Processor: NVIDIA GeForce RTX 3080/PCIe/SSE2
Comment 1 Dev Guy 2021-09-23 22:11:58 UTC
This bug seem to already have been reported and can be closed off here, nothing to do with the package of the NVidia driver.

https://github.com/microsoft/vscode/issues/133593

Temp workaround if anyone stumbles here that works for me: 

./code-insiders --no-sandbox
Comment 2 Chenzi Cao 2021-09-30 11:46:50 UTC
Based on the comment above, I close this bug report now, please feel free to reopen it whenever necessary, thanks.
Comment 3 Dev Guy 2021-10-02 11:40:59 UTC
I am noticing a few other crashes after the NVidia driver update.

Discord no longer opens, it crashes all the time and the window never opens.

I am also seeing kwin crashing. What happen is all the windows on my desktop disappear and I believe my screen will go black before everything reappears quickly. It happens really quick and I've noticed it happen to me 2 times. 

Then a popup alert shows up at the bottom-right, saying "kwin crashed unexpectedly", not sure if it say "kwin" or some other process that is responsible I guess for rendering/managing all the windows.

I figured I report this here, as it seem related to the latest NVidia driver update.
Comment 4 Stefan Dirsch 2021-10-17 17:17:53 UTC
Closing the initial issue as duplicate.  Things from comment #3 should be reported separately. Thanks.

*** This bug has been marked as a duplicate of bug 1191012 ***
Comment 5 Dev Guy 2021-10-17 20:27:16 UTC
FYI Any electron based app that is crashing due to the GPU bug can be started with the following flag, "-in-process-gpu".
Comment 6 Stefan Dirsch 2021-10-17 21:12:05 UTC
Thanks, interesting!
Comment 7 Dev Guy 2021-10-18 00:26:00 UTC
Made a typo in comment 5, should have 2 dashes, "--in-process-gpu"