Bug 1191204 - (CVE-2021-37974) VUL-0: chromium: multiple security issues fixed in 94.0.4606.71
(CVE-2021-37974)
VUL-0: chromium: multiple security issues fixed in 94.0.4606.71
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Security
Leap 15.3
Other Other
: P3 - Medium : Normal (vote)
: ---
Assigned To: Callum Farmer
E-mail List
:
Depends on:
Blocks: CVE-2021-37973
  Show dependency treegraph
 
Reported: 2021-10-01 05:39 UTC by Gianluca Gabrielli
Modified: 2021-10-30 19:19 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gianluca Gabrielli 2021-10-01 05:39:14 UTC
The Stable channel has been updated to 94.0.4606.71 for Windows, Mac and Linux which will roll out over the coming days/weeks. Extended stable channel has also been updated to 94.0.4606.71 for Windows and Mac which will roll out over the coming days/weeks

A full list of changes in this build is available in the log. Interested in switching release channels? Find out how here. If you find a new issue, please let us know by filing a bug. The community help forum is also a great place to reach out for help or learn about common issues.

Security Fixes and Rewards

Note: Access to bug details and links may be kept restricted until a majority of users are updated with a fix. We will also retain restrictions if the bug exists in a third party library that other projects similarly depend on, but haven’t yet fixed.

This update includes 4 security fixes. Below, we highlight fixes that were contributed by external researchers. Please see the Chrome Security Page for more information.

[$20000][1245578] High CVE-2021-37974 : Use after free in Safe Browsing. Reported by Weipeng Jiang (@Krace) from Codesafe Team of Legendsec at Qi'anxin Group on 2021-09-01

[$TBD][1252918] High CVE-2021-37975 : Use after free in V8. Reported by Anonymous on 2021-09-24

[$NA][1251787] Medium CVE-2021-37976 : Information leak in core. Reported by Clément Lecigne from Google TAG, with technical assistance from Sergei Glazunov and Mark Brand from Google Project Zero on 2021-09-21

We would also like to thank all security researchers that worked with us during the development cycle to prevent security bugs from ever reaching the stable channel.

Google is aware the exploits for CVE-2021-37975 and CVE-2021-37976 exist in the wild. 

As usual, our ongoing internal security work was responsible for a wide range of fixes:

    [1254756] Various fixes from internal audits, fuzzing and other initiatives

Many of our security bugs are detected using AddressSanitizer, MemorySanitizer, UndefinedBehaviorSanitizer, Control Flow Integrity, libFuzzer, or AFL.

Interested in switching release channels?  Find out how here. If you find a new issue, please let us know by filing a bug. The community help forum is also a great place to reach out for help or learn about common issues.
Comment 1 OBSbugzilla Bot 2021-10-03 12:40:15 UTC
This is an autogenerated message for OBS integration:
This bug (1191204) was mentioned in
https://build.opensuse.org/request/show/922843 Backports:SLE-15-SP3 / chromium
Comment 2 OBSbugzilla Bot 2021-10-03 14:50:14 UTC
This is an autogenerated message for OBS integration:
This bug (1191204) was mentioned in
https://build.opensuse.org/request/show/922846 15.2 / chromium
https://build.opensuse.org/request/show/922848 Backports:SLE-15-SP3 / chromium
Comment 3 OBSbugzilla Bot 2021-10-08 20:40:17 UTC
This is an autogenerated message for OBS integration:
This bug (1191204) was mentioned in
https://build.opensuse.org/request/show/924282 15.2 / chromium
https://build.opensuse.org/request/show/924283 Backports:SLE-15-SP3 / chromium
Comment 4 OBSbugzilla Bot 2021-10-09 20:40:15 UTC
This is an autogenerated message for OBS integration:
This bug (1191204) was mentioned in
https://build.opensuse.org/request/show/924489 15.2 / chromium
https://build.opensuse.org/request/show/924490 Backports:SLE-15-SP3 / chromium
Comment 5 Swamp Workflow Management 2021-10-11 13:16:32 UTC
openSUSE-SU-2021:1339-1: An update that fixes 21 vulnerabilities is now available.

Category: security (important)
Bug References: 1190765,1191166,1191204
CVE References: CVE-2021-37956,CVE-2021-37957,CVE-2021-37958,CVE-2021-37959,CVE-2021-37960,CVE-2021-37961,CVE-2021-37962,CVE-2021-37963,CVE-2021-37964,CVE-2021-37965,CVE-2021-37966,CVE-2021-37967,CVE-2021-37968,CVE-2021-37969,CVE-2021-37970,CVE-2021-37971,CVE-2021-37972,CVE-2021-37973,CVE-2021-37974,CVE-2021-37975,CVE-2021-37976
JIRA References: 
Sources used:
openSUSE Backports SLE-15-SP3 (src):    chromium-94.0.4606.71-bp153.2.31.1
Comment 6 Swamp Workflow Management 2021-10-12 13:59:08 UTC
openSUSE-SU-2021:1350-1: An update that fixes 25 vulnerabilities is now available.

Category: security (important)
Bug References: 1190765,1191166,1191204,1191463
CVE References: CVE-2021-37956,CVE-2021-37957,CVE-2021-37958,CVE-2021-37959,CVE-2021-37960,CVE-2021-37961,CVE-2021-37962,CVE-2021-37963,CVE-2021-37964,CVE-2021-37965,CVE-2021-37966,CVE-2021-37967,CVE-2021-37968,CVE-2021-37969,CVE-2021-37970,CVE-2021-37971,CVE-2021-37972,CVE-2021-37973,CVE-2021-37974,CVE-2021-37975,CVE-2021-37976,CVE-2021-37977,CVE-2021-37978,CVE-2021-37979,CVE-2021-37980
JIRA References: 
Sources used:
openSUSE Leap 15.2 (src):    chromium-94.0.4606.81-lp152.2.132.1
Comment 7 Callum Farmer 2021-10-30 19:19:43 UTC
done