Bug 1192498 - (CVE-2021-3933) VUL-0: CVE-2021-3933: OpenEXR,openexr: Integer-overflow in Imf_3_1:bytesPerDeepLineTable
(CVE-2021-3933)
VUL-0: CVE-2021-3933: OpenEXR,openexr: Integer-overflow in Imf_3_1:bytesPerDe...
Status: NEW
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Normal
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/314444/
CVSSv3.1:SUSE:CVE-2021-3933:5.5:(AV:L...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2021-11-09 08:25 UTC by Carlos López
Modified: 2021-12-06 17:22 UTC (History)
1 user (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos López 2021-11-09 08:25:23 UTC
rh#2019783

A vulnerability was found in openexr where an Integer-overflow was found in Imf_3_1::bytesPerDeepLineTable.

References:
https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=38912
https://bugzilla.redhat.com/show_bug.cgi?id=2019783
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2021-3933
Comment 1 Carlos López 2021-11-09 08:25:55 UTC
Affected codestreams:
 - SUSE:SLE-12:Update
 - SUSE:SLE-15:Update

Also affected on openSUSE:
 - openSUSE:Leap:15.2:Update
 - openSUSE:Factory
Comment 3 Petr Gajdos 2021-11-09 12:38:42 UTC
Submitted into TW,15,12/openexr.

(In reply to Carlos López from comment #1)
>  - openSUSE:Leap:15.2:Update

This is inherited from SLE-15, right? In other way, let me know.

I believe all fixed.
Comment 4 Carlos López 2021-11-09 14:19:50 UTC
I believe you are correct, thanks
Comment 9 Swamp Workflow Management 2021-12-01 20:36:28 UTC
SUSE-SU-2021:3843-1: An update that fixes three vulnerabilities is now available.

Category: security (moderate)
Bug References: 1184353,1192498,1192556
CVE References: CVE-2021-3477,CVE-2021-3933,CVE-2021-3941
JIRA References: 
Sources used:
SUSE Linux Enterprise Workstation Extension 12-SP5 (src):    openexr-2.1.0-6.42.1
SUSE Linux Enterprise Software Development Kit 12-SP5 (src):    openexr-2.1.0-6.42.1
SUSE Linux Enterprise Server 12-SP5 (src):    openexr-2.1.0-6.42.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 10 Swamp Workflow Management 2021-12-01 20:42:52 UTC
openSUSE-SU-2021:3844-1: An update that fixes two vulnerabilities is now available.

Category: security (moderate)
Bug References: 1192498,1192556
CVE References: CVE-2021-3933,CVE-2021-3941
JIRA References: 
Sources used:
openSUSE Leap 15.3 (src):    openexr-2.2.1-3.38.1
Comment 11 Swamp Workflow Management 2021-12-01 21:19:07 UTC
SUSE-SU-2021:3844-1: An update that fixes two vulnerabilities is now available.

Category: security (moderate)
Bug References: 1192498,1192556
CVE References: CVE-2021-3933,CVE-2021-3941
JIRA References: 
Sources used:
SUSE Linux Enterprise Module for Desktop Applications 15-SP3 (src):    openexr-2.2.1-3.38.1
SUSE Linux Enterprise Module for Desktop Applications 15-SP2 (src):    openexr-2.2.1-3.38.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 12 Swamp Workflow Management 2021-12-06 17:22:35 UTC
openSUSE-SU-2021:1537-1: An update that fixes two vulnerabilities is now available.

Category: security (moderate)
Bug References: 1192498,1192556
CVE References: CVE-2021-3933,CVE-2021-3941
JIRA References: 
Sources used:
openSUSE Leap 15.2 (src):    openexr-2.2.1-lp152.7.23.1