Bug 1193679 - (CVE-2020-28948) VUL-0: CVE-2020-28948: php5,php7,php72,php74,php53: Archive_Tar: allows an unserialization attack because phar: is blocked but PHAR: is not blocked
(CVE-2020-28948)
VUL-0: CVE-2020-28948: php5,php7,php72,php74,php53: Archive_Tar: allows an un...
Status: RESOLVED INVALID
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P5 - None : Normal
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/272078/
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2021-12-13 14:31 UTC by Gabriele Sonnu
Modified: 2021-12-13 14:32 UTC (History)
1 user (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gabriele Sonnu 2021-12-13 14:31:08 UTC
rh#1904001

Archive_Tar through 1.4.10 allows an unserialization attack because phar: is blocked but PHAR: is not blocked.

https://github.com/pear/Archive_Tar/issues/33
https://lists.debian.org/debian-lts-announce/2020/11/msg00045.html
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/4V35LBRM6HBCXBVCITKQ4UEBTXO2EG7B/
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/NBYZSHYTIOBK6V7C4N7TP6KIKCRKLVWP/

References:
https://bugzilla.redhat.com/show_bug.cgi?id=1904001
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2020-28948
https://www.debian.org/security/2020/dsa-4817
http://www.debian.org/security/-1/dsa-4817
https://access.redhat.com/security/cve/CVE-2020-28948
http://www.cvedetails.com/cve/CVE-2020-28948/
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-28948
https://github.com/pear/Archive_Tar/issues/33
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/KWM4CTMEGAC4I2CHYNJVSROY4CVXVEUT/
https://www.drupal.org/sa-core-2020-013
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/5KSFM672XW3X6BR7TVKRD63SLZGKK437/
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=976108
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/NBYZSHYTIOBK6V7C4N7TP6KIKCRKLVWP/
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/4V35LBRM6HBCXBVCITKQ4UEBTXO2EG7B/
https://security.gentoo.org/glsa/202101-23
https://lists.debian.org/debian-lts-announce/2020/11/msg00045.html
Comment 1 Gabriele Sonnu 2021-12-13 14:31:45 UTC
Not affected, closing.