Bug 1194352 - Inoptimal behaviors when trying to 1-click install while other YaST processes are open.
Inoptimal behaviors when trying to 1-click install while other YaST processes...
Status: RESOLVED DUPLICATE of bug 980292
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: YaST2
Current
x86-64 openSUSE Tumbleweed
: P5 - None : Minor (vote)
: ---
Assigned To: E-mail List
Jiri Srain
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2022-01-05 21:36 UTC by Gere Banok
Modified: 2022-01-08 12:09 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gere Banok 2022-01-05 21:36:51 UTC
For example, trying to setup a .yml 1-click install of a meta-package which includes repository changes while having another YaST2 process open such as Software Management, will result in an error dialog in the secondary 1-click install window "Perform Installation".

An error occurred while initializing the software repository.
Details:
http-download.opensuse.org-6518b9c8: [http-download.opensuse.org-6518b9c8|http://download.opensuse.org/tumbleweed/repo/oss/] Valid metadata not found at specified URL
History:
 - Unknown error reading from 'http://download.opensuse.org/tumbleweed/repo/oss/'
 - System management is locked by the application with pid 2818 (/usr/bin/ruby.ruby2.7).
Close this application before trying again.

Try again?

It gives buttons YES and NO

Clicking Yes, does apparently not try again, it brings up a new dialog about "Server & Directory" which gives an empty texbox for "Repository Name", and a populated texbox for "URL of the Repository"

It gives buttons OK and CANCEL

Clicking Cancel (not changing anything), brings up another dialog with an error message:

An error occurred while initializing the software repository.
Details:
Url scheme is a required component
Try again?

It gives buttons YES and NO

Clicking Yes, does apparently not try again (but takes a short moment), it brings up ontop a new and similar but different dialog to enter "Repository Name" and (just) "URL", without the radio buttons to edit the whole or parts of the URL and the dialog is titled "Repository URL" and not "Server & Directory". Is this intended, what's the difference? I am . All of the textboxes are empty, so it does not reference the default URL it referenced from the earlier similar dialog. 

Trying to Click OK correctly states shows a smaller dialog ontop that "URL cannot be empty" and provides an OK button.

Clicking Cancel simply closes this "Repository URL" dialog and waits in the previous dialo

Clicking No here, correctly proceeds to the next step, in this case there is another different repository URL which it also expectedly fails.

----

Perhaps it should actually try again when answering to the question in affirmative, and another button could offer to edit the URL and let it go into that loop in a different way, perhaps after failing the second or third time. And then there is the use of a different (lesser featured) dialog for subsequent fails.

On a larger note, funamentally if it does detect another YaST2 process is indeed running perhaps the error message and dialog procedure could be a bit different in such a case, so that the simplest error to fix, closing another runnign process, is mentioned first in the error message, before going into the edit URL dialogs at all. Or rather that the check for another process happens much earlier, before even starting the "Perform Installation" window and the Loading ... steps it does for a while before these dialogs come up.

However this is a minor thing as the primary error message does indeed include the relevant information about the running process and I did eventually read it in full and solved the issue, but since I'm currently totally new to OpenSUSE (and Linux distros for 24/7 usage in general) I thought to take this simple example to register and write my first (possible) bug report with, while trying to learn the proper way first without finding excuses for purely convenience fixes ofcourse.
Comment 1 Ladislav Slezák 2022-01-07 09:01:24 UTC
(In reply to Gere Banok from comment #0)

> On a larger note, funamentally if it does detect another YaST2 process is
> indeed running perhaps the error message and dialog procedure could be a bit
> different in such a case, so that the simplest error to fix, closing another
> runnign process

Actually it is a bit more complex. The package manager might be locked not by YaST but by some other application (usually it is PackageKit, but it might be zypper or something else) or even by some other user.

Closing another process is problematic, what if it is just installing 5th package out of 10? Killing it and installing just half of the packages would not be nice. So we leave this up to the user to resolve the problem correctly.


> I thought to take this simple example to register and write my first
> (possible) bug report with, while trying to learn the proper way first
> without finding excuses for purely convenience fixes of course.

Great! Thank you for the report!


Actually the problem with running multiple YaST instances has been already reported in bug #980292 so I'm closing this as a duplicate.

*** This bug has been marked as a duplicate of bug 980292 ***
Comment 2 Gere Banok 2022-01-08 12:09:33 UTC
Ah allright, that's probably better. 

Tho I apologize if it sounded that way, I must have not explained it clearer, I agree that it shouldn't kill the offending process automatically.