Bug 1194568 - (CVE-2021-4034) VUL-0: CVE-2021-4034: polkit: pkexec Local Privilege Escalation aka pwnkit
(CVE-2021-4034)
VUL-0: CVE-2021-4034: polkit: pkexec Local Privilege Escalation aka pwnkit
Status: RESOLVED FIXED
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Major
: ---
Assigned To: Marcus Meissner
Security Team bot
https://smash.suse.de/issue/320163/
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2022-01-12 06:56 UTC by Alexander Bergmann
Modified: 2022-01-26 11:20 UTC (History)
6 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Comment 5 Marcus Meissner 2022-01-13 09:55:50 UTC
i also screened the old PolicyKit in SLE11, all its binaries check argc count explicitly.

=> not affected
Comment 8 OBSbugzilla Bot 2022-01-25 18:50:03 UTC
This is an autogenerated message for OBS integration:
This bug (1194568) was mentioned in
https://build.opensuse.org/request/show/949109 Factory / polkit
Comment 9 Swamp Workflow Management 2022-01-25 23:18:12 UTC
SUSE-SU-2022:0189-1: An update that fixes one vulnerability is now available.

Category: security (important)
Bug References: 1194568
CVE References: CVE-2021-4034
JIRA References: 
Sources used:
SUSE OpenStack Cloud Crowbar 9 (src):    polkit-0.113-5.24.1
SUSE OpenStack Cloud Crowbar 8 (src):    polkit-0.113-5.24.1
SUSE OpenStack Cloud 9 (src):    polkit-0.113-5.24.1
SUSE OpenStack Cloud 8 (src):    polkit-0.113-5.24.1
SUSE Linux Enterprise Workstation Extension 12-SP5 (src):    polkit-0.113-5.24.1
SUSE Linux Enterprise Software Development Kit 12-SP5 (src):    polkit-0.113-5.24.1
SUSE Linux Enterprise Server for SAP 12-SP4 (src):    polkit-0.113-5.24.1
SUSE Linux Enterprise Server for SAP 12-SP3 (src):    polkit-0.113-5.24.1
SUSE Linux Enterprise Server 12-SP5 (src):    polkit-0.113-5.24.1
SUSE Linux Enterprise Server 12-SP4-LTSS (src):    polkit-0.113-5.24.1
SUSE Linux Enterprise Server 12-SP3-LTSS (src):    polkit-0.113-5.24.1
SUSE Linux Enterprise Server 12-SP3-BCL (src):    polkit-0.113-5.24.1
SUSE Linux Enterprise Server 12-SP2-BCL (src):    polkit-0.113-5.24.1
HPE Helion Openstack 8 (src):    polkit-0.113-5.24.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 10 Swamp Workflow Management 2022-01-25 23:21:56 UTC
SUSE-SU-2022:0191-1: An update that fixes one vulnerability is now available.

Category: security (important)
Bug References: 1194568
CVE References: CVE-2021-4034
JIRA References: 
Sources used:
SUSE Linux Enterprise Server for SAP 15-SP1 (src):    polkit-0.114-3.15.1
SUSE Linux Enterprise Server for SAP 15 (src):    polkit-0.114-3.15.1
SUSE Linux Enterprise Server 15-SP1-LTSS (src):    polkit-0.114-3.15.1
SUSE Linux Enterprise Server 15-SP1-BCL (src):    polkit-0.114-3.15.1
SUSE Linux Enterprise Server 15-LTSS (src):    polkit-0.114-3.15.1
SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS (src):    polkit-0.114-3.15.1
SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS (src):    polkit-0.114-3.15.1
SUSE Linux Enterprise High Performance Computing 15-LTSS (src):    polkit-0.114-3.15.1
SUSE Linux Enterprise High Performance Computing 15-ESPOS (src):    polkit-0.114-3.15.1
SUSE Enterprise Storage 6 (src):    polkit-0.114-3.15.1
SUSE CaaS Platform 4.0 (src):    polkit-0.114-3.15.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 11 Swamp Workflow Management 2022-01-25 23:31:01 UTC
SUSE-SU-2022:0190-1: An update that fixes one vulnerability is now available.

Category: security (important)
Bug References: 1194568
CVE References: CVE-2021-4034
JIRA References: 
Sources used:
SUSE MicroOS 5.1 (src):    polkit-0.116-3.6.1
SUSE MicroOS 5.0 (src):    polkit-0.116-3.6.1
SUSE Manager Server 4.1 (src):    polkit-0.116-3.6.1
SUSE Manager Retail Branch Server 4.1 (src):    polkit-0.116-3.6.1
SUSE Manager Proxy 4.1 (src):    polkit-0.116-3.6.1
SUSE Linux Enterprise Server for SAP 15-SP2 (src):    polkit-0.116-3.6.1
SUSE Linux Enterprise Server 15-SP2-LTSS (src):    polkit-0.116-3.6.1
SUSE Linux Enterprise Server 15-SP2-BCL (src):    polkit-0.116-3.6.1
SUSE Linux Enterprise Module for Basesystem 15-SP3 (src):    polkit-0.116-3.6.1
SUSE Linux Enterprise High Performance Computing 15-SP2-LTSS (src):    polkit-0.116-3.6.1
SUSE Linux Enterprise High Performance Computing 15-SP2-ESPOS (src):    polkit-0.116-3.6.1
SUSE Enterprise Storage 7 (src):    polkit-0.116-3.6.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 12 Swamp Workflow Management 2022-01-25 23:35:12 UTC
openSUSE-SU-2022:0190-1: An update that fixes one vulnerability is now available.

Category: security (important)
Bug References: 1194568
CVE References: CVE-2021-4034
JIRA References: 
Sources used:
openSUSE Leap 15.3 (src):    polkit-0.116-3.6.1
Comment 13 Marcus Meissner 2022-01-26 09:09:19 UTC
tumbleweed submission is in flight. everything else is done.
Comment 14 Michael Brookhuis 2022-01-26 09:32:59 UTC
https://www.suse.com/support/kb/doc/?id=000020564
Comment 15 OBSbugzilla Bot 2022-01-26 11:20:03 UTC
This is an autogenerated message for OBS integration:
This bug (1194568) was mentioned in
https://build.opensuse.org/request/show/949226 Factory / polkit