Bug 1194770 - (CVE-2022-23218) VUL-0: CVE-2022-23218: glibc.i686,glibc: stack buffer overflow in the deprecated function svcunix_create in the sunrpc module
(CVE-2022-23218)
VUL-0: CVE-2022-23218: glibc.i686,glibc: stack buffer overflow in the depreca...
Status: RESOLVED FIXED
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Normal
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/320464/
CVSSv3.1:SUSE:CVE-2022-23218:5.3:(AV:...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2022-01-17 12:05 UTC by Carlos López
Modified: 2022-03-21 15:31 UTC (History)
3 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos López 2022-01-17 12:05:19 UTC
CVE-2022-23218

The deprecated compatibility function svcunix_create in the sunrpc module of the
GNU C Library (aka glibc) through 2.34 copies its path argument on the stack
without validating its length, which may result in a buffer overflow,
potentially resulting in a denial of service or (if an application is not built
with a stack protector enabled) arbitrary code execution.

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2022-23218
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-23218
https://sourceware.org/bugzilla/show_bug.cgi?id=28768
Comment 1 Carlos López 2022-01-17 12:06:21 UTC
Affected:
 - SUSE:SLE-11-SP1:Update/glibc
 - SUSE:SLE-11-SP3:Update/glibc
 - SUSE:SLE-12-SP2:Update/glibc
 - SUSE:SLE-12-SP4:Update/glibc
 - SUSE:SLE-15:Update/glibc
 - SUSE:SLE-15-SP3:Update/glibc
 - openSUSE:Factory/glibc
 - SUSE:SLE-11-SP1:Update/glibc.i686
 - SUSE:SLE-11-SP3:Update/glibc.i686
 - SUSE:SLE-12-SP2:Update/glibc.i686
 - SUSE:SLE-12-SP4:Update/glibc.i686
Comment 5 Swamp Workflow Management 2022-02-04 14:27:11 UTC
openSUSE-SU-2022:0330-1: An update that solves three vulnerabilities, contains one feature and has one errata is now available.

Category: security (important)
Bug References: 1194640,1194768,1194770,1194785
CVE References: CVE-2021-3999,CVE-2022-23218,CVE-2022-23219
JIRA References: SLE-18195
Sources used:
openSUSE Leap 15.4 (src):    glibc-2.31-150300.9.12.1, glibc-utils-src-2.31-150300.9.12.1
openSUSE Leap 15.3 (src):    glibc-2.31-150300.9.12.1, glibc-utils-src-2.31-150300.9.12.1
Comment 6 Swamp Workflow Management 2022-02-04 14:30:01 UTC
SUSE-SU-2022:0330-1: An update that solves three vulnerabilities, contains one feature and has one errata is now available.

Category: security (important)
Bug References: 1194640,1194768,1194770,1194785
CVE References: CVE-2021-3999,CVE-2022-23218,CVE-2022-23219
JIRA References: SLE-18195
Sources used:
SUSE Linux Enterprise Module for Development Tools 15-SP4 (src):    glibc-2.31-150300.9.12.1, glibc-utils-src-2.31-150300.9.12.1
SUSE Linux Enterprise Module for Development Tools 15-SP3 (src):    glibc-2.31-150300.9.12.1, glibc-utils-src-2.31-150300.9.12.1
SUSE Linux Enterprise Module for Basesystem 15-SP4 (src):    glibc-2.31-150300.9.12.1
SUSE Linux Enterprise Module for Basesystem 15-SP3 (src):    glibc-2.31-150300.9.12.1
SUSE Linux Enterprise Micro 5.1 (src):    glibc-2.31-150300.9.12.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 7 Swamp Workflow Management 2022-02-16 17:20:54 UTC
SUSE-SU-2022:0441-1: An update that solves three vulnerabilities and has three fixes is now available.

Category: security (important)
Bug References: 1191835,1192620,1193478,1194640,1194768,1194770
CVE References: CVE-2021-3999,CVE-2022-23218,CVE-2022-23219
JIRA References: 
Sources used:
SUSE OpenStack Cloud Crowbar 9 (src):    glibc-2.22-114.19.1
SUSE OpenStack Cloud 9 (src):    glibc-2.22-114.19.1
SUSE Linux Enterprise Software Development Kit 12-SP5 (src):    glibc-2.22-114.19.1
SUSE Linux Enterprise Server for SAP 12-SP4 (src):    glibc-2.22-114.19.1
SUSE Linux Enterprise Server 12-SP5 (src):    glibc-2.22-114.19.1
SUSE Linux Enterprise Server 12-SP4-LTSS (src):    glibc-2.22-114.19.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 11 Swamp Workflow Management 2022-03-14 20:22:19 UTC
SUSE-SU-2022:0832-1: An update that solves four vulnerabilities and has one errata is now available.

Category: security (important)
Bug References: 1193625,1194640,1194768,1194770,1195560
CVE References: CVE-2015-8985,CVE-2021-3999,CVE-2022-23218,CVE-2022-23219
JIRA References: 
Sources used:
SUSE Manager Server 4.1 (src):    glibc-2.26-13.65.1, glibc-utils-src-2.26-13.65.1
SUSE Manager Retail Branch Server 4.1 (src):    glibc-2.26-13.65.1, glibc-utils-src-2.26-13.65.1
SUSE Manager Proxy 4.1 (src):    glibc-2.26-13.65.1, glibc-utils-src-2.26-13.65.1
SUSE Linux Enterprise Server for SAP 15-SP2 (src):    glibc-2.26-13.65.1, glibc-utils-src-2.26-13.65.1
SUSE Linux Enterprise Server for SAP 15-SP1 (src):    glibc-2.26-13.65.1, glibc-utils-src-2.26-13.65.1
SUSE Linux Enterprise Server for SAP 15 (src):    glibc-2.26-13.65.1, glibc-utils-src-2.26-13.65.1
SUSE Linux Enterprise Server 15-SP2-LTSS (src):    glibc-2.26-13.65.1, glibc-utils-src-2.26-13.65.1
SUSE Linux Enterprise Server 15-SP2-BCL (src):    glibc-2.26-13.65.1, glibc-utils-src-2.26-13.65.1
SUSE Linux Enterprise Server 15-SP1-LTSS (src):    glibc-2.26-13.65.1, glibc-utils-src-2.26-13.65.1
SUSE Linux Enterprise Server 15-SP1-BCL (src):    glibc-2.26-13.65.1, glibc-utils-src-2.26-13.65.1
SUSE Linux Enterprise Server 15-LTSS (src):    glibc-2.26-13.65.1, glibc-utils-src-2.26-13.65.1
SUSE Linux Enterprise Realtime Extension 15-SP2 (src):    glibc-2.26-13.65.1, glibc-utils-src-2.26-13.65.1
SUSE Linux Enterprise Micro 5.0 (src):    glibc-2.26-13.65.1
SUSE Linux Enterprise High Performance Computing 15-SP2-LTSS (src):    glibc-2.26-13.65.1, glibc-utils-src-2.26-13.65.1
SUSE Linux Enterprise High Performance Computing 15-SP2-ESPOS (src):    glibc-2.26-13.65.1, glibc-utils-src-2.26-13.65.1
SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS (src):    glibc-2.26-13.65.1, glibc-utils-src-2.26-13.65.1
SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS (src):    glibc-2.26-13.65.1, glibc-utils-src-2.26-13.65.1
SUSE Linux Enterprise High Performance Computing 15-LTSS (src):    glibc-2.26-13.65.1, glibc-utils-src-2.26-13.65.1
SUSE Linux Enterprise High Performance Computing 15-ESPOS (src):    glibc-2.26-13.65.1, glibc-utils-src-2.26-13.65.1
SUSE Enterprise Storage 7 (src):    glibc-2.26-13.65.1, glibc-utils-src-2.26-13.65.1
SUSE Enterprise Storage 6 (src):    glibc-2.26-13.65.1, glibc-utils-src-2.26-13.65.1
SUSE CaaS Platform 4.0 (src):    glibc-2.26-13.65.1, glibc-utils-src-2.26-13.65.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 12 Swamp Workflow Management 2022-03-21 14:17:08 UTC
SUSE-SU-2022:0909-1: An update that fixes three vulnerabilities is now available.

Category: security (important)
Bug References: 1194640,1194768,1194770
CVE References: CVE-2021-3999,CVE-2022-23218,CVE-2022-23219
JIRA References: 
Sources used:
SUSE OpenStack Cloud Crowbar 8 (src):    glibc-2.22-119.1
SUSE OpenStack Cloud 8 (src):    glibc-2.22-119.1
SUSE Linux Enterprise Server for SAP 12-SP3 (src):    glibc-2.22-119.1
SUSE Linux Enterprise Server 12-SP3-LTSS (src):    glibc-2.22-119.1
SUSE Linux Enterprise Server 12-SP3-BCL (src):    glibc-2.22-119.1
SUSE Linux Enterprise Server 12-SP2-BCL (src):    glibc-2.22-119.1
HPE Helion Openstack 8 (src):    glibc-2.22-119.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 13 Swamp Workflow Management 2022-03-21 14:20:34 UTC
SUSE-SU-2022:14923-1: An update that fixes 5 vulnerabilities is now available.

Category: security (important)
Bug References: 1193615,1193616,1194640,1194768,1194770
CVE References: CVE-2015-8982,CVE-2015-8983,CVE-2021-3999,CVE-2022-23218,CVE-2022-23219
JIRA References: 
Sources used:
SUSE Linux Enterprise Server 11-SP4-LTSS (src):    glibc-2.11.3-17.110.40.1
SUSE Linux Enterprise Point of Sale 11-SP3 (src):    glibc-2.11.3-17.110.40.1
SUSE Linux Enterprise Debuginfo 11-SP4 (src):    glibc-2.11.3-17.110.40.1
SUSE Linux Enterprise Debuginfo 11-SP3 (src):    glibc-2.11.3-17.110.40.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 14 Gianluca Gabrielli 2022-03-21 15:31:51 UTC
done