Bug 1194815 - GCC 12: cmake:full package fails
GCC 12: cmake:full package fails
Status: RESOLVED INVALID
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Basesystem
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Simon Lees
E-mail List
:
Depends on:
Blocks: 1194789
  Show dependency treegraph
 
Reported: 2022-01-18 09:45 UTC by Martin Liška
Modified: 2022-01-24 12:59 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Liška 2022-01-18 09:45:03 UTC
The package fails here:
https://build.opensuse.org/package/live_build_log/openSUSE:Factory:Staging:Gcc7/cmake:full/standard/x86_64

due to:
[ 3726s] 258/583 Test #267: CMakeLib.testCTestBinPacker .......................***Failed    0.01 sec
[ 3726s] Comparison did not match expected
[ 3726s] Comparison did not match expected
[ 3726s] Comparison did not match expected
[ 3726s] cmAllocateCTestResourcesRoundRobin did not return expected value
[ 3726s] cmAllocateCTestResourcesRoundRobin did not return expected value
[ 3726s] cmAllocateCTestResourcesRoundRobin did not return expected value
[ 3726s] cmAllocateCTestResourcesRoundRobin did not return expected value
[ 3726s] cmAllocateCTestResourcesRoundRobin did not return expected value
[ 3726s] cmAllocateCTestResourcesRoundRobin did not return expected value
[ 3726s] cmAllocateCTestResourcesRoundRobin did not return expected value
[ 3726s] cmAllocateCTestResourcesRoundRobin did not return expected value
[ 3726s] cmAllocateCTestResourcesRoundRobin did not return expected value
[ 3726s] 
[ 3726s]         Start 268: CMakeLib.testCTestResourceAllocator
[ 3726s] 259/583 Test #268: CMakeLib.testCTestResourceAllocator ...............***Failed    0.01 sec
[ 3726s] GetResources() did not return expected value
[ 3726s] in testInitializeFromResourceSpec()
[ 3726s] GetResources() did not return expected value
[ 3726s] GetResources() did not return expected value
[ 3726s] AllocateResource("gpus", "0", 1) returned true, should be false
[ 3726s] GetResources() did not return expected value
[ 3726s] AllocateResource("gpus", "1", 7) returned false, should be true
[ 3726s] GetResources() did not return expected value
[ 3726s] AllocateResource("gpus", "2", 1) returned true, should be false
[ 3726s] GetResources() did not return expected value
[ 3726s] GetResources() did not return expected value
[ 3726s] GetResources() did not return expected value
[ 3726s] in testAllocateResource()
[ 3726s] GetResources() did not return expected value
[ 3726s] GetResources() did not return expected value
[ 3726s] GetResources() did not return expected value
[ 3726s] GetResources() did not return expected value
[ 3726s] GetResources() did not return expected value
[ 3726s] GetResources() did not return expected value
[ 3726s] in testDeallocateResource()
[ 3726s] 
[ 3726s]         Start 269: CMakeLib.testCTestResourceSpec
[ 3726s] 260/583 Test #269: CMakeLib.testCTestResourceSpec ....................***Failed    0.02 sec
Comment 1 Simon Lees 2022-01-20 06:43:00 UTC
Reported upstream as https://gitlab.kitware.com/cmake/cmake/-/issues/23126 I couldn't see an obvious fix
Comment 2 Martin Liška 2022-01-20 08:04:02 UTC
(In reply to Simon Lees from comment #1)
> Reported upstream as https://gitlab.kitware.com/cmake/cmake/-/issues/23126 I
> couldn't see an obvious fix

Thanks for it. Do you understand what's the root cause of the failure? Note compiler can theoretically emit a wrong code so it would be good to understand it.
Comment 3 Martin Liška 2022-01-20 15:59:07 UTC
(In reply to Martin Liška from comment #2)
> (In reply to Simon Lees from comment #1)
> > Reported upstream as https://gitlab.kitware.com/cmake/cmake/-/issues/23126 I
> > couldn't see an obvious fix
> 
> Thanks for it. Do you understand what's the root cause of the failure? Note
> compiler can theoretically emit a wrong code so it would be good to
> understand it.

I've just analyzed that in the upstream bug report.
Comment 4 Simon Lees 2022-01-21 00:57:48 UTC
Thanks, I'll work on backporting the upstream commit to resolve it sometime today.
Comment 5 Martin Liška 2022-01-24 12:59:28 UTC
It's bug in GCC that should be fixed right now.