Bug 1195064 - VUL-0: webkit2gtk3: WebKitGTK and WPE WebKit Security Advisory WSA-2022-0001
VUL-0: webkit2gtk3: WebKitGTK and WPE WebKit Security Advisory WSA-2022-0001
Status: RESOLVED FIXED
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Normal
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/321573/
CVSSv3.1:SUSE:CVE-2021-30934:8.8:(AV:...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2022-01-24 15:35 UTC by Robert Frohl
Modified: 2022-04-11 07:49 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Frohl 2022-01-24 15:35:43 UTC
------------------------------------------------------------------------
WebKitGTK and WPE WebKit Security Advisory                 WSA-2022-0001
------------------------------------------------------------------------

Date reported           : January 21, 2022
Advisory ID             : WSA-2022-0001
WebKitGTK Advisory URL  : https://webkitgtk.org/security/WSA-2022-0001.html
WPE WebKit Advisory URL : https://wpewebkit.org/security/WSA-2022-0001.html
CVE identifiers         : CVE-2021-30934, CVE-2021-30936,
                          CVE-2021-30951, CVE-2021-30952,
                          CVE-2021-30953, CVE-2021-30954,
                          CVE-2021-30984, CVE-2022-XXXXX,
                          CVE-2021-45481, CVE-2021-45482,
                          CVE-2021-45483.

Several vulnerabilities were discovered in WebKitGTK and WPE WebKit.

CVE-2021-30934
    Versions affected: WebKitGTK and WPE WebKit before 2.34.4.
    Credit to Dani Biro.
    Impact: Processing maliciously crafted web content may lead to
    arbitrary code execution. Description: A buffer overflow issue was
    addressed with improved memory handling.

CVE-2021-30936
    Versions affected: WebKitGTK and WPE WebKit before 2.34.4.
    Credit to Chijin Zhou of ShuiMuYuLin Ltd and Tsinghua wingtecher
    lab.
    Impact: Processing maliciously crafted web content may lead to
    arbitrary code execution. Description: A use after free issue was
    addressed with improved memory management.

CVE-2021-30951
    Versions affected: WebKitGTK and WPE WebKit before 2.34.4.
    Credit to Pangu.
    Impact: Processing maliciously crafted web content may lead to
    arbitrary code execution. Description: A use after free issue was
    addressed with improved memory management.

CVE-2021-30952
    Versions affected: WebKitGTK and WPE WebKit before 2.34.4.
    Credit to WeBin.
    Impact: Processing maliciously crafted web content may lead to
    arbitrary code execution. Description: An integer overflow was
    addressed with improved input validation.

CVE-2021-30953
    Versions affected: WebKitGTK and WPE WebKit before 2.34.4.
    Credit to VRIJ.
    Impact: Processing maliciously crafted web content may lead to
    arbitrary code execution. Description: An out-of-bounds read was
    addressed with improved bounds checking.

CVE-2021-30954
    Versions affected: WebKitGTK and WPE WebKit before 2.34.4.
    Credit to Kunlun Lab.
    Impact: Processing maliciously crafted web content may lead to
    arbitrary code execution. Description: A type confusion issue was
    addressed with improved memory handling.

CVE-2021-30984
    Versions affected: WebKitGTK and WPE WebKit before 2.34.4.
    Credit to Kunlun Lab.
    Impact: Processing maliciously crafted web content may lead to
    arbitrary code execution. Description: A race condition was
    addressed with improved state handling.

CVE-2022-XXXXX
    Versions affected: WebKitGTK and WPE WebKit before 2.34.4.
    Credit to Martin Bajanik from fingerprintjs.com.
    Impact: A malicious website may exfiltrate data cross-origin.
    Description: A cross-origin issue existed with the IndexedDB. This
    was addressed with improved checking of security origins. 
    Notes: There is a public PoC demonstrating this issue at
    https://safarileaks.com so this issue may have been actively
    exploited. We still don't know the CVE number that will be assigned
    to this issue. We will update this advisory once we know it.

CVE-2021-45481
    Versions affected: WebKitGTK and WPE WebKit before 2.34.0.
    Credit to Chijin Zhou of ShuiMuYuLin Ltd and Tsinghua wingtecher lab.
    Processing maliciously crafted web content may cause an application
    crash due to an incorrect memory allocation in
    WebCore::ImageBufferCairoImageSurfaceBackend::create

CVE-2021-45482
    Versions affected: WebKitGTK and WPE WebKit before 2.32.4.
    Credit to Chijin Zhou of ShuiMuYuLin Ltd and Tsinghua wingtecher lab.
    Processing maliciously crafted web content may cause a memory
    corruption issue (use-after-free) in WebCore::ContainerNode::firstChild

CVE-2021-45483
    Versions affected: WebKitGTK and WPE WebKit before 2.34.0.
    Credit to Chijin Zhou of ShuiMuYuLin Ltd and Tsinghua wingtecher lab.
    Processing maliciously crafted web content may cause a memory
    corruption issue (heap-use-after-free) in WebCore::Frame::page


We recommend updating to the latest stable versions of WebKitGTK and WPE
WebKit. It is the best way to ensure that you are running safe versions
of WebKit. Please check our websites for information about the latest
stable releases.

Further information about WebKitGTK and WPE WebKit security advisories
can be found at: https://webkitgtk.org/security.html or
https://wpewebkit.org/security/.

The WebKitGTK and WPE WebKit team,
January 21, 2022
Comment 1 Carlos López 2022-02-01 12:05:51 UTC
> CVE-2022-XXXXX
>     Versions affected: WebKitGTK and WPE WebKit before 2.34.4.
>     Credit to Martin Bajanik from fingerprintjs.com.
>     Impact: A malicious website may exfiltrate data cross-origin.
>     Description: A cross-origin issue existed with the IndexedDB. This
>     was addressed with improved checking of security origins. 
>     Notes: There is a public PoC demonstrating this issue at
>     https://safarileaks.com so this issue may have been actively
>     exploited. We still don't know the CVE number that will be assigned
>     to this issue. We will update this advisory once we know it.

This is CVE-2022-22594.
Comment 6 Swamp Workflow Management 2022-03-03 17:18:35 UTC
SUSE-SU-2022:0690-1: An update that fixes 14 vulnerabilities is now available.

Category: security (important)
Bug References: 1195064,1195735
CVE References: CVE-2021-30934,CVE-2021-30936,CVE-2021-30951,CVE-2021-30952,CVE-2021-30953,CVE-2021-30954,CVE-2021-30984,CVE-2021-45481,CVE-2021-45482,CVE-2021-45483,CVE-2022-22589,CVE-2022-22590,CVE-2022-22592,CVE-2022-22594
JIRA References: 
Sources used:
SUSE OpenStack Cloud Crowbar 9 (src):    webkit2gtk3-2.34.5-2.85.3
SUSE OpenStack Cloud Crowbar 8 (src):    webkit2gtk3-2.34.5-2.85.3
SUSE OpenStack Cloud 9 (src):    webkit2gtk3-2.34.5-2.85.3
SUSE OpenStack Cloud 8 (src):    webkit2gtk3-2.34.5-2.85.3
SUSE Linux Enterprise Software Development Kit 12-SP5 (src):    webkit2gtk3-2.34.5-2.85.3
SUSE Linux Enterprise Server for SAP 12-SP4 (src):    webkit2gtk3-2.34.5-2.85.3
SUSE Linux Enterprise Server for SAP 12-SP3 (src):    webkit2gtk3-2.34.5-2.85.3
SUSE Linux Enterprise Server 12-SP5 (src):    webkit2gtk3-2.34.5-2.85.3
SUSE Linux Enterprise Server 12-SP4-LTSS (src):    webkit2gtk3-2.34.5-2.85.3
SUSE Linux Enterprise Server 12-SP3-LTSS (src):    webkit2gtk3-2.34.5-2.85.3
SUSE Linux Enterprise Server 12-SP3-BCL (src):    webkit2gtk3-2.34.5-2.85.3
SUSE Linux Enterprise Server 12-SP2-BCL (src):    webkit2gtk3-2.34.5-2.85.3
HPE Helion Openstack 8 (src):    webkit2gtk3-2.34.5-2.85.3

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 7 Swamp Workflow Management 2022-03-03 20:26:45 UTC
SUSE-SU-2022:0703-1: An update that fixes 15 vulnerabilities is now available.

Category: security (important)
Bug References: 1195064,1195735,1196133
CVE References: CVE-2021-30934,CVE-2021-30936,CVE-2021-30951,CVE-2021-30952,CVE-2021-30953,CVE-2021-30954,CVE-2021-30984,CVE-2021-45481,CVE-2021-45482,CVE-2021-45483,CVE-2022-22589,CVE-2022-22590,CVE-2022-22592,CVE-2022-22594,CVE-2022-22620
JIRA References: 
Sources used:
SUSE Linux Enterprise Server for SAP 15-SP1 (src):    webkit2gtk3-2.34.6-3.97.1
SUSE Linux Enterprise Server for SAP 15 (src):    webkit2gtk3-2.34.6-3.97.1
SUSE Linux Enterprise Server 15-SP1-LTSS (src):    webkit2gtk3-2.34.6-3.97.1
SUSE Linux Enterprise Server 15-SP1-BCL (src):    webkit2gtk3-2.34.6-3.97.1
SUSE Linux Enterprise Server 15-LTSS (src):    webkit2gtk3-2.34.6-3.97.1
SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS (src):    webkit2gtk3-2.34.6-3.97.1
SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS (src):    webkit2gtk3-2.34.6-3.97.1
SUSE Linux Enterprise High Performance Computing 15-LTSS (src):    webkit2gtk3-2.34.6-3.97.1
SUSE Linux Enterprise High Performance Computing 15-ESPOS (src):    webkit2gtk3-2.34.6-3.97.1
SUSE Enterprise Storage 6 (src):    webkit2gtk3-2.34.6-3.97.1
SUSE CaaS Platform 4.0 (src):    webkit2gtk3-2.34.6-3.97.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 8 Swamp Workflow Management 2022-03-04 11:19:47 UTC
SUSE-SU-2022:0705-1: An update that fixes 14 vulnerabilities is now available.

Category: security (important)
Bug References: 1195064,1195735,1196133
CVE References: CVE-2021-30934,CVE-2021-30936,CVE-2021-30951,CVE-2021-30952,CVE-2021-30953,CVE-2021-30954,CVE-2021-30984,CVE-2021-45481,CVE-2021-45482,CVE-2021-45483,CVE-2022-22589,CVE-2022-22590,CVE-2022-22592,CVE-2022-22620
JIRA References: 
Sources used:
SUSE Manager Server 4.1 (src):    webkit2gtk3-2.34.6-29.1
SUSE Manager Retail Branch Server 4.1 (src):    webkit2gtk3-2.34.6-29.1
SUSE Manager Proxy 4.1 (src):    webkit2gtk3-2.34.6-29.1
SUSE Linux Enterprise Server for SAP 15-SP2 (src):    webkit2gtk3-2.34.6-29.1
SUSE Linux Enterprise Server 15-SP2-LTSS (src):    webkit2gtk3-2.34.6-29.1
SUSE Linux Enterprise Server 15-SP2-BCL (src):    webkit2gtk3-2.34.6-29.1
SUSE Linux Enterprise Realtime Extension 15-SP2 (src):    webkit2gtk3-2.34.6-29.1
SUSE Linux Enterprise Module for Desktop Applications 15-SP3 (src):    webkit2gtk3-2.34.6-29.1
SUSE Linux Enterprise Module for Basesystem 15-SP4 (src):    webkit2gtk3-2.34.6-29.1
SUSE Linux Enterprise Module for Basesystem 15-SP3 (src):    webkit2gtk3-2.34.6-29.1
SUSE Linux Enterprise High Performance Computing 15-SP2-LTSS (src):    webkit2gtk3-2.34.6-29.1
SUSE Linux Enterprise High Performance Computing 15-SP2-ESPOS (src):    webkit2gtk3-2.34.6-29.1
SUSE Enterprise Storage 7 (src):    webkit2gtk3-2.34.6-29.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 9 Swamp Workflow Management 2022-03-04 11:24:05 UTC
openSUSE-SU-2022:0705-1: An update that fixes 14 vulnerabilities is now available.

Category: security (important)
Bug References: 1195064,1195735,1196133
CVE References: CVE-2021-30934,CVE-2021-30936,CVE-2021-30951,CVE-2021-30952,CVE-2021-30953,CVE-2021-30954,CVE-2021-30984,CVE-2021-45481,CVE-2021-45482,CVE-2021-45483,CVE-2022-22589,CVE-2022-22590,CVE-2022-22592,CVE-2022-22620
JIRA References: 
Sources used:
openSUSE Leap 15.4 (src):    webkit2gtk3-2.34.6-29.1
openSUSE Leap 15.3 (src):    webkit2gtk3-2.34.6-29.1
Comment 10 Gabriele Sonnu 2022-04-11 07:49:58 UTC
Done.