Bug 1196535 - general protection fault in swarst_dri.so
general protection fault in swarst_dri.so
Status: RESOLVED UPSTREAM
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: X.Org
Current
Other Other
: P3 - Medium : Normal (vote)
: ---
Assigned To: Gfx Bugs
Gfx Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2022-02-28 06:08 UTC by Aleksa Sarai
Modified: 2022-03-22 09:10 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aleksa Sarai 2022-02-28 06:08:05 UTC
When using Anki 2.1.49 (https://github.com/ankitects/anki/releases/tag/2.1.49), trying to use a plugin results in a segfault and coredump in swrast_dri.so. Sadly the Anki binaries do not come with debuginfo (and I'm not using the openSUSE package because it's very out of date) so the corefile is probably not that useful.

This problem has been happening for the past few days. In particular this problem exists in both Mesa-dri-21.3.6-301.3 and Mesa-dri-21.3.7-302.1. The only hint this is caused by Mesa-dri is the dmesg line:

[776164.804163] traps: Anki[5303] general protection fault ip:7f39446c56be sp:7fff618496e8 error:0 in swrast_dri.so[7f3944640000+10b7000]

Let me know if you need the corefile.
Comment 1 Stefan Dirsch 2022-03-09 17:39:02 UTC
Which ANKI plugin? Can you at least start anki in gdb and then do a 'bt' and post the backtrace when it crashes?
Comment 2 Aleksa Sarai 2022-03-22 02:52:51 UTC
(In reply to Stefan Dirsch from comment #1)
> Which ANKI plugin? Can you at least start anki in gdb and then do a 'bt' and
> post the backtrace when it crashes?

It's the Japanese Support plugin, and it crashes when you try to open the Kanji Stats panel. The backtrace is completely useless due to a lack of debugging symbols.

However, upstream has managed to debug and fix the issue (https://github.com/ankitects/anki-addons/commit/14a1e07f0ed7d79534891c4c0586021caa17fa45) so this can be closed. It seems the issue had to do with changing how saveGeom and restoreGeom were called as well as a few other ordering tweaks, but I haven't done much Qt programming so I'm not sure.
Comment 3 Stefan Dirsch 2022-03-22 09:10:10 UTC
Thanks. So if I understand this correctly this is fixed in 

https://ankiweb.net/shared/info/3918629684

with 

Update 2022-03-14:

- Fix crash on some systems when showing kanji stats.