Bug 1198001 - (CVE-2021-33657) VUL-0: CVE-2021-33657: SDL: Heap overflow problem in video/SDL_pixels.c
(CVE-2021-33657)
VUL-0: CVE-2021-33657: SDL: Heap overflow problem in video/SDL_pixels.c
Status: IN_PROGRESS
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Major
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/327920/
CVSSv3.1:SUSE:CVE-2021-33657:7.8:(AV:...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2022-04-04 11:29 UTC by Hu
Modified: 2022-04-22 19:27 UTC (History)
3 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hu 2022-04-04 11:29:53 UTC
CVE-2021-33657

There is a heap overflow problem in video/SDL_pixels.c in SDL (Simple
DirectMedia Layer) 2.x to 2.0.18 versions. By crafting a malicious .BMP file, an
attacker can cause the application using this library to crash, denial of
service or Code execution.

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2021-33657
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-33657
https://github.com/libsdl-org/SDL/commit/8c91cf7dba5193f5ce12d06db1336515851c9ee9
Comment 1 Hu 2022-04-04 11:32:56 UTC
Affected:

- SUSE:SLE-11:Update/SDL
- SUSE:SLE-12:Update/SDL
- SUSE:SLE-15:Update/SDL
- openSUSE:Factory/SDL
Comment 2 Michael Gorse 2022-04-04 21:44:52 UTC
This also affects SDL2. SDL is version 1.
Comment 3 Hu 2022-04-05 08:15:34 UTC
(In reply to Michael Gorse from comment #2)
> This also affects SDL2. SDL is version 1.

Thanks Michael, for the pointer. Updated affected list below:

(In reply to Hu from comment #1)
> Affected:
> 
> - SUSE:SLE-11:Update/SDL
> - SUSE:SLE-12:Update/SDL
> - SUSE:SLE-15:Update/SDL
> - openSUSE:Factory/SDL

- SUSE:SLE-15:Update/SDL2
- SUSE:SLE-15-SP2:Update/SDL2

openSUSE:Factory/SDL2 is not affected (version number 2.0.20)
Comment 4 Michael Gorse 2022-04-05 18:55:00 UTC
For TW, I think we should replace the old SDL package with sdl12-compat, since SDL 1.2 is no longer maintained. Red Hat has done this. But that should be a separate bug. I've submitted a backport of the CVE fix for now.
Comment 8 Marcus Meissner 2022-04-07 08:08:48 UTC
opened bug 1198182 for tumbleweed SDL 1
Comment 9 Swamp Workflow Management 2022-04-14 19:18:35 UTC
SUSE-SU-2022:1218-1: An update that fixes one vulnerability is now available.

Category: security (important)
Bug References: 1198001
CVE References: CVE-2021-33657
JIRA References: 
Sources used:
openSUSE Leap 15.4 (src):    SDL2-2.0.8-150200.11.6.1
openSUSE Leap 15.3 (src):    SDL2-2.0.8-150200.11.6.1
SUSE Manager Server 4.1 (src):    SDL2-2.0.8-150200.11.6.1
SUSE Manager Retail Branch Server 4.1 (src):    SDL2-2.0.8-150200.11.6.1
SUSE Manager Proxy 4.1 (src):    SDL2-2.0.8-150200.11.6.1
SUSE Linux Enterprise Server for SAP 15-SP2 (src):    SDL2-2.0.8-150200.11.6.1
SUSE Linux Enterprise Server 15-SP2-LTSS (src):    SDL2-2.0.8-150200.11.6.1
SUSE Linux Enterprise Server 15-SP2-BCL (src):    SDL2-2.0.8-150200.11.6.1
SUSE Linux Enterprise Realtime Extension 15-SP2 (src):    SDL2-2.0.8-150200.11.6.1
SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP4 (src):    SDL2-2.0.8-150200.11.6.1
SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP3 (src):    SDL2-2.0.8-150200.11.6.1
SUSE Linux Enterprise Module for Desktop Applications 15-SP4 (src):    SDL2-2.0.8-150200.11.6.1
SUSE Linux Enterprise Module for Desktop Applications 15-SP3 (src):    SDL2-2.0.8-150200.11.6.1
SUSE Linux Enterprise High Performance Computing 15-SP2-LTSS (src):    SDL2-2.0.8-150200.11.6.1
SUSE Linux Enterprise High Performance Computing 15-SP2-ESPOS (src):    SDL2-2.0.8-150200.11.6.1
SUSE Enterprise Storage 7 (src):    SDL2-2.0.8-150200.11.6.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 10 Swamp Workflow Management 2022-04-20 10:24:40 UTC
SUSE-SU-2022:1273-1: An update that fixes three vulnerabilities is now available.

Category: security (important)
Bug References: 1181201,1181202,1198001
CVE References: CVE-2020-14409,CVE-2020-14410,CVE-2021-33657
JIRA References: 
Sources used:
openSUSE Leap 15.4 (src):    SDL-1.2.15-150000.3.19.1
openSUSE Leap 15.3 (src):    SDL-1.2.15-150000.3.19.1
SUSE Manager Server 4.1 (src):    SDL-1.2.15-150000.3.19.1
SUSE Manager Retail Branch Server 4.1 (src):    SDL-1.2.15-150000.3.19.1
SUSE Manager Proxy 4.1 (src):    SDL-1.2.15-150000.3.19.1
SUSE Linux Enterprise Server for SAP 15-SP2 (src):    SDL-1.2.15-150000.3.19.1
SUSE Linux Enterprise Server for SAP 15-SP1 (src):    SDL-1.2.15-150000.3.19.1
SUSE Linux Enterprise Server for SAP 15 (src):    SDL-1.2.15-150000.3.19.1
SUSE Linux Enterprise Server 15-SP2-LTSS (src):    SDL-1.2.15-150000.3.19.1
SUSE Linux Enterprise Server 15-SP2-BCL (src):    SDL-1.2.15-150000.3.19.1
SUSE Linux Enterprise Server 15-SP1-LTSS (src):    SDL-1.2.15-150000.3.19.1
SUSE Linux Enterprise Server 15-SP1-BCL (src):    SDL-1.2.15-150000.3.19.1
SUSE Linux Enterprise Server 15-LTSS (src):    SDL-1.2.15-150000.3.19.1
SUSE Linux Enterprise Realtime Extension 15-SP2 (src):    SDL-1.2.15-150000.3.19.1
SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP3 (src):    SDL-1.2.15-150000.3.19.1
SUSE Linux Enterprise Module for Desktop Applications 15-SP4 (src):    SDL-1.2.15-150000.3.19.1
SUSE Linux Enterprise Module for Desktop Applications 15-SP3 (src):    SDL-1.2.15-150000.3.19.1
SUSE Linux Enterprise High Performance Computing 15-SP2-LTSS (src):    SDL-1.2.15-150000.3.19.1
SUSE Linux Enterprise High Performance Computing 15-SP2-ESPOS (src):    SDL-1.2.15-150000.3.19.1
SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS (src):    SDL-1.2.15-150000.3.19.1
SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS (src):    SDL-1.2.15-150000.3.19.1
SUSE Linux Enterprise High Performance Computing 15-LTSS (src):    SDL-1.2.15-150000.3.19.1
SUSE Linux Enterprise High Performance Computing 15-ESPOS (src):    SDL-1.2.15-150000.3.19.1
SUSE Enterprise Storage 7 (src):    SDL-1.2.15-150000.3.19.1
SUSE Enterprise Storage 6 (src):    SDL-1.2.15-150000.3.19.1
SUSE CaaS Platform 4.0 (src):    SDL-1.2.15-150000.3.19.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 11 Swamp Workflow Management 2022-04-22 19:20:16 UTC
SUSE-SU-2022:1312-1: An update that fixes three vulnerabilities is now available.

Category: security (important)
Bug References: 1181201,1181202,1198001
CVE References: CVE-2020-14409,CVE-2020-14410,CVE-2021-33657
JIRA References: 
Sources used:
SUSE OpenStack Cloud Crowbar 9 (src):    SDL-1.2.15-15.17.1
SUSE OpenStack Cloud Crowbar 8 (src):    SDL-1.2.15-15.17.1
SUSE OpenStack Cloud 9 (src):    SDL-1.2.15-15.17.1
SUSE OpenStack Cloud 8 (src):    SDL-1.2.15-15.17.1
SUSE Linux Enterprise Software Development Kit 12-SP5 (src):    SDL-1.2.15-15.17.1
SUSE Linux Enterprise Server for SAP 12-SP4 (src):    SDL-1.2.15-15.17.1
SUSE Linux Enterprise Server for SAP 12-SP3 (src):    SDL-1.2.15-15.17.1
SUSE Linux Enterprise Server 12-SP5 (src):    SDL-1.2.15-15.17.1
SUSE Linux Enterprise Server 12-SP4-LTSS (src):    SDL-1.2.15-15.17.1
SUSE Linux Enterprise Server 12-SP3-LTSS (src):    SDL-1.2.15-15.17.1
SUSE Linux Enterprise Server 12-SP3-BCL (src):    SDL-1.2.15-15.17.1
SUSE Linux Enterprise Server 12-SP2-BCL (src):    SDL-1.2.15-15.17.1
HPE Helion Openstack 8 (src):    SDL-1.2.15-15.17.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 12 Swamp Workflow Management 2022-04-22 19:26:13 UTC
SUSE-SU-2022:1313-1: An update that fixes one vulnerability is now available.

Category: security (important)
Bug References: 1198001
CVE References: CVE-2021-33657
JIRA References: 
Sources used:
SUSE Linux Enterprise Server for SAP 15-SP1 (src):    SDL2-2.0.8-150000.3.21.1
SUSE Linux Enterprise Server for SAP 15 (src):    SDL2-2.0.8-150000.3.21.1
SUSE Linux Enterprise Server 15-SP1-LTSS (src):    SDL2-2.0.8-150000.3.21.1
SUSE Linux Enterprise Server 15-SP1-BCL (src):    SDL2-2.0.8-150000.3.21.1
SUSE Linux Enterprise Server 15-LTSS (src):    SDL2-2.0.8-150000.3.21.1
SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS (src):    SDL2-2.0.8-150000.3.21.1
SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS (src):    SDL2-2.0.8-150000.3.21.1
SUSE Linux Enterprise High Performance Computing 15-LTSS (src):    SDL2-2.0.8-150000.3.21.1
SUSE Linux Enterprise High Performance Computing 15-ESPOS (src):    SDL2-2.0.8-150000.3.21.1
SUSE Enterprise Storage 6 (src):    SDL2-2.0.8-150000.3.21.1
SUSE CaaS Platform 4.0 (src):    SDL2-2.0.8-150000.3.21.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 13 Swamp Workflow Management 2022-04-22 19:27:15 UTC
SUSE-SU-2022:14943-1: An update that fixes four vulnerabilities is now available.

Category: security (important)
Bug References: 1124825,1181201,1181202,1198001
CVE References: CVE-2019-7637,CVE-2020-14409,CVE-2020-14410,CVE-2021-33657
JIRA References: 
Sources used:
SUSE Linux Enterprise Server 11-SP4-LTSS (src):    SDL-1.2.13-106.21.1
SUSE Linux Enterprise Point of Sale 11-SP3 (src):    SDL-1.2.13-106.21.1
SUSE Linux Enterprise Debuginfo 11-SP4 (src):    SDL-1.2.13-106.21.1
SUSE Linux Enterprise Debuginfo 11-SP3 (src):    SDL-1.2.13-106.21.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.