Bug 1199460 - (CVE-2022-29162) VUL-0: CVE-2022-29162: runc: incorrect handling of inheritable capabilities in default configuration
(CVE-2022-29162)
VUL-0: CVE-2022-29162: runc: incorrect handling of inheritable capabilities i...
Status: RESOLVED FIXED
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Normal
: ---
Assigned To: Containers Team
Security Team bot
https://smash.suse.de/issue/331562/
CVSSv3.1:SUSE:CVE-2022-29162:4.0:(AV:...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2022-05-12 07:20 UTC by Hu
Modified: 2023-01-23 08:43 UTC (History)
4 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hu 2022-05-12 07:20:23 UTC
CVE-2022-29162

Posted by Aleksa Sarai on May 11A security update for runc (v1.1.2) was released to mitigate
CVE-2022-29162, which is a low severity vulnerability related to
mishandling of inheritable capabilities which resulted in an atypical
Linux environment inside containers.

As the inheritable set was a subset of the permitted capabilities (which
are limited) this bug does not affect the container security boundary,
it simply ensures that programs running inside the container do not...

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2022-29162
https://seclists.org/oss-sec/2022/q2/98
Comment 1 Hu 2022-05-12 07:20:39 UTC
Affected:
 - SUSE:SLE-12:Update/runc   1.0.3
 - SUSE:SLE-15:Update/runc   1.0.3
 - openSUSE:Factory/runc     1.1.1
Comment 5 Swamp Workflow Management 2022-06-23 19:17:39 UTC
SUSE-SU-2022:2165-1: An update that solves two vulnerabilities and has three fixes is now available.

Category: security (important)
Bug References: 1192051,1199460,1199565,1200088,1200145
CVE References: CVE-2022-29162,CVE-2022-31030
JIRA References: 
Sources used:
SUSE Linux Enterprise Module for Containers 12 (src):    containerd-1.6.6-16.62.1, docker-20.10.17_ce-98.83.1, runc-1.1.3-16.21.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 6 Swamp Workflow Management 2022-07-08 19:21:35 UTC
SUSE-SU-2022:2341-1: An update that solves two vulnerabilities and has three fixes is now available.

Category: security (important)
Bug References: 1192051,1199460,1199565,1200088,1200145
CVE References: CVE-2022-29162,CVE-2022-31030
JIRA References: 
Sources used:
openSUSE Leap 15.4 (src):    containerd-1.6.6-150000.73.2, docker-20.10.17_ce-150000.166.1, docker-kubic-20.10.17_ce-150000.166.1, runc-1.1.3-150000.30.1
openSUSE Leap 15.3 (src):    containerd-1.6.6-150000.73.2, docker-20.10.17_ce-150000.166.1, docker-kubic-20.10.17_ce-150000.166.1, runc-1.1.3-150000.30.1
SUSE Manager Server 4.1 (src):    containerd-1.6.6-150000.73.2, docker-20.10.17_ce-150000.166.1, runc-1.1.3-150000.30.1
SUSE Manager Retail Branch Server 4.1 (src):    containerd-1.6.6-150000.73.2, docker-20.10.17_ce-150000.166.1, runc-1.1.3-150000.30.1
SUSE Manager Proxy 4.1 (src):    containerd-1.6.6-150000.73.2, docker-20.10.17_ce-150000.166.1, runc-1.1.3-150000.30.1
SUSE Linux Enterprise Server for SAP 15-SP2 (src):    containerd-1.6.6-150000.73.2, docker-20.10.17_ce-150000.166.1, runc-1.1.3-150000.30.1
SUSE Linux Enterprise Server for SAP 15-SP1 (src):    containerd-1.6.6-150000.73.2, docker-20.10.17_ce-150000.166.1, runc-1.1.3-150000.30.1
SUSE Linux Enterprise Server for SAP 15 (src):    containerd-1.6.6-150000.73.2, docker-20.10.17_ce-150000.166.1, runc-1.1.3-150000.30.1
SUSE Linux Enterprise Server 15-SP2-LTSS (src):    containerd-1.6.6-150000.73.2, docker-20.10.17_ce-150000.166.1, runc-1.1.3-150000.30.1
SUSE Linux Enterprise Server 15-SP2-BCL (src):    containerd-1.6.6-150000.73.2, docker-20.10.17_ce-150000.166.1, runc-1.1.3-150000.30.1
SUSE Linux Enterprise Server 15-SP1-LTSS (src):    containerd-1.6.6-150000.73.2, docker-20.10.17_ce-150000.166.1, runc-1.1.3-150000.30.1
SUSE Linux Enterprise Server 15-SP1-BCL (src):    containerd-1.6.6-150000.73.2, docker-20.10.17_ce-150000.166.1, runc-1.1.3-150000.30.1
SUSE Linux Enterprise Server 15-LTSS (src):    containerd-1.6.6-150000.73.2, docker-20.10.17_ce-150000.166.1, runc-1.1.3-150000.30.1
SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP3 (src):    containerd-1.6.6-150000.73.2
SUSE Linux Enterprise Module for Containers 15-SP4 (src):    containerd-1.6.6-150000.73.2, docker-20.10.17_ce-150000.166.1, runc-1.1.3-150000.30.1
SUSE Linux Enterprise Module for Containers 15-SP3 (src):    containerd-1.6.6-150000.73.2, docker-20.10.17_ce-150000.166.1, runc-1.1.3-150000.30.1
SUSE Linux Enterprise Micro 5.2 (src):    containerd-1.6.6-150000.73.2, docker-20.10.17_ce-150000.166.1, runc-1.1.3-150000.30.1
SUSE Linux Enterprise Micro 5.1 (src):    containerd-1.6.6-150000.73.2, docker-20.10.17_ce-150000.166.1, runc-1.1.3-150000.30.1
SUSE Linux Enterprise High Performance Computing 15-SP2-LTSS (src):    containerd-1.6.6-150000.73.2, docker-20.10.17_ce-150000.166.1, runc-1.1.3-150000.30.1
SUSE Linux Enterprise High Performance Computing 15-SP2-ESPOS (src):    containerd-1.6.6-150000.73.2, docker-20.10.17_ce-150000.166.1, runc-1.1.3-150000.30.1
SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS (src):    containerd-1.6.6-150000.73.2, docker-20.10.17_ce-150000.166.1, runc-1.1.3-150000.30.1
SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS (src):    containerd-1.6.6-150000.73.2, docker-20.10.17_ce-150000.166.1, runc-1.1.3-150000.30.1
SUSE Linux Enterprise High Performance Computing 15-LTSS (src):    containerd-1.6.6-150000.73.2, docker-20.10.17_ce-150000.166.1, runc-1.1.3-150000.30.1
SUSE Linux Enterprise High Performance Computing 15-ESPOS (src):    containerd-1.6.6-150000.73.2, docker-20.10.17_ce-150000.166.1
SUSE Enterprise Storage 7.1 (src):    runc-1.1.3-150000.30.1
SUSE Enterprise Storage 7 (src):    containerd-1.6.6-150000.73.2, docker-20.10.17_ce-150000.166.1, runc-1.1.3-150000.30.1
SUSE Enterprise Storage 6 (src):    containerd-1.6.6-150000.73.2, docker-20.10.17_ce-150000.166.1, runc-1.1.3-150000.30.1
SUSE CaaS Platform 4.0 (src):    containerd-1.6.6-150000.73.2, docker-20.10.17_ce-150000.166.1, runc-1.1.3-150000.30.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 8 Vincent Moutoussamy 2022-08-17 15:07:02 UTC
I think this can be closed right?
Comment 11 Swamp Workflow Management 2022-09-20 19:19:29 UTC
SUSE-SU-2022:3321-1: An update that solves three vulnerabilities and has two fixes is now available.

Category: security (important)
Bug References: 1199392,1199460,1199603,1200528,1202516
CVE References: CVE-2022-1798,CVE-2022-1996,CVE-2022-29162
JIRA References: 
Sources used:
openSUSE Leap 15.3 (src):    kubevirt-0.49.0-150300.8.13.1
SUSE Linux Enterprise Module for Containers 15-SP3 (src):    kubevirt-0.49.0-150300.8.13.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 12 Swamp Workflow Management 2022-09-22 10:20:57 UTC
SUSE-SU-2022:3333-1: An update that solves three vulnerabilities and has two fixes is now available.

Category: security (important)
Bug References: 1199392,1199460,1199603,1200528,1202516
CVE References: CVE-2022-1798,CVE-2022-1996,CVE-2022-29162
JIRA References: 
Sources used:
openSUSE Leap 15.4 (src):    kubevirt-0.54.0-150400.3.3.2
SUSE Linux Enterprise Module for Containers 15-SP4 (src):    kubevirt-0.54.0-150400.3.3.2

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.