Bug 1199621 - 15.4RC1: Installation - package counter not updated
15.4RC1: Installation - package counter not updated
Status: RESOLVED FIXED
: 1200395 1200580 1201507 (view as bug list)
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Installation
Leap 15.4
aarch64 Other
: P5 - None : Minor (vote)
: ---
Assigned To: E-mail List
Jiri Srain
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2022-05-17 12:12 UTC by Axel Braun
Modified: 2022-09-19 10:24 UTC (History)
5 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Axel Braun 2022-05-17 12:12:15 UTC
Leap 15.4 RC1 installation from netiso on Raspi4:
During installation process the package counter
Installing packages....(Remaining: 2.669GB, 1798 packages)
updates the remaining size, but the number of packages stays at 1798
Comment 1 Steffen Winterfeldt 2022-05-17 13:10:20 UTC
Just did a TW install and I've seen this as well.
Comment 2 Steffen Winterfeldt 2022-05-17 13:10:59 UTC
To be precise: a network TW install.
Comment 3 Stefan Hundhammer 2022-05-17 13:12:45 UTC
I just checked in the installed system (up-to-date TW): When I do the GUI counterpart of "zypper dup", the "remaining packages" count does decrease.

But in that screnario, it does not do parallel downloading / installation; everything is strictly sequential.

So if this is a bug, it might be in libzypp.
Comment 4 Imobach Gonzalez Sosa 2022-05-17 21:00:58 UTC
Actually, it looks like a YaST bug. See https://github.com/yast/yast-packager/blob/2f54b720b20ed804caf4ad6b053050845ff47146/src/modules/PackageSlideShow.rb#L398-L398. We keep a list of installed packages but we only update such a list in normal mode. That's the reason that it worked for Stefan in an installed system.

I do not know which is the rationale for not updating the list of packages. I *guess* that we want to avoid keeping a list in memory that is not going to be used in installation/upgrade mode.

I have opened a PR that should fix the issue: https://github.com/yast/yast-packager/pull/619.
Comment 5 Imobach Gonzalez Sosa 2022-05-17 21:03:10 UTC
As mentioned in the PR, if keeping the lists is not a problem, I would go with a simpler approach and remove the "if Mode.normal" clauses.
Comment 6 Stefan Hundhammer 2022-05-19 12:51:07 UTC
I just tested the PR from comment #4, and I can confirm that it works.
Comment 8 Imobach Gonzalez Sosa 2022-05-19 14:41:55 UTC
Hi all,

@HuHa, thanks for testing the PR. I have submitted the fix:


* https://build.suse.de/request/show/272645 (SLE-15-SP4)
* https://build.opensuse.org/request/show/978139 (master, Tumbleweed)

I am closing the bug by now. Thanks for reporting!

Regards,
Imo
Comment 9 Imobach Gonzalez Sosa 2022-05-19 14:42:09 UTC
Closing.
Comment 10 Imobach Gonzalez Sosa 2022-06-10 11:02:16 UTC
*** Bug 1200395 has been marked as a duplicate of this bug. ***
Comment 11 Imobach Gonzalez Sosa 2022-06-16 05:00:55 UTC
*** Bug 1200580 has been marked as a duplicate of this bug. ***
Comment 13 Andreas Stieger 2022-07-15 15:55:32 UTC
*** Bug 1201507 has been marked as a duplicate of this bug. ***
Comment 14 Swamp Workflow Management 2022-09-19 10:24:36 UTC
SUSE-RU-2022:3299-1: An update that has 26 recommended fixes and contains one feature can now be installed.

Category: recommended (important)
Bug References: 1195059,1195608,1195894,1196674,1198076,1198848,1199451,1199480,1199554,1199621,1199746,1200155,1200274,1200780,1200803,1200964,1201129,1201185,1201532,1201747,1201924,1201966,1202228,1202479,1202892,1202919
CVE References: 
JIRA References: SLE-22069
Sources used:
openSUSE Leap 15.4 (src):    autoyast2-4.4.39-150400.3.8.1, yast2-4.4.52-150400.3.8.1, yast2-auth-client-4.4.4-150400.3.7.1, yast2-fcoe-client-4.4.3-150400.3.3.1, yast2-firstboot-4.4.9-150400.3.3.1, yast2-installation-4.4.56-150400.3.9.1, yast2-network-4.4.49-150400.3.6.1, yast2-nfs-client-4.4.5-150400.3.4.1, yast2-online-update-configuration-4.4.1-150400.3.10.1, yast2-packager-4.4.32-150400.3.4.1, yast2-schema-default-4.4.14-150400.3.6.2, yast2-schema-micro-4.4.14-150400.3.6.2, yast2-security-4.4.14-150400.3.3.1, yast2-update-4.4.7-150400.3.3.1, yast2-users-4.4.11-150400.3.3.1, yast2-x11-4.4.2-150400.3.3.1
SUSE Linux Enterprise Module for Basesystem 15-SP4 (src):    autoyast2-4.4.39-150400.3.8.1, yast2-4.4.52-150400.3.8.1, yast2-auth-client-4.4.4-150400.3.7.1, yast2-fcoe-client-4.4.3-150400.3.3.1, yast2-firstboot-4.4.9-150400.3.3.1, yast2-installation-4.4.56-150400.3.9.1, yast2-network-4.4.49-150400.3.6.1, yast2-nfs-client-4.4.5-150400.3.4.1, yast2-online-update-configuration-4.4.1-150400.3.10.1, yast2-packager-4.4.32-150400.3.4.1, yast2-schema-default-4.4.14-150400.3.6.2, yast2-security-4.4.14-150400.3.3.1, yast2-update-4.4.7-150400.3.3.1, yast2-users-4.4.11-150400.3.3.1, yast2-x11-4.4.2-150400.3.3.1
SUSE Linux Enterprise Installer 15-SP4 (src):    autoyast2-4.4.39-150400.3.8.1, yast2-4.4.52-150400.3.8.1, yast2-installation-4.4.56-150400.3.9.1, yast2-packager-4.4.32-150400.3.4.1, yast2-users-4.4.11-150400.3.3.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.