Bug 1199748 - OBS zfs build error on Leap 15.4 x86-64
OBS zfs build error on Leap 15.4 x86-64
Status: RESOLVED FIXED
: 1200337 1200588 (view as bug list)
Classification: openSUSE
Product: PUBLIC SUSE Linux Enterprise Desktop 15 SP4
Classification: openSUSE
Component: Kernel
unspecified
x86-64 openSUSE Leap 15.4
: P5 - None : Normal
: ---
Assigned To: Jan Engelhardt
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2022-05-20 07:41 UTC by Michiya Hagimoto
Modified: 2022-06-21 08:26 UTC (History)
9 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michiya Hagimoto 2022-05-20 07:41:31 UTC
Leap 15.4 now RC phase, I try to zfs module on Leap 15.4.

But now OBS zfs build for 15.4 is fail.

https://build.opensuse.org/package/show/filesystems/zfs

I check build log, anything wrong on fpu context save/restroe?

https://github.com/openzfs/zfs/commit/e5db31349484e5e859c7a942eb15b98d68ce5b4d

Please check it.
Comment 1 Jan Engelhardt 2022-05-20 08:22:50 UTC
The 15.4 kernel rpm is broken.

Commit b56d2795b29792c465cc8ef036abad5127a003fb upstream removed the *contents* of asm/fpu/internal.h, but *not* the file itself.

Patch x86-fpu-replace-the-includes-of-fpu-internal-h.patch in SUSE is the same.

But, in the produced kernel-default-devel.rpm/kernel-devel.rpm, the asm/fpu/internal.h file is *completely missing*.
Comment 2 Takashi Iwai 2022-05-20 09:25:18 UTC
That's likely a subtle difference of git vs patch behavior.

A possible fix would be to put some space or a new line, i.e. making it non-empty.  Alternatively fix zfs not to include asm/fpu/internal.h.

Boris?
Comment 3 Borislav Petkov 2022-05-20 10:25:22 UTC
Whoops, fixed:

https://lore.kernel.org/r/20220520101723.12006-1-bp@alien8.de

> Alternatively fix zfs not to include asm/fpu/internal.h.

Yes, that.

Thx.
Comment 4 Takashi Iwai 2022-05-20 10:34:47 UTC
OK, now the upstream follows the state of Leap 15.4 -- the empty header files are gone.

Jan, please fix it in zfs package side.
Comment 5 Michiya Hagimoto 2022-05-30 02:42:05 UTC
I try to 15.4 again, but still failed ZFS module.
Comment 6 Takashi Iwai 2022-06-08 14:23:42 UTC
It has to be fixed in ZFS side now; the header file is gone officially in the upstream, too.
Comment 7 Takashi Iwai 2022-06-08 14:23:52 UTC
*** Bug 1200337 has been marked as a duplicate of this bug. ***
Comment 8 Andrew Hibberson 2022-06-08 16:10:17 UTC
Copying my comment from OBS here for visibility:

I created a VERY dirty patch just removing the inclusion of the header in my home project just to get it working https://build.opensuse.org/package/show/home:hibby50:server/zfs

This is patched upstream in https://github.com/openzfs/zfs/commit/4c6526208db0d3d5abf44664e74d1e28156a3db7 but the diff does not apply cleanly to 2.1.4
Comment 9 Andreas Stieger 2022-06-16 06:58:09 UTC
*** Bug 1200588 has been marked as a duplicate of this bug. ***
Comment 10 Dominik Heidler 2022-06-21 08:17:56 UTC
I modified the spec to only apply the patch on >=15.4 and submitted to filesystems project:
https://build.opensuse.org/request/show/983995

The request was accepted so we have successfully built zfs packages for 15.4.
Comment 11 Michiya Hagimoto 2022-06-21 08:26:31 UTC
Thanks for update, I confirm 15.4 build done.

Try to test on Leap 15.4.

but tw still failed to build, will release openZFS 2.1.5 soon, please apply it...