Bug 1201613 - Since version 102, Firefox renders PDFs in greyscale
Since version 102, Firefox renders PDFs in greyscale
Status: RESOLVED WORKSFORME
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Firefox
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Factory Mozilla
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2022-07-18 21:08 UTC by Atri Bhattacharya
Modified: 2022-08-29 08:27 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
Screenshot of PDF incorrectly rendered in greyscale (829.08 KB, image/png)
2022-07-18 21:08 UTC, Atri Bhattacharya
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Atri Bhattacharya 2022-07-18 21:08:44 UTC
Created attachment 860241 [details]
Screenshot of PDF incorrectly rendered in greyscale

Open any PDF with coloured text and/or images, Firefox (since version 102 and currently with 102.1) renders them in greyscale. Same PDFs were correctly rendered by versions 101.x and earlier.

OS: openSUSE Tumbleweed 20220714
Desktop: GNOME 42.3 on Xorg/Wayland

For example, see attached screenshot for rendering of Ffx (left) vs Evince (right) of the same PDF from:
https://arxiv.org/pdf/1502.01076.pdf

Happy to help with any additional info if/as directed.
Comment 1 Wolfgang Rosenauer 2022-08-28 07:37:49 UTC
Cannot reproduce with Firefox 104.0 in Tumbleweed. (Soon to be released in TW)

I haven't checked older versions though. And I don't have wayland so if it still is a problem for you with that version, please reopen.
Comment 2 Martin Sirringhaus 2022-08-29 08:27:08 UTC
Just for completeness, I think this was: https://bugzilla.mozilla.org/show_bug.cgi?id=1777895
and should be fixed with FF 104+ (the described workaround solved it for me on FF 103)