Bug 1202234 - Release packages of addon products are not installed by autoyast
Release packages of addon products are not installed by autoyast
Status: CONFIRMED
Classification: SUSE Linux Enterprise Server
Product: PUBLIC SUSE Linux Enterprise Server 15 SP3
Classification: SUSE Linux Enterprise Server
Component: AutoYaST
SLES15SP3Maint-Upd
Other Other
: P5 - None : Normal
: unspecified
Assigned To: YaST Team
E-mail List
https://openqa.suse.de/tests/9274096/...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2022-08-08 14:49 UTC by Jonathan Rivrain
Modified: 2022-08-25 07:45 UTC (History)
4 users (show)

See Also:
Found By: openQA
Services Priority:
Business Priority:
Blocker: Yes
Marketing QA Status: ---
IT Deployment: ---


Attachments
installation y2logs (7.75 MB, application/x-xz)
2022-08-08 14:49 UTC, Jonathan Rivrain
Details
full-logs (2.22 MB, application/x-xz)
2022-08-12 12:49 UTC, Imobach Gonzalez Sosa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Rivrain 2022-08-08 14:49:31 UTC
Created attachment 860673 [details]
installation y2logs

In sle 15 sp3 and sp4, after autoyast installation, release packages for add-on products (eg sle-module-basesystem-release) are not installed.

For example, in the installation here https://openqa.suse.de/tests/9274096. 
If we run rpm -qa in the resulting qcow, we see that only sles-release (sles-release-15.3-55.4.1.x86_64) was installed, but none of the other add-on product release packages. 
But if we do the same installation with interactive installation (like , the -release packages are installed.
Comment 1 David Diaz 2022-08-12 11:25:27 UTC
Hi @Jonathan

Sorry for the delay. Could you please attach the AutoYaST profile?

Thanks!
Comment 2 Imobach Gonzalez Sosa 2022-08-12 12:49:08 UTC
Created attachment 860765 [details]
full-logs

Hi all,

I was able to reproduce the issue on a virtual machine. I am attaching my logs because QA ones are incomplete (y2log-5 does not contain the beginning of the installation).

In the logs I can see that AutoYaST is selecting the product for installation:

2022-08-12 08:33:00 <1> install(3981) [Ruby] clients/add-on_auto.rb(install_product):390 Installing product: sle-module-basesystem

We need to find out why the release package is not included.
Comment 3 Imobach Gonzalez Sosa 2022-08-12 12:50:44 UTC
The logs are not required anymore. I asked for them because I was thinking about some product name mismatch, but that's not the case. Sorry for the noise. Something like this causes the problem:

  <add-on>
    <add_on_products config:type="list">
      <listentry>
        <media_url><![CDATA[cd:///?devices=/dev/sr0]]></media_url>
        <product_dir>/Module-Basesystem</product_dir>
        <product>sle-module-basesystem</product>
      </listentry>
      <listentry>
        <media_url><![CDATA[cd:///?devices=/dev/sr0]]></media_url>
        <product_dir>/Module-Server-Applications</product_dir>
        <product>sle-module-server-applications</product>
      </listentry>
    </add_on_products>
  </add-on>
Comment 4 Imobach Gonzalez Sosa 2022-08-12 13:32:42 UTC
(In reply to Imobach Gonzalez Sosa from comment #3)
> The logs are not required anymore.

I meant the profile.