Bug 1202388 - Kernel Oops when connected to type-c docking station
Kernel Oops when connected to type-c docking station
Status: RESOLVED DUPLICATE of bug 1202386
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
x86-64 Other
: P5 - None : Normal (vote)
: ---
Assigned To: openSUSE Kernel Bugs
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2022-08-15 10:00 UTC by Nicholas Yang
Modified: 2022-08-19 20:31 UTC (History)
5 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
oops message (3.60 KB, text/x-log)
2022-08-15 10:00 UTC, Nicholas Yang
Details
hwinfo.txt.zst (548.69 KB, application/zstd)
2022-08-18 08:57 UTC, Nicholas Yang
Details
dmesg.txt.zst (42.54 KB, application/zstd)
2022-08-18 08:58 UTC, Nicholas Yang
Details
dmesg_disconnected.txt (2.05 KB, text/plain)
2022-08-18 08:59 UTC, Nicholas Yang
Details
dmesg (296.77 KB, text/plain)
2022-08-18 10:15 UTC, Jiri Slaby
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nicholas Yang 2022-08-15 10:00:12 UTC
Created attachment 860782 [details]
oops message

I noticed my laptop is not able to boot into graphic mode today and kernel oops is logged to console.

This problem reproduces randomly and blacklisting ucsi_acpi fixes the problem. When it reproduces, a device `ucsi-source-psy-USBC000:002` is shown in `/sys/class/power_supply` with type `Unknown`.

Hardware:

* ThinkPad p15 gen2
* Dell TB16 thunderbolt 3 docking station
* AC power adapter

Kernel: 5.19.0-1-default
Comment 1 Takashi Iwai 2022-08-17 11:31:06 UTC
Could you give the hwinfo and dmesg outputs taken before the disconnection, as well as the dmesg after the disconnection?
Comment 2 Nicholas Yang 2022-08-18 08:57:15 UTC
Created attachment 860888 [details]
hwinfo.txt.zst
Comment 3 Nicholas Yang 2022-08-18 08:58:09 UTC
Created attachment 860889 [details]
dmesg.txt.zst
Comment 4 Nicholas Yang 2022-08-18 08:59:45 UTC
Created attachment 860890 [details]
dmesg_disconnected.txt
Comment 5 Jiri Slaby 2022-08-18 10:14:03 UTC
> BUG: kernel NULL pointer dereference, address: 0000000000000000
> #PF: supervisor instruction fetch in kernel mode
> #PF: error_code(0x0010) - not-present page
> PGD 0 P4D 0
> Oops: 0010 [#1] PREEMPT SMP NOPTI
> CPU: 4 PID: 1269 Comm: systemd-logind Tainted: P           OE     5.19.1-1-default #1 openSUSE Tumbleweed f3b44bfb672cdb9f235aff53b57724eba8b9411b
> Hardware name: LENOVO 20YRS2DA17/20YRS2DA17, BIOS N37ET36W (1.17 ) 11/22/2021
> RIP: 0010:0x0
> Code: Unable to access opcode bytes at RIP 0xffffffffffffffd6.
> RSP: 0018:ffffa81fc29a3c70 EFLAGS: 00010202
> RAX: 0000000000000000 RBX: ffffffffa825de28 RCX: ffffffffa825de28
> RDX: ffffa81fc29a3c78 RSI: 0000000000000004 RDI: ffff9b43b23bf800
> RBP: 0000000000000004 R08: ffff9b43b23bf838 R09: ffff9b4081297bc0
> R10: 0000000000000000 R11: 0000000000000001 R12: ffff9b408a04c000
> R13: ffff9b43b23bf838 R14: ffffffffa825de28 R15: ffff9b43b23bf800
> FS:  00007fe880e22b80(0000) GS:ffff9b4f9fd00000(0000) knlGS:0000000000000000
> CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
> CR2: ffffffffffffffd6 CR3: 0000000431be0002 CR4: 0000000000770ee0
> PKRU: 55555554
> Call Trace:
>  <TASK>
>  power_supply_show_property+0xb3/0x230
>  dev_attr_show+0x15/0x40
>  sysfs_kf_seq_show+0xa0/0xe0
>  seq_read_iter+0x11f/0x450
>  new_sync_read+0xf7/0x180
>  vfs_read+0x144/0x190
>  ksys_read+0x63/0xe0

*** This bug has been marked as a duplicate of bug 1202386 ***
Comment 6 Jiri Slaby 2022-08-18 10:15:06 UTC
Created attachment 860895 [details]
dmesg

No need to compress!