Bug 1202507 - Kernel <TASK> power_supply_show_property, Null Pointer dereference
Kernel <TASK> power_supply_show_property, Null Pointer dereference
Status: RESOLVED DUPLICATE of bug 1202386
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
x86-64 Other
: P5 - None : Major (vote)
: ---
Assigned To: openSUSE Kernel Bugs
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2022-08-18 00:30 UTC by Malte von der Lancken Wakenitz
Modified: 2022-08-18 08:08 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
journalctl log (1.95 MB, text/plain)
2022-08-18 00:30 UTC, Malte von der Lancken Wakenitz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Malte von der Lancken Wakenitz 2022-08-18 00:30:13 UTC
Created attachment 860883 [details]
journalctl log

I recently did a zypper dup to  version 20220815. I am now unable to log into KDE. Just a cursor on an external screen connected via Lenovo Thunderbolt 4 Workstation dock.

While investigating it seemed like the laptop was going in and out of suspend during the boot process. I set autoSuspend=no in /etc/systemd/sleep.conf, which stopped the suspend but still no login, just the cursor. I then noticed the null pointer exceptions when reading: power_supply_show_property+0xb3/0x230. This can be seen in the journalctl output I have attached.

The machine boots and logs in fine without the doc present. Still using an external monitor. All this is with the proprietary NVIDIA drivers. I tried the one from the repo and also manually the ones from NVIDIA directly. Both behave the same.

I also have a "stop job" waiting for the Power management daemon when shutting down. I assume it's related. 

I'd be glad to assist with more information to get this resolved. It's a bit of a showstopper for me.

Malte
Comment 1 Takashi Iwai 2022-08-18 08:08:06 UTC
Seems to be a dup of bug 1202386.

*** This bug has been marked as a duplicate of bug 1202386 ***