Bug 1202739 - (CVE-2022-41973) VUL-0: CVE-2022-41973,CVE-2022-41974: multipath-tools: multipathd: authorization bypass and symlink attack "Leeloo Multipath"
(CVE-2022-41973)
VUL-0: CVE-2022-41973,CVE-2022-41974: multipath-tools: multipathd: authorizat...
Status: IN_PROGRESS
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Normal
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/340664
CVSSv3.1:SUSE:CVE-2022-41973:6.2:(AV:...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2022-08-25 07:36 UTC by Alexander Bergmann
Modified: 2022-10-26 19:42 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Comment 15 Martin Wilck 2022-10-24 09:41:01 UTC
Upstream Pull request https://github.com/opensvc/multipath-tools/pull/46
created and merged in upstream multipath-tools 0.9.2.

Factory SR: 1030702
SLE15-SP5 SR: 283008
Comment 16 Hu 2022-10-24 09:47:16 UTC
public
Comment 17 Martin Wilck 2022-10-24 10:38:45 UTC
Factory SR 1030843
SLE15-SP5 SR 283023

(fixed a glitch in the Factory changelog)
Comment 18 Marcus Meissner 2022-10-24 16:05:45 UTC
cve publication request issued.

https://www.qualys.com/2022/10/24/leeloo-multipath/leeloo-multipath.txt
Comment 19 Swamp Workflow Management 2022-10-24 19:19:31 UTC
SUSE-SU-2022:3712-1: An update that solves one vulnerability and has two fixes is now available.

Category: security (important)
Bug References: 1202616,1202739,1204325
CVE References: CVE-2022-41974
JIRA References: 
Sources used:
openSUSE Leap 15.4 (src):    multipath-tools-0.7.3+173+suse.7dd1b01-150000.3.29.1
openSUSE Leap 15.3 (src):    multipath-tools-0.7.3+173+suse.7dd1b01-150000.3.29.1
SUSE Linux Enterprise Server for SAP 15 (src):    multipath-tools-0.7.3+173+suse.7dd1b01-150000.3.29.1
SUSE Linux Enterprise Server 15-LTSS (src):    multipath-tools-0.7.3+173+suse.7dd1b01-150000.3.29.1
SUSE Linux Enterprise High Performance Computing 15-LTSS (src):    multipath-tools-0.7.3+173+suse.7dd1b01-150000.3.29.1
SUSE Linux Enterprise High Performance Computing 15-ESPOS (src):    multipath-tools-0.7.3+173+suse.7dd1b01-150000.3.29.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 20 Swamp Workflow Management 2022-10-24 19:20:23 UTC
SUSE-SU-2022:3713-1: An update that solves one vulnerability and has two fixes is now available.

Category: security (important)
Bug References: 1202616,1202739,1204325
CVE References: CVE-2022-41974
JIRA References: 
Sources used:
SUSE OpenStack Cloud Crowbar 9 (src):    multipath-tools-0.7.3+177+suse.b16d5dc-2.23.1
SUSE OpenStack Cloud 9 (src):    multipath-tools-0.7.3+177+suse.b16d5dc-2.23.1
SUSE Linux Enterprise Server for SAP 12-SP4 (src):    multipath-tools-0.7.3+177+suse.b16d5dc-2.23.1
SUSE Linux Enterprise Server 12-SP4-LTSS (src):    multipath-tools-0.7.3+177+suse.b16d5dc-2.23.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 21 Swamp Workflow Management 2022-10-24 19:21:42 UTC
SUSE-SU-2022:3711-1: An update that solves two vulnerabilities and has 6 fixes is now available.

Category: security (important)
Bug References: 1197570,1199342,1199345,1199346,1199347,1201483,1202616,1202739
CVE References: CVE-2022-41973,CVE-2022-41974
JIRA References: 
Sources used:
openSUSE Leap 15.4 (src):    multipath-tools-0.9.0+62+suse.3e048d4-150400.4.7.1
SUSE Linux Enterprise Module for Basesystem 15-SP4 (src):    multipath-tools-0.9.0+62+suse.3e048d4-150400.4.7.1
SUSE Linux Enterprise Micro 5.3 (src):    multipath-tools-0.9.0+62+suse.3e048d4-150400.4.7.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 22 Swamp Workflow Management 2022-10-24 19:22:34 UTC
SUSE-SU-2022:3707-1: An update that solves two vulnerabilities and has one errata is now available.

Category: security (important)
Bug References: 1187534,1202616,1202739
CVE References: CVE-2022-41973,CVE-2022-41974
JIRA References: 
Sources used:
SUSE Linux Enterprise Software Development Kit 12-SP5 (src):    multipath-tools-0.7.9+232+suse.cbc3754-3.14.1
SUSE Linux Enterprise Server 12-SP5 (src):    multipath-tools-0.7.9+232+suse.cbc3754-3.14.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 23 Swamp Workflow Management 2022-10-24 19:23:11 UTC
SUSE-SU-2022:3715-1: An update that solves one vulnerability and has two fixes is now available.

Category: security (important)
Bug References: 1202616,1202739,1204325
CVE References: CVE-2022-41974
JIRA References: 
Sources used:
SUSE Linux Enterprise Server 12-SP2-BCL (src):    multipath-tools-0.6.2+suse20221017.514d453-71.26.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 24 Swamp Workflow Management 2022-10-24 19:24:22 UTC
SUSE-SU-2022:3714-1: An update that solves one vulnerability and has 8 fixes is now available.

Category: security (important)
Bug References: 1118495,1125145,1125507,1131789,1134648,1139369,1202616,1202739,1204325
CVE References: CVE-2022-41974
JIRA References: 
Sources used:
SUSE Linux Enterprise Server 12-SP3-BCL (src):    multipath-tools-0.7.1+125+suse.c18e287-2.23.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 25 Swamp Workflow Management 2022-10-24 19:25:29 UTC
SUSE-SU-2022:3708-1: An update that solves two vulnerabilities and has one errata is now available.

Category: security (important)
Bug References: 1187534,1202616,1202739
CVE References: CVE-2022-41973,CVE-2022-41974
JIRA References: 
Sources used:
SUSE Linux Enterprise Server for SAP 15-SP1 (src):    multipath-tools-0.7.9+232+suse.cbc3754-150100.3.20.1
SUSE Linux Enterprise Server 15-SP1-LTSS (src):    multipath-tools-0.7.9+232+suse.cbc3754-150100.3.20.1
SUSE Linux Enterprise Server 15-SP1-BCL (src):    multipath-tools-0.7.9+232+suse.cbc3754-150100.3.20.1
SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS (src):    multipath-tools-0.7.9+232+suse.cbc3754-150100.3.20.1
SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS (src):    multipath-tools-0.7.9+232+suse.cbc3754-150100.3.20.1
SUSE Enterprise Storage 6 (src):    multipath-tools-0.7.9+232+suse.cbc3754-150100.3.20.1
SUSE CaaS Platform 4.0 (src):    multipath-tools-0.7.9+232+suse.cbc3754-150100.3.20.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 26 Swamp Workflow Management 2022-10-24 19:26:45 UTC
SUSE-SU-2022:3710-1: An update that solves two vulnerabilities, contains one feature and has four fixes is now available.

Category: security (important)
Bug References: 1189551,1191900,1195506,1197570,1202616,1202739
CVE References: CVE-2022-41973,CVE-2022-41974
JIRA References: PED-1448
Sources used:
openSUSE Leap Micro 5.2 (src):    multipath-tools-0.8.5+126+suse.8ce8da5-150300.2.14.1
openSUSE Leap 15.3 (src):    multipath-tools-0.8.5+126+suse.8ce8da5-150300.2.14.1
SUSE Linux Enterprise Module for Basesystem 15-SP3 (src):    multipath-tools-0.8.5+126+suse.8ce8da5-150300.2.14.1
SUSE Linux Enterprise Micro 5.2 (src):    multipath-tools-0.8.5+126+suse.8ce8da5-150300.2.14.1
SUSE Linux Enterprise Micro 5.1 (src):    multipath-tools-0.8.5+126+suse.8ce8da5-150300.2.14.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 27 Swamp Workflow Management 2022-10-24 19:27:56 UTC
SUSE-SU-2022:3709-1: An update that solves two vulnerabilities and has one errata is now available.

Category: security (important)
Bug References: 1189551,1202616,1202739
CVE References: CVE-2022-41973,CVE-2022-41974
JIRA References: 
Sources used:
SUSE Manager Server 4.1 (src):    multipath-tools-0.8.2+182.6d41865-150200.4.14.1
SUSE Manager Retail Branch Server 4.1 (src):    multipath-tools-0.8.2+182.6d41865-150200.4.14.1
SUSE Manager Proxy 4.1 (src):    multipath-tools-0.8.2+182.6d41865-150200.4.14.1
SUSE Linux Enterprise Server for SAP 15-SP2 (src):    multipath-tools-0.8.2+182.6d41865-150200.4.14.1
SUSE Linux Enterprise Server 15-SP2-LTSS (src):    multipath-tools-0.8.2+182.6d41865-150200.4.14.1
SUSE Linux Enterprise Server 15-SP2-BCL (src):    multipath-tools-0.8.2+182.6d41865-150200.4.14.1
SUSE Linux Enterprise High Performance Computing 15-SP2-LTSS (src):    multipath-tools-0.8.2+182.6d41865-150200.4.14.1
SUSE Linux Enterprise High Performance Computing 15-SP2-ESPOS (src):    multipath-tools-0.8.2+182.6d41865-150200.4.14.1
SUSE Enterprise Storage 7 (src):    multipath-tools-0.8.2+182.6d41865-150200.4.14.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.