Bug 1202748 - [Build E.662.1] yast forcibly calls netconfig update
[Build E.662.1] yast forcibly calls netconfig update
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: YaST2
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: YaST Team
Jiri Srain
https://openqa.opensuse.org/tests/255...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2022-08-25 09:43 UTC by Dominique Leuenberger
Modified: 2022-10-19 09:38 UTC (History)
2 users (show)

See Also:
Found By: openQA
Services Priority:
Business Priority:
Blocker: Yes
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominique Leuenberger 2022-08-25 09:43:08 UTC
## Observation

In light of ALP, we are trying to eliminate netconfig wrappers.
To this end, we changed one of the last packages depending on sysconfig-netconfig to no longer do so (NetworkManager)

This results in a system installation error:
"Cannot update the dynamic configuration policy"

As netconfig is no longer mandatory, YaST should cope with its absence


openQA test in scenario opensuse-Staging:E-Staging-DVD-x86_64-RAID0_gpt@64bit fails in
[perform_installation](https://openqa.opensuse.org/tests/2550590/modules/perform_installation/steps/5)

## Test suite description



## Reproducible

Fails since (at least) Build [E.662.1](https://openqa.opensuse.org/tests/2550590) (current job)


## Expected result

Last good: [E.661.1](https://openqa.opensuse.org/tests/2538496) (or more recent)


## Further details

Always latest result in this scenario: [latest](https://openqa.opensuse.org/tests/latest?arch=x86_64&distri=opensuse&flavor=Staging-DVD&machine=64bit&test=RAID0_gpt&version=Staging%3AE)
Comment 1 Dominique Leuenberger 2022-08-25 09:45:28 UTC
The error seems to track back to:


yast/yast-ntp-client
src/modules/NtpClient.rb
    # Writes sysconfig ntp policy and calls netconfig to update ntp. Report an
    # error if some of the call fails.
      success = write_policy && update_netconfig

      Report.Error(_("Cannot update the dynamic configuration policy.")) unless success
Comment 4 Knut Alejandro Anderssen González 2022-09-20 08:29:15 UTC
This looks like a duplicate of https://bugzilla.suse.com/show_bug.cgi?id=1198066, although not crashing in case of netconfig is more generic and we need to adapt several modules but for that we have the Jira request.
Comment 5 Knut Alejandro Anderssen González 2022-09-26 09:51:15 UTC
At least the installation should work fine with the fix introduced by yast2-ntp-client-4.5.1 but there are other modules that needs to be adapted like yast2-samba (see https://bugzilla.suse.com/show_bug.cgi?id=1198066)

As for removing completely netconfig we already have a jira entry, do we want to maintain this bug open or can we close it already once the installation should works now fine with yast2-ntp-client fixes?
Comment 6 Michal Filka 2022-10-03 06:51:54 UTC
changing assignment as it is already being handled in yast kanban queue
Comment 7 Dominique Leuenberger 2022-10-19 09:38:15 UTC
(In reply to Knut Alejandro Anderssen González from comment #5)
> At least the installation should work fine with the fix introduced by
> yast2-ntp-client-4.5.1 but there are other modules that needs to be adapted
> like yast2-samba (see https://bugzilla.suse.com/show_bug.cgi?id=1198066)
> 
> As for removing completely netconfig we already have a jira entry, do we
> want to maintain this bug open or can we close it already once the
> installation should works now fine with yast2-ntp-client fixes?

I'd say we can close the bug - as the immediate issue reported here is fixed and the remaining pieces are part of the jira ticket