Bug 1203411 - Wrong progress step strings in processing
Wrong progress step strings in processing
Status: RESOLVED WORKSFORME
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: YaST2
Current
Other Other
: P5 - None : Minor (vote)
: ---
Assigned To: E-mail List
Jiri Srain
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2022-09-14 15:16 UTC by Milachew
Modified: 2022-09-29 14:18 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
yast-packager (4.25 KB, image/jpeg)
2022-09-14 15:16 UTC, Milachew
Details
software manager startup (38.60 KB, image/png)
2022-09-29 07:32 UTC, Michal Filka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Milachew 2022-09-14 15:16:20 UTC
Created attachment 861475 [details]
yast-packager

When some progress step in the processing on the, for example, opening of some YaST module, strings don't change.

According to the git, it must change (https://github.com/yast/yast-packager/blob/master/src/lib/y2packager/clients/inst_productsources.rb#L1537).

But users see only one type of sentence (https://github.com/yast/yast-packager/blob/master/src/lib/y2packager/clients/inst_productsources.rb#L1535).

I attached the screenshot of the last Live image of TW.

It also shows up on Leap 15.4 and 15.5.
Comment 1 Michal Filka 2022-09-19 07:45:39 UTC
I don't understand what the problem is. You talk about module initialization on one side and point to the code related to updating repository list which is run when writing changes during module shutdown.

So, could you please clarify?
Comment 2 Milachew 2022-09-19 11:13:12 UTC
Yeap.
On the attachment, you can see an arrow opposite the item that is currently being performed.

For example, when a new repository is added, as far as I understand, the text should change opposite the arrow to "Adding repositories..." (https://github.com/yast/yast-packager/blob/70d6da0518bb204a0cbc9836313bd666861fa5b0/src/lib/y2packager/clients/inst_productsources.rb#L1568).
But it remains Add Repository.

Is this how it should be?

Because, when translated into Russian or Ukrainian, for example, "Add Repository" doesn't indicate a process, but looks like a simple sentence (like "Go for milk").
Here, it seems to me, "Adding repositories" would be more suitable, because it's indicate a process with a beginning and an ending (like "Going for milk").
Comment 3 Michal Filka 2022-09-29 07:31:42 UTC
(In reply to Milachew from comment #2)
> Yeap.
> On the attachment, you can see an arrow opposite the item that is currently
> being performed.
> 
> For example, when a new repository is added, as far as I understand, the
> text should change opposite the arrow to "Adding repositories..."
> (https://github.com/yast/yast-packager/blob/
> 70d6da0518bb204a0cbc9836313bd666861fa5b0/src/lib/y2packager/clients/
> inst_productsources.rb#L1568).
> But it remains Add Repository.
> 
> Is this how it should be?
> 
> Because, when translated into Russian or Ukrainian, for example, "Add
> Repository" doesn't indicate a process, but looks like a simple sentence
> (like "Go for milk").
> Here, it seems to me, "Adding repositories" would be more suitable, because
> it's indicate a process with a beginning and an ending (like "Going for
> milk").

I think, I understand it better now.

It seems that it works as expected, because by the arrow is showed name of Stage  like e.g. "Load the Configured Repositories". Real action which is taken during the stage is shown above the progress bar (e.g. Building repository ...) as you can see in the screenshot taken on my system I've attached.
Comment 4 Michal Filka 2022-09-29 07:32:29 UTC
Created attachment 861838 [details]
software manager startup
Comment 5 Michal Filka 2022-09-29 07:33:38 UTC
For now I'm going to close this as "works as expected". Feel free to reopen if you have some more comments or issues regarding this. Thanks for the report.
Comment 6 Milachew 2022-09-29 14:18:57 UTC
(In reply to Michal Filka from comment #3)
> It seems that it works as expected, because by the arrow is showed name of
> Stage  like e.g. "Load the Configured Repositories". Real action which is
> taken during the stage is shown above the progress bar (e.g. Building
> repository ...) as you can see in the screenshot taken on my system I've
> attached.

Oh, now I understand.
But still, it doesn’t sound very good in the languages ​​I listed when translating ...

Then, if by default the problem is not observed in general, I will correct the translations themselves.

Thanks for the feedback and your time!