Bug 1203479 - [Build 5.14.21-150500.14.1.gc80fb26] Network doesn't work with 15-SP5 KOTD kernel
[Build 5.14.21-150500.14.1.gc80fb26] Network doesn't work with 15-SP5 KOTD ke...
Status: VERIFIED FIXED
: 1203612 (view as bug list)
Classification: openSUSE
Product: PUBLIC SUSE Linux Enterprise Server 15 SP5
Classification: openSUSE
Component: Kernel
unspecified
Other Other
: P5 - None : Normal
: ---
Assigned To: Thomas Bogendoerfer
https://openqa.suse.de/tests/9526246/...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2022-09-16 08:42 UTC by Petr Cervinka
Modified: 2023-01-18 17:53 UTC (History)
3 users (show)

See Also:
Found By: openQA
Services Priority:
Business Priority:
Blocker: Yes
Marketing QA Status: ---
IT Deployment: ---


Attachments
dmesg - different kernels (48.91 KB, application/x-compressed-tar)
2022-09-16 08:42 UTC, Petr Cervinka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Cervinka 2022-09-16 08:42:08 UTC
Created attachment 861510 [details]
dmesg - different kernels

## Observation

openQA test in scenario sle-15-SP5-Online-KOTD-x86_64-install_ltp+sle+Online-KOTD@64bit fails in
[install_ltp](https://openqa.suse.de/tests/9526246/modules/install_ltp/steps/88)

## Test suite description
Maintainer: pcervinka


## Reproducible

Fails since (at least) Build [5.14.21-150500.12.1.g25f225f](https://openqa.suse.de/tests/9515612)


## Expected result

Last good: (unknown) (or more recent)


## Further details

Always latest result in this scenario: [latest](https://openqa.suse.de/tests/latest?arch=x86_64&distri=sle&flavor=Online-KOTD&machine=64bit&test=install_ltp%2Bsle%2BOnline-KOTD&version=15-SP5)


Test scenario fails after KOTD installation and reboot, system under system has no ip assigned. Manually verified behavior in vm with different kernels on the same vm image:

15-sp4 KOTD  5.14.21-150400.639.gad373ba-default  works OK
15-sp5 (latest milestone)  5.14.21-150400.24.18-default works OK
15-sp5 KOTD 5.14.21-150500.14.gc80fb26-default fails

dmesg shows for 15-sp4-KOTD and 15-sp5 "eth0: link becomes ready", line is missing in dmesg for 15-sp5 KOTD (no link is reported by ethtool too).
Comment 1 Petr Cervinka 2022-09-16 08:48:09 UTC
Same result is also on aarch64  https://openqa.suse.de/tests/9525986#step/install_ltp/3  (no ip assigned on eth0)
Comment 2 Martin Doucha 2022-09-16 09:19:28 UTC
There's CONFIG_VIRTIO_NET=m in the kernel config but virtio_net.ko.zst appears to be missing in the RPM.
Comment 3 Petr Cervinka 2022-09-16 09:32:10 UTC
(In reply to Martin Doucha from comment #2)
> There's CONFIG_VIRTIO_NET=m in the kernel config but virtio_net.ko.zst
> appears to be missing in the RPM.

Module is present:
susetest:~ # modinfo virtio_net
filename:       /lib/modules/5.14.21-150500.14.gc80fb26-default/kernel/drivers/net/virtio_net.ko.zst
license:        GPL
description:    Virtio network driver
suserelease:    SLE15-SP5
srcversion:     3C617505FCAC78789D33CA8
alias:          virtio:d00000001v*
depends:        net_failover
supported:      yes
retpoline:      Y
intree:         Y
name:           virtio_net
vermagic:       5.14.21-150500.14.gc80fb26-default SMP preempt mod_unload modversions 
sig_id:         PKCS#7
signer:         Devel:Kernel OBS Project
sig_key:        8C:5D:5D:2E:73:71:FF:FE
sig_hashalgo:   sha256
signature:      43:B1:60:D9:08:06:00:D4:5D:A8:D7:66:61:7F:D2:CC:88:5A:6A:D1:
		BA:35:A2:18:43:34:68:19:7D:66:76:86:2C:CB:83:10:C5:5A:0D:E9:
		A9:04:5D:6F:80:60:2E:D3:D4:AE:26:37:05:27:BF:BF:E3:41:F3:41:
		63:44:C1:5D:21:54:6A:A0:A5:23:37:05:09:4E:60:69:7D:48:68:32:
		77:FC:95:65:F4:E1:15:00:A3:4B:69:8F:23:A9:08:8C:7A:58:12:89:
		29:80:19:7E:4A:72:48:44:D8:F0:82:36:F2:9F:40:C9:79:2A:F0:FE:
		66:3B:33:6B:C5:67:6D:40:79:C5:20:B5:81:8C:73:94:17:A5:CB:00:
		C4:61:24:0E:A6:35:4F:00:92:04:A9:B5:3A:D4:1C:E1:5E:7F:64:53:
		61:1D:67:DB:5E:44:E9:6B:97:AC:85:9C:B2:1E:F3:40:84:61:25:EE:
		AC:9C:06:D6:B7:84:4B:B7:17:31:73:71:B1:6A:35:33:32:03:42:1A:
		56:62:7F:8D:4B:0F:08:99:61:42:A9:3D:DB:F9:7F:E7:E7:7B:8A:AE:
		93:9C:3C:A9:A5:90:2A:6B:84:B0:7A:81:EF:D9:B4:80:22:C0:C9:F6:
		20:F7:70:BA:20:BE:5E:4E:E5:AD:13:28:13:F6:A5:CA
parm:           napi_weight:int
parm:           csum:bool
parm:           gso:bool
parm:           napi_tx:bool
Comment 4 Martin Doucha 2022-09-16 09:40:29 UTC
Sorry, you're right.
Comment 5 Thomas Bogendoerfer 2022-09-17 11:04:09 UTC
I've missed a change in a merge commit during backport. Fix commit is now on my for-next branch.

https://build.suse.de/repositories/home:tsbogend:bsc1203479

has a kernel with the fix included.
Comment 6 Petr Cervinka 2022-09-19 07:23:38 UTC
(In reply to Thomas Bogendoerfer from comment #5)
> https://build.suse.de/repositories/home:tsbogend:bsc1203479

Tested kernel from above repo on x86_64 and works fine. Thanks for the fix.
Comment 7 Thomas Bogendoerfer 2022-09-21 11:33:20 UTC
*** Bug 1203612 has been marked as a duplicate of this bug. ***
Comment 9 Petr Cervinka 2022-10-07 11:06:15 UTC
Issue is fixed and verified.