Bug 1203732 - [Build 24.1] openQA test(UEFI + NON-SECUREBOOT) fails in installation - hang and VNC stalled
[Build 24.1] openQA test(UEFI + NON-SECUREBOOT) fails in installation - hang ...
Status: RESOLVED INVALID
Classification: openSUSE
Product: PUBLIC SUSE Linux Enterprise Server 15 SP5
Classification: openSUSE
Component: Installation
unspecified
x86-64 SLES 15
: P2 - High : Normal
: ---
Assigned To: E-mail List
https://openqa.nue.suse.com/tests/958...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2022-09-26 05:33 UTC by Ming Li
Modified: 2022-10-10 07:11 UTC (History)
3 users (show)

See Also:
Found By: openQA
Services Priority:
Business Priority:
Blocker: Yes
Marketing QA Status: ---
IT Deployment: ---


Attachments
serial0.txt (54.42 KB, text/plain)
2022-09-26 05:33 UTC, Ming Li
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ming Li 2022-09-26 05:33:23 UTC
Created attachment 861721 [details]
serial0.txt

## Observation
This test failed at the end of installation and hang there and VNC lost connection. Use vncviewer connect it only show black screen and force reboot then the case will pass.
https://openqa.nue.suse.com/tests/9600542#
In serial0.txt, it can prove the reboot hasn't started.

openQA test in scenario sle-15-SP5-Online-x86_64-autoyast_non_secure_boot@uefi fails in
[installation](https://openqa.nue.suse.com/tests/9583696/modules/installation/steps/10)

## Test suite description
Autoyast installation on UEFI mode with non_secure_boot.


## Reproducible

Fails since (at least) Build [21.1](https://openqa.nue.suse.com/tests/9518846)


## Expected result

Last good: [19.1](https://openqa.nue.suse.com/tests/9418251) (or more recent)


## Further details

Always latest result in this scenario: [latest](https://openqa.nue.suse.com/tests/latest?arch=x86_64&distri=sle&flavor=Online&machine=uefi&test=autoyast_non_secure_boot&version=15-SP5)
Comment 1 Michal Filka 2022-09-29 06:16:52 UTC
i don't see yast logs in between logs&assets. Could you collect them. You can use save_y2logs.
Comment 2 Ming Li 2022-10-08 07:24:16 UTC
(In reply to Michal Filka from comment #1)
> i don't see yast logs in between logs&assets. Could you collect them. You
> can use save_y2logs.

Sorry for so late reply, just come back from public holidays.
I can't reproduce this issue in local environment manually. And when this issue happened I can't switch tty to save y2log, but system is not dead, I can send ctrl-alt-del to restart then test pass.

I tried to set QEMUVGA=qxl then the issue is gone, I think it is something related the resolution, maybe for this ticket : https://progress.opensuse.org/issues/111992

So please close it, this should be a test issue.
Comment 3 Knut Alejandro Anderssen González 2022-10-10 07:11:15 UTC
(In reply to Ming Li from comment #2)
> (In reply to Michal Filka from comment #1)
> > i don't see yast logs in between logs&assets. Could you collect them. You
> > can use save_y2logs.
> 
> Sorry for so late reply, just come back from public holidays.
> I can't reproduce this issue in local environment manually. And when this
> issue happened I can't switch tty to save y2log, but system is not dead, I
> can send ctrl-alt-del to restart then test pass.
> 
> I tried to set QEMUVGA=qxl then the issue is gone, I think it is something
> related the resolution, maybe for this ticket :
> https://progress.opensuse.org/issues/111992
> 
> So please close it, this should be a test issue.

Closing it according to last comment.