Bug 694167 - YaST2 cannot configure RSA certificate for vsftpd
YaST2 cannot configure RSA certificate for vsftpd
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE 11.3
Classification: openSUSE
Component: YaST2
Final
x86-64 openSUSE 11.3
: P5 - None : Minor (vote)
: ---
Assigned To: Christopher Hofmann
Jiri Srain
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-17 00:20 UTC by Mészáros Gyula
Modified: 2016-10-26 15:32 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mészáros Gyula 2011-05-17 00:20:59 UTC
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

YaST2 can only set a DSA certificate for vsftpd, but not RSA certificate, however:
a) YaST2 CA management creates RSA certificates,
b) it's easy: YaST2 needs to put a rsa_cert_file line instead of dsa_cert_file into /etc/vsftpd


Reproducible: Always

Steps to Reproduce:
1. Start YaST2 and enter FTP Server configuration.
2. Go to the Expert Settings page
3. It's the end: there is no way to enter RSA certificate.
Actual Results:  
There is no way to enter RSA certificate for vsftpd, it enters only a dsa_cert_file line into /etc/vsftpd.conf.

Expected Results:  
There should be a way to enter RSA certificate for vsftpd, entering simply an rsa_cert_file line into /etc/vsftpd.conf.
Comment 1 Zhi Juan Jia 2011-05-17 02:33:19 UTC
Please attach y2logs. If you are in doubt follow:
http://en.opensuse.org/openSUSE:Bugreport_YaST
Thanks!
Comment 2 Mészáros Gyula 2011-05-17 03:38:45 UTC
What kinda logs you mean exactly? There is no way to add an RSA certificate for vsftpd with YaST2, because there is no such button or menu point to press, so it is not in any logs at all - simply because it does not happen.
Comment 6 Christopher Hofmann 2016-10-26 15:32:43 UTC
Fixed in yast2-ftp-server-3.2.0