Bug 735865 - add BuildRequires: python-cups to printer driver packages
add BuildRequires: python-cups to printer driver packages
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE 12.2
Classification: openSUSE
Component: Printing
Factory
All SUSE Other
: P4 - Low : Enhancement (vote)
: Factory
Assigned To: Johannes Meixner
Johannes Meixner
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-09 12:14 UTC by Ludwig Nussel
Modified: 2020-07-08 13:27 UTC (History)
0 users

See Also:
Found By: Development
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ludwig Nussel 2011-12-09 12:14:50 UTC
all printer driver packages should have

BuildRequires: python-cups

python-cups installs special rpm macros that adds Provides tags for the printer drivers supported by the package.
See gutenprint for an example how the resulting rpm looks like.

See also bug 735864
Comment 1 Johannes Meixner 2011-12-09 13:01:33 UTC
This is not a bug which will be fixed for openSUSE 12.1
but an enhancement request for the next openSUSE version.
Comment 2 Johannes Meixner 2012-04-13 13:46:49 UTC
Implemented for HPLIP
via openSUSE build system submitrequest 113411
in the development project "Printing"
(will be forwarded to openSUSE:Factory).
Comment 3 Johannes Meixner 2012-04-13 14:13:20 UTC
For my own information:
http://lists.opensuse.org/opensuse-packaging/2011-05/msg00158.html

I wonder how this works in general for sub-packages because
for HPLIP it is not the main-package hplip which provides
the printer driver but its sub-package hplip-hpijs.
For HPLIP this does not really matter because the main-package
hplip requires its sub-package hplip-hpijs.
Comment 4 Johannes Meixner 2012-12-07 09:57:04 UTC
For my own information, regarding comment#3
"how this works in general for sub-packages":

At least for HPLIP it "magically" works in the right way.
In hplip.spec I have only "BuildRequires: python-cups"
which results that the right binary RPM hplip-hpijs has
the RPM provides "postscriptdriver(manufacturer; model;)".
Comment 5 Johannes Meixner 2013-02-22 14:38:25 UTC
Added "BuildRequires: python-cups" to
OpenPrintingPPDs
epson-inkjet-printer-escpr
m2300w
splix
so that now all printer driver packages
in the OBS "Printing" project have it.
Comment 7 Swamp Workflow Management 2020-04-15 16:25:21 UTC
SUSE-RU-2020:0998-1: An update that has one recommended fix can now be installed.

Category: recommended (moderate)
Bug References: 735865
CVE References: 
Sources used:
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1 (src):    python-pycups-1.9.74-3.3.2
SUSE Linux Enterprise Module for Desktop Applications 15-SP1 (src):    python-pycups-1.9.74-3.3.2

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 8 Swamp Workflow Management 2020-05-01 22:15:45 UTC
openSUSE-RU-2020:0583-1: An update that has one recommended fix can now be installed.

Category: recommended (moderate)
Bug References: 735865
CVE References: 
Sources used:
openSUSE Leap 15.1 (src):    python-pycups-1.9.74-lp151.3.3.1
Comment 9 Swamp Workflow Management 2020-07-08 13:27:23 UTC
SUSE-RU-2020:0998-2: An update that has one recommended fix can now be installed.

Category: recommended (moderate)
Bug References: 735865
CVE References: 
Sources used:
SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP2 (src):    python-pycups-1.9.74-3.3.2
SUSE Linux Enterprise Module for Desktop Applications 15-SP2 (src):    python-pycups-1.9.74-3.3.2

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.