Bug 780621 - YaST Installer continues to ignore low-vision accessibility
YaST Installer continues to ignore low-vision accessibility
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE 12.2
Classification: openSUSE
Component: YaST2
Final
Other openSUSE 12.2
: P2 - High : Major (vote)
: ---
Assigned To: Imobach Gonzalez Sosa
Jiri Srain
:
Depends on: 768112
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-15 14:56 UTC by Bryen Yunashko
Modified: 2021-03-09 12:13 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
kernel command line on installation screen (477.53 KB, image/png)
2012-09-20 07:32 UTC, Gabriele Mohr
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bryen Yunashko 2012-09-15 14:56:41 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:15.0) Gecko/20100101 Firefox/15.0

YaST uses a bright white background for the dialogue windows during installation.  This is a big no-no for low-vision users as well as for people with aging eyes.

Typically, many low-vision users are extremely sensitive to white on screen.  We tend to set our desktops to have a black background with white font.   

As my vision continues to deteriorate, I am having more difficulty with each openSUSE release to be able to see the screen and select my options.  While I know there is a text-based install, even the default for YaST-ncurses is not a low-vision friendly color and requires you to edit a file to change the default color options.  (I've never tried this during actual install, only during normal installed usage of openSUSE.)

That is simply not an optimal solution for low-vision users, especially new users who may not have experience in how to configure in the background.

Please devise a plan to provide alternative visual options for users.  Perhaps a toggle-button that automatically inverts the colors of the install dialogues or alternative graphics screen that provides a darker background.

This is not a protest statement, but a factual one... with my continued declining vision, if this is not fixed by 12.3, it is quite possible that I will no longer be able to install and use openSUSE.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Comment 1 Gabriele Mohr 2012-09-18 11:33:27 UTC
For 'qt' there (theoretically) is the possibility to switch to high contrast mode by pressing Shift F4. 
This doesn't work any longer, the bug is tracked in bnc #768112 - yast2-qt high contrast mode broken.
I will check how the mode can be set for ncurses during installation.
Comment 2 Gabriele Mohr 2012-09-19 11:59:40 UTC
For ncurses the color mode used during installation can be set on the kernel command line. The available themes for Y2NCURSES_COLOR_THEME are specified in /etc/sysconfig/yast2, e.g. set 'textmode=1 Y2NCURSES_COLOR_THEME="inverted"'.
I will add this info to the YaST portal on openSUSE wiki.
Comment 3 Bryen Yunashko 2012-09-19 12:27:25 UTC
Shift+F4 is a good option that I'll have to watch for when it is working again.

Typing into a command line is not intuitive and requires user to be confident enough to go in and edit files.  Additionally, we'd have to go back and forth into the file until we find the mode that works best for us.  I would prefer a toggle function within ncurses-yast instead that allows us to toggle through the differnet color options until we find one satisfactory for ourselves.

Additionally, a user would have to know how to call up a text editor in the first place.   Which editor is available during installation process?  What they may already be familiar with may not be available in installation process yet.  VI?  Emacs?  Pico?

For the record, my ncurses-yast has been set for a while now to rxvt.  But even though it is described as using a black background, it is actually using a grey background, so the conversion isn't optimal.
Comment 4 Bryen Yunashko 2012-09-20 03:19:58 UTC
I ust did a quick check of installation in virtualbox by switching to text mode with ncurses-yast visible.  Then I did Alt+F1 to switch to terminal and saw there is not yet have /etc/sysconfig/yast so it would appear there is no way to configure color settings during installation of openSUSE.

As a side note, when I'm in graphical mode, if I expand my virtualbox window, the GUI installer expands with it to keep fit in window.  But ncurses-yast does not do that.  It remains a small view even with window expanded.  Is this a bug?
Comment 5 Gabriele Mohr 2012-09-20 07:20:39 UTC
(In reply to comment #4)
> I ust did a quick check of installation in virtualbox by switching to text mode
> with ncurses-yast visible.  Then I did Alt+F1 to switch to terminal and saw
> there is not yet have /etc/sysconfig/yast so it would appear there is no way to
> configure color settings during installation of openSUSE.
The color mode can be set as boot option 'Y2NCURSES_COLOR_THEME' on the kernel command line at the very begin of the installation (available values are: xterm, linux, rxvt, mono, inverted, highcontrast), for an example see screenshot in attachment.
> 
> As a side note, when I'm in graphical mode, if I expand my virtualbox window,
> the GUI installer expands with it to keep fit in window.  But ncurses-yast does
> not do that.  It remains a small view even with window expanded.  Is this a
> bug?
I cannot reproduce this with the VirtualBox on my system, the text mode window is quite as big as the graphical.
Comment 6 Gabriele Mohr 2012-09-20 07:32:49 UTC
Created attachment 506385 [details]
kernel command line on installation screen
Comment 7 Gabriele Mohr 2012-09-20 11:00:23 UTC
An easier way to select the color mode for ncurses can be added at the installation screen. F3 already offers Textmode. This menu entry can be expanded by a sub menu which offers the available modes.
Comment 8 Lukas Ocilka 2016-09-29 10:11:22 UTC
The team will take care of it in this sprint. We are looking for a simple
way of making it as easy as possible.
Comment 9 Bernhard Wiedemann 2016-10-19 12:01:09 UTC
This is an autogenerated message for OBS integration:
This bug (780621) was mentioned in
https://build.opensuse.org/request/show/436118 42.2 / installation-images-openSUSE
Comment 11 Imobach Gonzalez Sosa 2017-08-08 07:01:14 UTC
Although there is room for improvement, the installer already implements support for low-vision accessibility. Closing the bug report.
Comment 12 Swamp Workflow Management 2019-10-28 20:19:59 UTC
SUSE-RU-2019:2796-1: An update that has four recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1009914,1033202,1132363,780621
CVE References: 
Sources used:
SUSE OpenStack Cloud 7 (src):    gfxboot-4.5.21-7.3.1
SUSE Linux Enterprise Server for SAP 12-SP2 (src):    gfxboot-4.5.21-7.3.1
SUSE Linux Enterprise Server 12-SP2-LTSS (src):    gfxboot-4.5.21-7.3.1
SUSE Linux Enterprise Server 12-SP2-BCL (src):    gfxboot-4.5.21-7.3.1
SUSE Linux Enterprise Point of Sale 12-SP2 (src):    gfxboot-4.5.21-7.3.1
SUSE Enterprise Storage 4 (src):    gfxboot-4.5.21-7.3.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.