Bug 793709 - DVD left as enabled software source after installing from USB thumb drive, prevents software installation
DVD left as enabled software source after installing from USB thumb drive, pr...
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE 12.2
Classification: openSUSE
Component: Installation
Final
x86-64 openSUSE 12.2
: P5 - None : Normal (vote)
: ---
Assigned To: Jiří Suchomel
Jiri Srain
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-10 17:51 UTC by Michael Catanzaro
Modified: 2021-03-09 12:13 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
y2logs (1.30 MB, application/x-gzip)
2012-12-10 17:51 UTC, Michael Catanzaro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Catanzaro 2012-12-10 17:51:36 UTC
Created attachment 516396 [details]
y2logs

User-Agent:       Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/535.22+ (KHTML, like Gecko) Chromium/17.0.963.56 Chrome/17.0.963.56 Safari/535.22+ SUSE/12.2 (3.4.2) Epiphany/3.4.2

After a fresh 12.2 install using a USB thumb drive and the DVD image, the removable USB drive is left as an installation source. *This prevents software installation after the USB drive is removed.* (See the warning message below.) Disabling or removing the USB repo solves the problem, but the average user won't know how to do this.

michael@linux-wrb5:~> zypper lr -d
# | Alias                     | Name                               | Enabled | Refresh | Priority | Type  | URI                                                                            | Service
--+---------------------------+------------------------------------+---------+---------+----------+-------+--------------------------------------------------------------------------------+--------
1 | openSUSE-12.2-1.6         | openSUSE-12.2-1.6                  | Yes     | Yes     |   99     | yast2 | hd:///?device=/dev/disk/by-id/usb-SanDisk_Cruzer_Edge_20052845210F4F819323-0:0 |        
2 | repo-debug                | openSUSE-12.2-Debug                | No      | Yes     |   99     | NONE  | http://download.opensuse.org/debug/distribution/12.2/repo/oss/                 |        
3 | repo-debug-update         | openSUSE-12.2-Update-Debug         | No      | Yes     |   99     | NONE  | http://download.opensuse.org/debug/update/12.2/                                |        
4 | repo-debug-update-non-oss | openSUSE-12.2-Update-Debug-Non-Oss | No      | Yes     |   99     | NONE  | http://download.opensuse.org/debug/update/12.2-non-oss/                        |        
5 | repo-non-oss              | openSUSE-12.2-Non-Oss              | Yes     | Yes     |   99     | NONE  | http://download.opensuse.org/distribution/12.2/repo/non-oss/                   |        
6 | repo-oss                  | openSUSE-12.2-Oss                  | Yes     | Yes     |   99     | NONE  | http://download.opensuse.org/distribution/12.2/repo/oss/                       |        
7 | repo-source               | openSUSE-12.2-Source               | No      | Yes     |   99     | NONE  | http://download.opensuse.org/source/distribution/12.2/repo/oss/                |        
8 | repo-update               | openSUSE-12.2-Update               | Yes     | Yes     |   99     | NONE  | http://download.opensuse.org/update/12.2/                                      |        
9 | repo-update-non-oss       | openSUSE-12.2-Update-Non-Oss       | Yes     | Yes     |   99     | NONE  | http://download.opensuse.org/update/12.2-non-oss/

Reproducible: Always

Steps to Reproduce:
1. Get the DVD installation image from software.opensuse.org and dd it to a USB thumb drive
2. Install
3. Try to install gcc - get the below warning.
4. Run YaST online update (twice)
5. Still getting the warning.
Actual Results:  
I get the following warning:

"Cannot access installation media
hd:///?device=/dev/disk/by-id/usb-SanDisk_Cruzer_Edge_20052845210F4F819323-0:0
openSUSE-12.2-1.6 (Medium 1).
Check whether the server is accessible."


Expected Results:  
"Check whether the server is accessible" isn't a valid error message for this situation, for one thing, but for another the source should not be left enabled by default.

This also leads to frequent warning notifications from Apper:

"Problem connecting to a software origin

Empty destination in URI: hd:///?device=/dev/disk/by-id/usb-SanDisk_Cruzer_Edge_20052845210F4F819323-0:0"


--------------------

By the way, I'm aware that there's an installation option that I *believe* disables the repo after installation?  (I didn't test that option since I already ran two installs as part of this report.) But it's not ever presented to the user - you'd have to scroll down the list of options that's presented just before installation begins to change the setting, and the average user won't even know what it means. We should make it seamless by default.

--------------------------------------------

Lastly, there's a discussion on this in the forums: https://forums.opensuse.org/english/get-technical-help-here/install-boot-login/481256-dvd-still-enabled-software-sources-after-install-bug-report.html
Comment 1 Jiří Suchomel 2012-12-12 16:04:27 UTC
Well, maybe we should disable USB sources after installation.

Do we have a good way to detect such source - Ladislav, Michael?
Comment 2 Ladislav Slezák 2012-12-12 17:05:19 UTC
I'm not sure if we can do it, hd:// scheme is generic for any storage device, we can only guess it's USB based when the URL contains "device=/dev/disk/by-id/usb-" substring.

This trick is used in the repository manager, if you add repository via Add -> USB Mass Storage.

This obviously will work only for by-id mounts.
Comment 3 Jiří Suchomel 2012-12-13 08:31:30 UTC
I'll look into it
Comment 4 Jiří Suchomel 2012-12-14 12:43:33 UTC
Here is the pull request that should solve it:

https://github.com/yast/yast-installation/pull/14

However, I do not have ways for testing it...
Comment 5 Jiří Suchomel 2012-12-14 15:57:25 UTC
done in 2.23.5, let's see in next build
Comment 6 Bernhard Wiedemann 2012-12-14 16:00:09 UTC
This is an autogenerated message for OBS integration:
This bug (793709) was mentioned in
https://build.opensuse.org/request/show/145507 Factory / yast2-installation