Bug 796017 - VUL-0: CVE-2012-0882: mysql/yaSSL buffer overflow
VUL-0: CVE-2012-0882: mysql/yaSSL buffer overflow
Status: RESOLVED FIXED
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Normal
: ---
Assigned To: Michal Hrusecky
Security Team bot
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-27 15:52 UTC by Marcus Meissner
Modified: 2014-03-04 15:58 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcus Meissner 2012-12-27 15:52:50 UTC
is public, via cve db

CVE-2012-0882

Buffer overflow in yaSSL, as used in MySQL 5.5.20 and possibly other versions including 5.5.x before 5.5.22 and 5.1.x before 5.1.62, allows remote attackers to execute arbitrary code via unspecified vectors, as demonstrated by VulnDisco Pack Professional 9.17.  NOTE: as of 20120224, this disclosure has no actionable information. However, because the module author is a reliable researcher, the issue is being assigned a CVE identifier for tracking purposes.  NOTE: due to lack of details, it is not clear whether this issue is a duplicate of CVE-2012-0492 or another CVE.
Reference: MLIST: https://lists.immunityinc.com/pipermail/canvas/2012-February/000014.html
Reference: MLIST: https://lists.immunityinc.com/pipermail/canvas/2012-February/000011.html
Reference: MISC: https://bugzilla.redhat.com/show_bug.cgi?id=789141
Reference: MISC: https://blogs.oracle.com/sunsecurity/entry/cve_2012_0882buffer_overflow_vulnerability
Reference: MLIST: http://www.openwall.com/lists/oss-security/2012/02/24/2


(we cover the 5.1 and 5.5 mysql affectedness by the version updates I hope)
Comment 1 Marcus Meissner 2012-12-27 16:16:21 UTC
(needs cross checking as information was not reliable)
Comment 2 Swamp Workflow Management 2012-12-27 23:00:29 UTC
bugbot adjusting priority
Comment 3 Sebastian Krahmer 2013-01-14 13:31:08 UTC
Michal, can you confirm this?
Comment 4 Michal Hrusecky 2013-01-16 17:18:46 UTC
SLE11, and all openSUSE versions are not affected as we compile it with openssl instead of yaSSL. Might possibly affect SLE10 with version 5.0.26.
Comment 5 Matthias Weckbecker 2013-07-01 15:37:02 UTC
CVSS Scorting for the issue(s):

$VAR1 = \{
            'CVE-2012-0882' => '6.8/AV:N/AC:M/Au:N/C:P/I:P/A:P',
            'CVE-2012-0492' => '2.1/AV:N/AC:H/Au:S/C:N/I:N/A:P'
          };
Comment 6 Marcus Meissner 2014-03-04 15:58:01 UTC
We will not release mysql updates for older products anymore, and SLES 11 SP3
has mysql 5.5 which is fixed.