Bug 803023 - kopete crashed
kopete crashed
Status: RESOLVED DUPLICATE of bug 803004
Classification: openSUSE
Product: openSUSE 12.3
Classification: openSUSE
Component: KDE4 Applications
RC 1
Other Other
: P5 - None : Critical (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-11 08:59 UTC by Andreas Jaeger
Modified: 2013-02-11 11:05 UTC (History)
0 users

See Also:
Found By: Product Management
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Jaeger 2013-02-11 08:59:13 UTC
I had kopete just running idly and got the following crash,
Andreas

Application: Kopete (kopete), signal: Aborted
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f171cd9d780 (LWP 7832))]

Thread 3 (Thread 0x7f16fe2c8700 (LWP 7868)):
#0  0x00007f1713b39815 in ?? () from /usr/lib64/libglib-2.0.so.0
#1  0x00007f1713b39a99 in g_mutex_unlock () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f1713afca99 in ?? () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f1713afcbc4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f171a8041c6 in QEventDispatcherGlib::processEvents (this=0x7f16f00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007f171a7d49bf in QEventLoop::processEvents (this=this@entry=0x7f16f00013c0, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f171a7d4c48 in QEventLoop::exec (this=0x7f16f00013c0, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f17052dc71e in QCA::SyncThread::run() () from /usr/lib64/libqca.so.2
#8  0x00007f171a6da09c in QThreadPrivate::start (arg=0x263ee10) at thread/qthread_unix.cpp:338
#9  0x00007f1718bf7e0f in start_thread () from /lib64/libpthread.so.0
#10 0x00007f17191587dd in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f16fd2c6700 (LWP 7870)):
#0  0x00007f171914f87d in poll () from /lib64/libc.so.6
#1  0x00007f1713afcaa4 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f1713afcbc4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f171a8041c6 in QEventDispatcherGlib::processEvents (this=0x7f16e80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f171a7d49bf in QEventLoop::processEvents (this=this@entry=0x7f16e80013c0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f171a7d4c48 in QEventLoop::exec (this=0x7f16e80013c0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f1705728f6f in ?? () from /usr/lib64/kde4/kopete_jabber.so
#7  0x00007f171a6da09c in QThreadPrivate::start (arg=0x21f32e0) at thread/qthread_unix.cpp:338
#8  0x00007f1718bf7e0f in start_thread () from /lib64/libpthread.so.0
#9  0x00007f17191587dd in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f171cd9d780 (LWP 7832)):
[KCrash Handler]
#6  0x00007f17190a53d5 in raise () from /lib64/libc.so.6
#7  0x00007f17190a6858 in abort () from /lib64/libc.so.6
#8  0x00007f171a6cfc24 in qt_message_output (msgType=msgType@entry=QtFatalMsg, buf=<optimized out>) at global/qglobal.cpp:2323
#9  0x00007f171a6cfdd8 in qt_message(QtMsgType, const char *, typedef __va_list_tag __va_list_tag *) (msgType=msgType@entry=QtFatalMsg, msg=msg@entry=0x7f171a838bc8 "ASSERT: \"%s\" in file %s, line %d", ap=ap@entry=0x7fffd0f89058) at global/qglobal.cpp:2369
#10 0x00007f171a6cff64 in qFatal (msg=msg@entry=0x7f171a838bc8 "ASSERT: \"%s\" in file %s, line %d") at global/qglobal.cpp:2552
#11 0x00007f171a6cffaa in qt_assert (assertion=<optimized out>, file=<optimized out>, line=<optimized out>) at global/qglobal.cpp:2018
#12 0x00007f170532fe08 in ?? () from /usr/lib64/libqca.so.2
#13 0x00007f171a7eb17f in QMetaObject::activate (sender=0x24ae350, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3548
#14 0x00007f171a7ea65e in QObject::event (this=0x24ae350, e=<optimized out>) at kernel/qobject.cpp:1203
#15 0x00007f171990286c in QApplicationPrivate::notify_helper (this=this@entry=0x1b8e990, receiver=receiver@entry=0x24ae350, e=e@entry=0x2459490) at kernel/qapplication.cpp:4562
#16 0x00007f1719906ceb in QApplication::notify (this=0x7fffd0f89cd0, receiver=0x24ae350, e=0x2459490) at kernel/qapplication.cpp:4423
#17 0x00007f171b23acb6 in KApplication::notify (this=0x7fffd0f89cd0, receiver=0x24ae350, event=0x2459490) at /usr/src/debug/kdelibs-4.10.0/kdeui/kernel/kapplication.cpp:311
#18 0x00007f171a7d5c6e in QCoreApplication::notifyInternal (this=0x7fffd0f89cd0, receiver=receiver@entry=0x24ae350, event=event@entry=0x2459490) at kernel/qcoreapplication.cpp:946
#19 0x00007f171a7d95d1 in sendEvent (event=0x2459490, receiver=0x24ae350) at kernel/qcoreapplication.h:231
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1b471f0) at kernel/qcoreapplication.cpp:1570
#21 0x00007f171a804013 in sendPostedEvents () at kernel/qcoreapplication.h:236
#22 postEventSourceDispatch (s=0x1b8acb0) at kernel/qeventdispatcher_glib.cpp:279
#23 0x00007f1713afc7d5 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#24 0x00007f1713afcb08 in ?? () from /usr/lib64/libglib-2.0.so.0
#25 0x00007f1713afcbc4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#26 0x00007f171a8041a6 in QEventDispatcherGlib::processEvents (this=0x1b4ca70, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#27 0x00007f17199a2c1e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#28 0x00007f171a7d49bf in QEventLoop::processEvents (this=this@entry=0x7fffd0f89ba0, flags=...) at kernel/qeventloop.cpp:149
#29 0x00007f171a7d4c48 in QEventLoop::exec (this=0x7fffd0f89ba0, flags=...) at kernel/qeventloop.cpp:204
#30 0x00007f171a7d98e8 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#31 0x000000000041499b in ?? ()
#32 0x00007f1719091a15 in __libc_start_main () from /lib64/libc.so.6
#33 0x0000000000414a01 in _start ()
Comment 1 Andreas Jaeger 2013-02-11 11:05:57 UTC
Fixed after updating openssl

*** This bug has been marked as a duplicate of bug 803004 ***