Bug 820382 - Interface wwan0 not listed in Yast-firewall module
Interface wwan0 not listed in Yast-firewall module
Status: RESOLVED DUPLICATE of bug 578787
Classification: openSUSE
Product: openSUSE 12.3
Classification: openSUSE
Component: YaST2
Final
x86-64 openSUSE 12.3
: P5 - None : Normal (vote)
: ---
Assigned To: Michal Filka
Jiri Srain
GOLD
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-17 08:55 UTC by Keks Dose
Modified: 2016-10-20 12:14 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Keks Dose 2013-05-17 08:55:23 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:20.0) Gecko/20100101 Firefox/20.0

The YAST2-firewall-module does not list wwan-interfaces, even if they are active. Maybe this ist the cause:

File

/usr/share/YAST2/modules/NetworkInterfaces.ycp

contents:

====================================

/**
 * Predefined network card regular expressions
 */
global map<string,string> CardRegex = $[
    "netcard"	: "arc|ath|bnep|ci|ctc|dummy|bond|escon|eth|fddi|ficon|hsi|qeth|lcs|iucv|myri|tr|usb|wlan|xp|vlan|br|tun|tap|ib|em|p|p[0-9]+p",
    "modem"	: "ppp|modem",
    "isdn"	: "isdn|ippp",
    "dsl"	: "dsl",
    /* other: irlan|lo|plip|... */
];

====================================

As you can see, "wwan" is missing. Discussion see here:
https://forums.opensuse.org/english/get-technical-help-here/network-internet/486988-wwan-susefirewall2.html

However, I'd think that the Yast2-firewall-modul should be able to recognise / customize the wwan - interface.

I don't no anything about firewalls, so if I'm completely wrong, just close this thread. 

Reproducible: Always

Steps to Reproduce:
1.Boot a machine with an umts-card
2.make wwan work
3.Open YAST2-firewall modul: no wwan
Actual Results:  
no wwan listed in YAST2-firewall-modul

Expected Results:  
'shouldn't it be listed?
Comment 1 Josef Reidinger 2016-10-20 12:14:53 UTC
already reported

*** This bug has been marked as a duplicate of bug 578787 ***