Bug 893275 - Mesa fails to build for power
Mesa fails to build for power
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: X.Org
201408*
PowerPC-64 openSUSE 13.2
: P3 - Medium : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-08-24 13:08 UTC by Dinar Valeev
Modified: 2015-02-11 15:06 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
assert_include.patch (355 bytes, text/plain)
2014-09-25 19:32 UTC, Dinar Valeev
Details
Mesa-fix-llvm-link.patch (509 bytes, patch)
2014-09-25 19:33 UTC, Dinar Valeev
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dinar Valeev 2014-08-24 13:08:19 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0

Mesa fails to build for PowerPC in Factory.

See build log: https://build.opensuse.org/package/show/openSUSE:Factory:PowerPC/Mesa

Reproducible: Always

Steps to Reproduce:
1. Build Mesa for PowerPC

Actual Results:  
Fails to build due to various reasons

Expected Results:  
Mesa build succeeds
Comment 1 Stefan Dirsch 2014-08-25 08:08:46 UTC
Build for ppc64le you've fixed yourself via SR#246142.
Comment 2 Dinar Valeev 2014-08-25 10:41:04 UTC
Yeah.. That was easy one :)

ppc64 fails seems to be related to llvm.
Comment 3 Bernhard Wiedemann 2014-08-25 11:00:26 UTC
This is an autogenerated message for OBS integration:
This bug (893275) was mentioned in
https://build.opensuse.org/request/show/246335 Factory / Mesa
Comment 4 Dinar Valeev 2014-09-25 19:32:22 UTC
Created attachment 607989 [details]
assert_include.patch

This patch is required in order to build with -Werror
Comment 5 Dinar Valeev 2014-09-25 19:33:30 UTC
Created attachment 607991 [details]
Mesa-fix-llvm-link.patch

This one resolves undefined reference to `setupterm'
Comment 6 Dinar Valeev 2014-09-25 19:34:35 UTC
Both patches applicable to 10.3.0-rc1, if I try to apply them to Factory (which is 10.3.0) build fails with: 
[  560s] /usr/lib64/gcc/powerpc64-suse-linux/4.8/../../../../powerpc64-suse-linux/bin/ld: cannot find -ltinfo
[  560s] collect2: error: ld returned 1 exit status

weird
Comment 7 Stefan Dirsch 2014-09-26 09:46:14 UTC
BTW, before submitrequesting anything, please read

  https://en.opensuse.org/openSUSE:Patches_Guidelines_for_X11:XOrg_Project

beforehand. Thanks.
Comment 8 Dinar Valeev 2015-02-11 15:06:58 UTC
Fixed