Bug 901751 - Not functional YAST2 -> NTP -> Synchronize without daemon
Not functional YAST2 -> NTP -> Synchronize without daemon
Status: RESOLVED FIXED
: 915699 (view as bug list)
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: YaST2
13.2
Other Other
: P5 - None : Major (vote)
: ---
Assigned To: Peter Varkoly
Jiri Srain
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-10-17 13:23 UTC by Daniel Noga
Modified: 2015-06-22 13:30 UTC (History)
6 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
YaST2 logs (3.65 MB, application/x-compressed-tar)
2014-10-30 20:14 UTC, Daniel Noga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Noga 2014-10-17 13:23:18 UTC
Not functional YAST2 -> NTP -> Synchronize without daemon. Clean installation openSUSE 13.2 20141007 factory DVD iso with /home from old openSUSE 12.3 (but IMHO, YAST2 settings are not in /home, so I think old /home is not the case)


(It is major issue for me because I have problem with broken notebook which erase time after every plug in electricity and I must start manual NTP synchronization.)
Comment 1 Gabriele Mohr 2014-10-30 09:26:14 UTC
Please attach YaST log-files, see
http://en.opensuse.org/openSUSE:Report_a_YaST_bug.
Comment 2 Daniel Noga 2014-10-30 20:14:30 UTC
Created attachment 611913 [details]
YaST2 logs
Comment 3 John Serock 2015-02-28 09:04:44 UTC
I was having the same issue in openSUSE 13.2 64-bit. Inserting the following line at the beginning of the generated /etc/cron.d/novell.ntp-synchronize file resolved the issue for me (I now see NTP traffic in Wireshark):

PATH=/sbin:/usr/sbin:/bin:/usr/bin
Comment 4 Wolfgang Bauer 2015-03-08 09:56:42 UTC
I just noticed the same here when I was wondering why my system clock always is wrong and doesn't get synchronized. After removing the "&>/dev/null" from /etc/cron.d/novell.ntp-synchronize I get EMails from cron every 5 minutes with the content:
From root@linux-lf90.site  Sun Mar  8 10:35:01 2015
X-Original-To: root
Delivered-To: root@linux-lf90.site
From: "(Cron Daemon)" <root@linux-lf90.site>
To: root@linux-lf90.site
Subject: Cron <root@linux-lf90> /usr/sbin/start-ntpd ntptimeset 
Content-Type: text/plain; charset=UTF-8
Auto-Submitted: auto-generated
Precedence: bulk
X-Cron-Env: <XDG_SESSION_ID=227>
X-Cron-Env: <XDG_RUNTIME_DIR=/run/user/0>
X-Cron-Env: <LANG=de_AT.UTF-8>
X-Cron-Env: <SHELL=/bin/sh>
X-Cron-Env: <HOME=/root>
X-Cron-Env: <PATH=/usr/bin:/bin>
X-Cron-Env: <LOGNAME=root>
X-Cron-Env: <USER=root>
Date: Sun,  8 Mar 2015 10:35:01 +0100 (CET)

Time could not be synchronized


Adding PATH=/sbin:/usr/sbin:/bin:/usr/bin to /etc/cron.d/novell.ntp-synchronize as mentioned in comment#3 fixes it.

Another (probably better) fix would be to explicitely call /usr/sbin/sntp in line#237 in /usr/sbin/start-ntp, which it already does in function add_runtime_server() (line#141).

So this should either be fixed in yast2-ntp-client (which writes /etc/cron.d/novell.ntp-synchronize in line 885ff in /usr/share/YaST2/modules/NtpClient.rb), or in ntp's /usr/sbin/start-ntp script.

CC'ing the ntp maintainer.
Comment 5 Wolfgang Bauer 2015-03-08 20:30:55 UTC
I submitted a fixed ntp package to the devel project:
https://build.opensuse.org/request/show/289929

@maintenance team:
Can we please do an update for 13.2?
Comment 6 Benjamin Brunner 2015-03-09 12:59:16 UTC
As soon as it's accepted in the devel-project, we can start an update for 13.2 too. 

Thank in advance.
Comment 7 Wolfgang Bauer 2015-03-09 14:38:31 UTC
(In reply to Benjamin Brunner from comment #6)
> As soon as it's accepted in the devel-project, we can start an update for
> 13.2 too. 
It has been accepted, so here's the Maintenance Request:
https://build.opensuse.org/request/show/290045
Comment 8 Benjamin Brunner 2015-03-18 10:51:22 UTC
Update released for openSUSE 13.2. Resolved fixed.
Comment 9 Swamp Workflow Management 2015-03-18 11:06:23 UTC
openSUSE-RU-2015:0521-1: An update that has one recommended fix can now be installed.

Category: recommended (moderate)
Bug References: 901751
CVE References: 
Sources used:
openSUSE 13.2 (src):    ntp-4.2.6p5-25.9.1
Comment 10 Reinhard Max 2015-06-22 13:30:34 UTC
*** Bug 915699 has been marked as a duplicate of this bug. ***