Bug 904214 - Control characters are not interpreted in Linux console (tab, backspace, ctrl+c)
Control characters are not interpreted in Linux console (tab, backspace, ctrl+c)
Status: RESOLVED FIXED
: 932981 (view as bug list)
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Basesystem
13.2
All openSUSE 13.2
: P1 - Urgent : Major with 11 votes (vote)
: 13.2
Assigned To: Thomas Renninger
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-11-06 13:20 UTC by Tibor Volánszki
Modified: 2017-05-19 06:35 UTC (History)
15 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
vmware console bug screenshot (108.60 KB, image/png)
2014-11-06 13:20 UTC, Tibor Volánszki
Details
let-vconsole-setup-get-properties-only-once-to-copy-them.patch (2.82 KB, text/plain)
2015-09-17 11:43 UTC, Dr. Werner Fink
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tibor Volánszki 2014-11-06 13:20:36 UTC
Created attachment 612659 [details]
vmware console bug screenshot

The control characters (tab, backspace, ctrl+c/d, etc...) are not interpreted in any vmware console window. The problem is mostly the same after an distribution upgrade or after a fresh install. 

I attached a screenshot about it. On the left side there is an upgraded VM (13.1->13.2) and on the right side there is a newly installed system.

Via SSH everything is working fine, the problem exists only on console. By default the TERM variable is "linux" on console. Changing that to xterm does not help.

I tried it in vSphere Client at Windows (old Client) and in FireFox too (via Webclient), but the problem remains the same. 

Thank you in advance!
Comment 1 Bernhard Wiedemann 2014-11-06 18:05:47 UTC
seems to be some problem with the input of control characters
Comment 2 Xu Lian 2014-11-11 23:50:10 UTC
I confirm that this problem exist, but it's not vmware specific.

I just upgraded my tumbleweed from 13.1 to 13.2 and I have the same problem on my local console on my laptop (dell xps 13).

I can't input any control characters. Escape codes, that are shown instead of expected control chars, are the same as on Tibor's screenshot.

$ grep ^[^#] /etc/sysconfig/console
CONSOLE_FONT="lat2-16.psfu"
CONSOLE_UNICODEMAP=""
CONSOLE_SCREENMAP="8859-2"
CONSOLE_MAGIC="(K"
FB_MODULES=""
FBSET_PARAMS=""
CONSOLE_ENCODING="UTF-8"

$ grep ^[^#] /etc/sysconfig/language
INPUT_METHOD=""
RC_LANG="pl_PL"
RC_LC_ALL=""
RC_LC_MESSAGES=""
RC_LC_CTYPE=""
RC_LC_COLLATE="C"
RC_LC_TIME=""
RC_LC_NUMERIC=""
RC_LC_MONETARY=""
RC_LC_PAPER=""
ROOT_USES_LANG="ctype"
AUTO_DETECT_UTF8="no"
INSTALLED_LANGUAGES="pl_PL"

$ cat /etc/vconsole.conf
KEYMAP=Pl02
Comment 3 Bernhard Wiedemann 2014-11-15 08:27:53 UTC
OK, so if this is unrelated to VMware,
I think this is somehow related to the locales
which are HU and PL in this case - maybe not even UTF8?

and maybe it is made worse by some leftover entry from 13.1

however, I did not manage to reproduce it on a fresh (en_US) 13.2 install
by just changing sysconfig files as given in comment 2
and running mkinitrd
Comment 4 Tibor Volánszki 2014-11-19 09:47:08 UTC
Thank you for your comments, they were very helpful! 
Summarizing them, there is a workaround for this problem:

1. If you have an upgraded system, you should change the language to english in Yast and set the keyboard layout to what you want.
2. For a new system you should not modify the language option, only the keyboard layout. 

So we can avoid this bug, but it will remain a problem for many users. I hope it will be fixed soon!

Thx for your help!
Comment 5 Stanislav Brabec 2014-11-21 20:31:41 UTC
Looking at the /usr/share/YaST2/data/keyboard_raw.ycp, yast sets Polish keymap to Pl02. This keymap is grown from zero, not using any includes, but the map is incomplete, and it expects inheritance on English keyboard symbols:
/usr/share/kbd/keymaps/i386/qwerty/Pl02.map.gz

It probably stopped to work during migration of keymap set to Dracut.

This Polish keymap is broken, and either needs a fix, or use a different keymap.
Comment 6 Tibor Volánszki 2014-11-21 22:14:43 UTC
Not only the Polish, the Hungarian too. So probably there are more.
Comment 7 Weihua Du 2014-12-25 07:25:21 UTC
Stanislav, would you please take a look at this kbd problem?Thanks!
Comment 8 Xu Lian 2015-04-26 21:11:10 UTC
brain-dead fix:

go to any console (control-alt-fX), log in as root and run:
yast language
and then just exit yast without changing anything.
all consoles will be fixed until next reboot.

this is really annoying...
Comment 9 Stanislav Brabec 2015-05-04 18:31:46 UTC
I can (sometimes) reproduce this problem even in a non-virtual system in both openSUSE 13.2 and Factory.

It looks like a race condition in the dracut keyboard initialization.

I see no problem from the kbd package itself (except of independent problem of failing "loadkeys -d")

It is interesting that frequency of this problem varies from machine to machine. Some systems exhibit it nearly always, some only sometimes and some probably never.


There is an easy work around: Run command

unicode_start

And the loadkeys of your keymap.
Comment 10 Stanislav Brabec 2015-05-04 18:38:57 UTC
Update: loadkeys -d affects only 13.1, 13.2 is already fixed. This problem affects 13.2 and newer => There is no relation.
Comment 11 Dainius Masiliunas 2015-08-15 18:43:31 UTC
I can confirm this in both 13.2 and Tumbleweed, using Lithuanian localisation.
Comment 14 Dr. Werner Fink 2015-09-17 11:43:06 UTC
Created attachment 647655 [details]
let-vconsole-setup-get-properties-only-once-to-copy-them.patch

With this the kernel should do it correct.  It looks like the kernel does not like the mixed GIO* and PIO* ioctls for its virtual consoles.  This patch simply does the GIO* only once to spread then the results with the PIO* ioctls over the remaining virtual consoles.  Beside the correct results on the virtual consoles the systemd-vconsole-setup is a bit faster ;)
Comment 15 Dr. Werner Fink 2015-09-17 11:56:59 UTC
*** Bug 932981 has been marked as a duplicate of this bug. ***
Comment 17 Bernhard Wiedemann 2015-09-17 14:00:09 UTC
This is an autogenerated message for OBS integration:
This bug (904214) was mentioned in
https://build.opensuse.org/request/show/331793 13.1 / systemd
Comment 21 Bernhard Wiedemann 2015-09-23 11:00:10 UTC
This is an autogenerated message for OBS integration:
This bug (904214) was mentioned in
https://build.opensuse.org/request/show/333146 13.2 / systemd
Comment 25 Bernhard Wiedemann 2015-09-24 16:00:10 UTC
This is an autogenerated message for OBS integration:
This bug (904214) was mentioned in
https://build.opensuse.org/request/show/333485 13.2 / systemd
Comment 26 Bernhard Wiedemann 2015-09-25 15:00:34 UTC
This is an autogenerated message for OBS integration:
This bug (904214) was mentioned in
https://build.opensuse.org/request/show/333777 Factory / systemd
Comment 28 Swamp Workflow Management 2015-10-02 10:10:03 UTC
openSUSE-RU-2015:1669-1: An update that has 28 recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 900558,904214,906900,909358,912334,913517,916420,918118,920195,921831,921898,926169,927457,928265,931388,932284,933365,933512,933521,933533,934077,937512,937900,938908,939571,940264,941576,944132
CVE References: 
Sources used:
openSUSE 13.2 (src):    systemd-210-25.19.1, systemd-mini-210-25.19.1
Comment 31 Pal Korossy 2015-10-22 19:22:58 UTC
Same problem here but the patch is not available for me in repo update/13.2.
Comment 32 Swamp Workflow Management 2015-11-11 15:10:59 UTC
SUSE-RU-2015:1954-1: An update that has 24 recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 900558,904214,912334,913517,932284,933521,933533,934901,937512,937900,938908,939571,940264,941576,942946,944132,944799,945282,947212,948705,950510,951265,951663,953241
CVE References: 
Sources used:
SUSE Linux Enterprise Software Development Kit 12 (src):    systemd-210-70.25.1
SUSE Linux Enterprise Server 12 (src):    systemd-210-70.25.1
SUSE Linux Enterprise Desktop 12 (src):    systemd-210-70.25.1
Comment 33 Swamp Workflow Management 2016-02-03 14:42:26 UTC
openSUSE-RU-2016:0320-1: An update that has 146 recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 737690,742774,750845,818044,838475,841544,849870,852015,852021,852232,853293,854884,856389,856392,856858,857204,858864,859072,859365,860574,860937,861316,861489,863217,864745,864904,865834,866732,866933,867128,867663,867664,867840,868019,868230,868439,868931,869142,869603,872929,873432,873444,874665,875502,876587,876694,877021,877674,878525,880438,880732,881125,881559,881942,882393,882714,883565,884271,884403,885232,885288,886211,886599,886852,888178,888215,888612,889297,889357,890977,892096,892162,892300,893797,895087,896664,897799,897801,897803,898233,898240,898432,900558,901481,902240,902901,903009,903963,904214,904517,904828,905550,906709,906900,907318,907393,908476,909358,910643,911347,912030,912334,913517,916420,918118,919095,920195,921831,921898,921920,926169,927250,927457,928265,931388,932284,933365,933512,933521,933533,934077,934901,937512,937900,938908,939571,940264,941576,944132,944799,945282,947212,948458,948555,948705,949574,949683,949739,950510,951265,951663,953241,954336,954781,955635,961576
CVE References: 
Sources used:
openSUSE 13.1 (src):    systemd-210-40.1, systemd-mini-210-40.1
Comment 35 Swamp Workflow Management 2017-05-18 19:11:42 UTC
SUSE-RU-2017:1342-1: An update that has 8 recommended fixes can now be installed.

Category: recommended (low)
Bug References: 1018106,1023220,1025398,1025886,1026775,1029183,1029691,904214
CVE References: 
Sources used:
SUSE Linux Enterprise Server for SAP 12 (src):    systemd-210-70.64.3
SUSE Linux Enterprise Server 12-LTSS (src):    systemd-210-70.64.3
Comment 36 Swamp Workflow Management 2017-05-18 19:13:27 UTC
SUSE-RU-2017:1344-1: An update that has 8 recommended fixes can now be installed.

Category: recommended (low)
Bug References: 1018106,1023220,1025398,1025886,1026775,1029183,1029691,904214
CVE References: 
Sources used:
SUSE Linux Enterprise Software Development Kit 12-SP1 (src):    systemd-210-116.9.1
SUSE Linux Enterprise Server 12-SP1 (src):    systemd-210-116.9.1
SUSE Linux Enterprise Desktop 12-SP1 (src):    systemd-210-116.9.1