Bug 930505 - every package available in standard or optional repos is not discoverable via https://software.opensuse.org/search
every package available in standard or optional repos is not discoverable via...
Status: RESOLVED FIXED
: 1175428 1190980 (view as bug list)
Classification: openSUSE
Product: openSUSE.org
Classification: openSUSE
Component: Infrastructure
unspecified
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Ancor Gonzalez Sosa
Lars Vogdt
https://github.com/openSUSE/software-...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-05-12 08:04 UTC by Felix Miata
Modified: 2021-10-06 02:25 UTC (History)
11 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
screenshot of https://software.opensuse.org/search results from typing mc in search box and clicking on search (458.46 KB, image/png)
2016-10-30 08:51 UTC, Felix Miata
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Felix Miata 2015-05-12 08:04:09 UTC
mc is the package name and binary executable for the best available file manager in openSUSE repos.

Latest Midnight Commander (mc) not discoverable via https://software.opensuse.org/search .

Until recently, current mc for 13.1 could be found on http://download.opensuse.org/repositories/Base:/System/openSUSE_13.2/ but this repo has been retired.

Searching https://software.opensuse.org/search for search term commander produces no hits for Midnight Commander or mc.

Search term mc is not acceptable to https://software.opensuse.org/search, as it rejects two character search strings, first by announcement, then when proceeding anyway, searching for mc only as a substring, listing many packages containing string mc but not mc itself.

I tried searching for latest mc on https://build.opensuse.org/search but as I am not a builder I found it too difficult to use to locate latest (mc-4.8.14) even with help from irc://freenode/opensuse-factory.

Something needs to be done so that every package that exists in standard or BS repos can be discovered via https://software.opensuse.org/search without the degree of difficulty searching for Midnight Commander presents.
Comment 1 Andreas Stieger 2015-05-18 19:59:12 UTC
Not sure why this is in Base:System. I think mc would be much better suited for the utilities project. Devel project can be trivially switched: mc is a leaf in Base:System.
Comment 2 Peter Linnell 2015-05-18 22:30:57 UTC
(In reply to Andreas Stieger from comment #1)
> Not sure why this is in Base:System. I think mc would be much better suited
> for the utilities project. Devel project can be trivially switched: mc is a
> leaf in Base:System.

Most likely Base:System was chosen as that is the pattern it is in.

I'm not opposed to switching the devel repo, but this may not fix the real bug which is why I cannot be discovered in the search.
Comment 3 white brian 2015-06-24 05:19:46 UTC
(In reply to Andreas Stieger from comment #1)
> Not sure why this is in Base:System. I think mc would be much better suited
> for the utilities project. Devel project can be trivially switched: mc is a
> leaf in Base:System.

What does this have to do with the problem report?
Comment 4 Matthias Mailänder 2016-07-26 12:20:35 UTC
This describes multiple problems
1) mc can't be searched for https://github.com/openSUSE/software-o-o/issues/61 due to it containing too few letters.
2) For some reason the title and description for https://software.opensuse.org/package/mc isn't searched.
Comment 5 Ancor Gonzalez Sosa 2016-10-03 11:39:52 UTC
Now we are tracking software.o.o problems directly in github. As already commented this bug report turned into https://github.com/openSUSE/software-o-o/issues/61. It was fixed and closed and now you can search for "mc". So I'm closing this original report.

On the other hand, only packages names are used for searching. If you want that to be changed, open an issue in https://github.com/openSUSE/software-o-o/issues/ where it could be discussed by the current team taking care of software.o.o.
Comment 6 Felix Miata 2016-10-29 23:57:26 UTC
No mc package for any distribution release or TW is currently returned by https://software.opensuse.org/search . I need 4.8.17 for TW because 4.8.18 has been broken since its release. None of the standard repos have anything in between 4.8.15 and 4.8.18. The github bug was closed 3 months ago, yet this is not fixed.
Comment 7 Andreas Stieger 2016-10-30 08:11:39 UTC
(In reply to Felix Miata from comment #6)
> No mc package for any distribution release or TW is currently returned by
> https://software.opensuse.org/search 

Huh? I am not sure what you are doing, but plenty of mc packages for many releases, including Tumbleweed, are returned.
Case in point: https://software.opensuse.org/package/mc
Closing this issue as you so not seem to be using the search correctly.

> I need 4.8.17 for TW because 4.8.18
> has been broken since its release. None of the standard repos have anything
> in between 4.8.15 and 4.8.18.

This is not how Tumbleweed works, sorry. If you are on Tumbleweed, an earlier version will simply not be offered.

If not already done so, please report a bug against the mc package for a fix to be applied. If you have a post 4.8.18 git commit, even better.
Comment 8 Felix Miata 2016-10-30 08:51:57 UTC
Created attachment 699975 [details]
screenshot of https://software.opensuse.org/search results from typing mc in search box and clicking on search

(In reply to Andreas Stieger from comment #7)
> (In reply to Felix Miata from comment #6)
> > No mc package for any distribution release or TW is currently returned by
> > https://software.opensuse.org/search 

> Huh? I am not sure what you are doing, but plenty of mc packages for many
> releases, including Tumbleweed, are returned.
> Case in point: https://software.opensuse.org/package/mc

That is not the URI returned from using the search box on https://software.opensuse.org/search

> Closing this issue as you so not seem to be using the search correctly.

How does one incorrectly use a search box in a web page? I type mc, click the search button, and 31 of 31 total packages returned are not mc.
Comment 9 Matthias Mailänder 2016-10-30 16:20:23 UTC
Please open https://github.com/openSUSE/software-o-o/issues/new as we want to avoid fragmentation.
Comment 10 Felix Miata 2016-10-30 18:20:07 UTC
(In reply to Matthias Mailänder from comment #9)
> Please open https://github.com/openSUSE/software-o-o/issues/new as we want
> to avoid fragmentation.

https://github.com/openSUSE/software-o-o/issues/114
Comment 11 Christoph Wickert 2020-08-20 11:46:43 UTC
*** Bug 1175428 has been marked as a duplicate of this bug. ***
Comment 12 Felix Miata 2021-10-06 02:25:09 UTC
*** Bug 1190980 has been marked as a duplicate of this bug. ***