Bug 956696 - USB device communication error since changing to Asus Z97-P where xhci is used
USB device communication error since changing to Asus Z97-P where xhci is used
Status: RESOLVED DUPLICATE of bug 856794
Classification: openSUSE
Product: openSUSE 13.1
Classification: openSUSE
Component: Kernel
Final
x86-64 openSUSE 13.1
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-25 13:47 UTC by Episteme PROMENEUR
Modified: 2015-11-25 15:19 UTC (History)
1 user (show)

See Also:
Found By: Community User
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Episteme PROMENEUR 2015-11-25 13:47:08 UTC
Asus Z97-P , bios 2803 (last one)

Opensuse 13.1 x86_64 kernel 3.11.10

usb printer-scanner HP 1220 (usb 1.1) connected to a 1.1/2.0 plug of the Mb

with my old asus M2N no pb with my printer-scanner

since i upgraded to Z97-P i get a pb to print and scan

i can print one time but after a delay i can't . there is no more communication with the printer . sometime i get "device communication error"

i can scan one time but after i can't scan .

the app find the scanner but when running a scan it says "waiting for scanner starting"

i know there is something new with :
- the MB : USB 3.0 
- linux uses xhci module to manage usb

i think the pb is around these new features . perhaps linux manages badly this mixed devices usb 1.1 , 2.0 , 3.0 ?
Comment 1 Episteme PROMENEUR 2015-11-25 13:49:09 UTC
linux-b4lz:~ # lsusb
Bus 002 Device 002: ID 8087:8001 Intel Corp. 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:8009 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 003: ID 0a5c:21e8 Broadcom Corp. BCM20702A0 Bluetooth 4.0
Bus 003 Device 002: ID 046d:081b Logitech, Inc. Webcam C310
Bus 003 Device 008: ID 03f0:0417 Hewlett-Packard LaserJet 1200 series
Bus 003 Device 007: ID 0443:000c Gateway, Inc. 
Bus 003 Device 006: ID 0443:000d Gateway, Inc. 
Bus 003 Device 005: ID 046d:c016 Logitech, Inc. Optical Wheel Mouse
Bus 003 Device 004: ID 152d:2338 JMicron Technology Corp. / JMicron USA Technology Corp. JM20337 Hi-Speed USB to SATA & PATA Combo Bridge
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
linux-b4lz:~ #
Comment 2 Episteme PROMENEUR 2015-11-25 13:50:50 UTC
linux-b4lz:~ # lsusb -t
/:  Bus 04.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/6p, 5000M
/:  Bus 03.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/14p, 480M
    |__ Port 5: Dev 8, If 0, Class=Printer, Driver=usblp, 12M
    |__ Port 6: Dev 2, If 0, Class=Video, Driver=uvcvideo, 480M
    |__ Port 6: Dev 2, If 1, Class=Video, Driver=uvcvideo, 480M
    |__ Port 6: Dev 2, If 2, Class=Audio, Driver=snd-usb-audio, 480M
    |__ Port 6: Dev 2, If 3, Class=Audio, Driver=snd-usb-audio, 480M
    |__ Port 8: Dev 3, If 0, Class=Vendor Specific Class, Driver=btusb, 12M
    |__ Port 8: Dev 3, If 1, Class=Vendor Specific Class, Driver=btusb, 12M
    |__ Port 8: Dev 3, If 2, Class=Vendor Specific Class, Driver=, 12M
    |__ Port 8: Dev 3, If 3, Class=Application Specific Interface, Driver=, 12M
    |__ Port 12: Dev 4, If 0, Class=Mass Storage, Driver=usb-storage, 480M
    |__ Port 13: Dev 5, If 0, Class=Human Interface Device, Driver=usbhid, 1.5M
    |__ Port 14: Dev 6, If 0, Class=Hub, Driver=hub/2p, 12M
        |__ Port 1: Dev 7, If 0, Class=Human Interface Device, Driver=usbhid, 12M
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/2p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/8p, 480M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/2p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/6p, 480M
linux-b4lz:~ #
Comment 3 Episteme PROMENEUR 2015-11-25 13:51:41 UTC
linux-b4lz:~ # dmesg | grep xhci
[    0.858692] xhci_hcd 0000:00:14.0: setting latency timer to 64
[    0.858695] xhci_hcd 0000:00:14.0: xHCI Host Controller
[    0.858699] xhci_hcd 0000:00:14.0: new USB bus registered, assigned bus number 3
[    0.858777] xhci_hcd 0000:00:14.0: cache line size of 64 is not supported
[    0.858790] xhci_hcd 0000:00:14.0: irq 42 for MSI/MSI-X
[    0.858832] usb usb3: Manufacturer: Linux 3.11.10-29-desktop xhci_hcd
[    0.858925] xHCI xhci_add_endpoint called for root hub
[    0.858926] xHCI xhci_check_bandwidth called for root hub
[    0.860386] xhci_hcd 0000:00:14.0: xHCI Host Controller
[    0.860388] xhci_hcd 0000:00:14.0: new USB bus registered, assigned bus number 4
[    0.860412] usb usb4: Manufacturer: Linux 3.11.10-29-desktop xhci_hcd
[    0.860960] xHCI xhci_add_endpoint called for root hub
[    0.860962] xHCI xhci_check_bandwidth called for root hub
[    1.212460] usb 3-6: new high-speed USB device number 2 using xhci_hcd
[    1.595881] usb 3-8: new full-speed USB device number 3 using xhci_hcd
[    1.761611] usb 3-12: new high-speed USB device number 4 using xhci_hcd
[    1.927348] usb 3-13: new low-speed USB device number 5 using xhci_hcd
[    2.097103] usb 3-14: new full-speed USB device number 6 using xhci_hcd
[    2.383739] usb 3-14.1: new full-speed USB device number 7 using xhci_hcd
[ 5079.793217] xhci_queue_intr_tx: 268 callbacks suppressed
[ 5128.772953] xhci_queue_intr_tx: 19 callbacks suppressed
[ 6062.295668] xhci_queue_intr_tx: 2 callbacks suppressed
[21636.119894] usb 3-5: new full-speed USB device number 8 using xhci_hcd
linux-b4lz:~ #
Comment 4 Episteme PROMENEUR 2015-11-25 13:52:20 UTC
linux-b4lz:~ # lspci | grep USB 
00:14.0 USB controller: Intel Corporation Device 8cb1
00:1a.0 USB controller: Intel Corporation Device 8cad
00:1d.0 USB controller: Intel Corporation Device 8ca6
linux-b4lz:~ #
Comment 5 Episteme PROMENEUR 2015-11-25 13:54:14 UTC
same pb with Leap 42.1
Comment 6 Episteme PROMENEUR 2015-11-25 13:55:18 UTC
all other usb device works well : kb , mouse , bluetooth dongle , webcam
Comment 7 Johannes Meixner 2015-11-25 14:23:36 UTC
In general "sometimes device communication error"
indicates that the root cause is somehow hardware related
where "hardware" means the actual computer hardware plus
the computer's built-in firmware (i.e. BIOS or UEFI)
and "hardware related" means computer hardware plus
firmware plus Linux kernel driver plus low-level hardware
related software (e.g. libusb).

There are currently issues with USB ports where the kernel
module "xhci" is used as kernel driver.

When "lsusb -t" shows "Driver=xhci_hcd" for the USB bus
and port where the USB device is connected
(see "lsusb" where the USB device is connected),
then there could be issues depending
on the computer hardware and firmware.

In this case see bug#856794

In particular see
https://bugzilla.opensuse.org/show_bug.cgi?id=856794#c24
that reads (excerpt):
-----------------------------------------------------------------
My machine has 4 USB ports, two labeled with
the "super speed" USB logo (a.k.a. USB 3) and
two labeled with the normal USB logo (a.k.a. USB 2)
but for all 4 ports xhci is used and it fails on all 4 ports.
-----------------------------------------------------------------
and see
https://bugzilla.opensuse.org/show_bug.cgi?id=856794#c40

With very high probability this issue here
is a duplicate of bug#856794

The real solution is a kernel upgrade.

What you might try to do as workaround:

When your computer has a USB port where not xhci is used
connect the USB device there.

When xhci is used is used for all USB ports on your computer
(regardless how the ports are labeled, cf. above)
check the firmware (BIOS or UEFI) settings of your computer
whether or not there is an option to disable USB 3.

If your computer BIOS or UEFI has an option to disable USB 3
try if disabling USB 3 helps so that xhci is no longer used
for the USB ports.

When you use BIOS try if it works with UEFI.
You do not need to also use "Secure Boot" with UEFI
but switching from BIOS to UEFI usually requires
a new installation from scratch because switching from BIOS
to UEFI usually requires harddisk partitioning from scratch.

*** This bug has been marked as a duplicate of bug 856794 ***
Comment 8 Episteme PROMENEUR 2015-11-25 15:19:05 UTC
in bios usb settings there are 3 parameters about bios:

Legacy USB support (Enabled) : Enabled | Disabled

Intel xHCI mode (Smart auto) : Smart auto | auto | Enabled | Disabled

EHCI Hand-off (Disabled) : Enabled | Disabled

after experiments i chose Intel xHCI mode : Auto

for all the other values i get trouble with
- my keyboard 
randomly not activated during bios or opensuse start or suddenly deactivated during kde session

- my mouse suddenly deactivated during kde session

- i get trouble with printing and i can't scan

the sole solution now is to test solution from bug report #856794

a standard kernel 4.3.0-17 from http://download.opensuse.org/repositories/Kernel:/stable/standard/
plus
sane-backend 1.0.25 from http://download.opensuse.org/repositories/graphics/openSUSE_13.1/

thanks