Bug 972197 - libsamba-passdb-devel and libsmbclient0 provides/ obsoletes cleanup
libsamba-passdb-devel and libsmbclient0 provides/ obsoletes cleanup
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Samba
Leap 42.1
All openSUSE 42.1
: P5 - None : Normal (vote)
: ---
Assigned To: Lars Müller
The 'Opening Windows to a Wider World' guys
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-22 17:54 UTC by Lars Müller
Modified: 2016-04-17 15:12 UTC (History)
1 user (show)

See Also:
Found By: Development
Services Priority:
Business Priority:
Blocker: No
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lars Müller 2016-03-22 17:54:34 UTC
While is only should have

  Obsoletes:      libpdb-devel < %{version}
Comment 1 Lars Müller 2016-03-22 19:07:27 UTC
The spec file also should have:

  Obsoletes:      libsmbclient < %{version}

while the both lines:

  Provides:       libpdb-devel

and

  Provides:       libsmbclient = %{version}

get removed in the cases where it applies.
Comment 2 Lars Müller 2016-03-22 19:45:17 UTC
Fixed with build source time-stamp 3628
Comment 4 Bernhard Wiedemann 2016-03-22 21:00:40 UTC
This is an autogenerated message for OBS integration:
This bug (972197) was mentioned in
https://build.opensuse.org/request/show/378291 Factory / samba
Comment 8 Swamp Workflow Management 2016-04-12 22:10:39 UTC
SUSE-SU-2016:1022-1: An update that solves 7 vulnerabilities and has 13 fixes is now available.

Category: security (important)
Bug References: 320709,913547,919309,924519,936862,942716,946051,949022,964023,966271,968973,971965,972197,973031,973032,973033,973034,973036,973832,974629
CVE References: CVE-2015-5370,CVE-2016-2110,CVE-2016-2111,CVE-2016-2112,CVE-2016-2113,CVE-2016-2115,CVE-2016-2118
Sources used:
SUSE Linux Enterprise Software Development Kit 12 (src):    samba-4.2.4-18.17.1
SUSE Linux Enterprise Server 12 (src):    samba-4.2.4-18.17.1
SUSE Linux Enterprise High Availability 12 (src):    samba-4.2.4-18.17.1
SUSE Linux Enterprise Desktop 12 (src):    samba-4.2.4-18.17.1
Comment 9 Swamp Workflow Management 2016-04-12 22:14:13 UTC
SUSE-SU-2016:1024-1: An update that solves 7 vulnerabilities and has 5 fixes is now available.

Category: security (important)
Bug References: 924519,936862,968973,971965,972197,973031,973032,973033,973034,973036,973832,974629
CVE References: CVE-2015-5370,CVE-2016-2110,CVE-2016-2111,CVE-2016-2112,CVE-2016-2113,CVE-2016-2115,CVE-2016-2118
Sources used:
SUSE Linux Enterprise Software Development Kit 12-SP1 (src):    samba-4.2.4-16.1
SUSE Linux Enterprise Server 12-SP1 (src):    samba-4.2.4-16.1
SUSE Linux Enterprise High Availability 12-SP1 (src):    samba-4.2.4-16.1
SUSE Linux Enterprise Desktop 12-SP1 (src):    samba-4.2.4-16.1
Comment 10 Swamp Workflow Management 2016-04-13 12:08:46 UTC
openSUSE-SU-2016:1025-1: An update that solves 7 vulnerabilities and has 5 fixes is now available.

Category: security (important)
Bug References: 924519,936862,968973,971965,972197,973031,973032,973033,973034,973036,973832,974629
CVE References: CVE-2015-5370,CVE-2016-2110,CVE-2016-2111,CVE-2016-2112,CVE-2016-2113,CVE-2016-2115,CVE-2016-2118
Sources used:
openSUSE Leap 42.1 (src):    samba-4.2.4-15.1
Comment 11 Swamp Workflow Management 2016-04-17 13:18:48 UTC
openSUSE-SU-2016:1064-1: An update that solves 16 vulnerabilities and has 17 fixes is now available.

Category: security (important)
Bug References: 898031,901813,912457,913238,913547,914279,917376,919309,924519,936862,942716,946051,947552,949022,958581,958582,958583,958584,958585,958586,964023,966271,968222,968973,971965,972197,973031,973032,973033,973034,973036,973832,974629
CVE References: CVE-2014-8143,CVE-2015-0240,CVE-2015-3223,CVE-2015-5252,CVE-2015-5296,CVE-2015-5299,CVE-2015-5330,CVE-2015-5370,CVE-2015-7560,CVE-2015-8467,CVE-2016-2110,CVE-2016-2111,CVE-2016-2112,CVE-2016-2113,CVE-2016-2115,CVE-2016-2118
Sources used:
openSUSE 13.2 (src):    samba-4.2.4-34.1
Comment 12 Swamp Workflow Management 2016-04-17 15:12:46 UTC
openSUSE-OU-2016:1076-1: An update that has one optional fix can now be installed.

Category: optional (low)
Bug References: 972197
CVE References: 
Sources used:
openSUSE Leap 42.1 (src):    yast2-samba-server-3.1.14-16.1