Bug 975279 - (CVE-2016-4003) VUL-0: CVE-2016-4003: struts: Cross-site scripting (XSS) vulnerability in the URLDecoder functio
(CVE-2016-4003)
VUL-0: CVE-2016-4003: struts: Cross-site scripting (XSS) vulnerability in the...
Status: RESOLVED INVALID
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Normal
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/167753/
CVSSv2:NVD:CVE-2016-4003:4.3:(AV:N/A...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-04-13 08:17 UTC by Johannes Segitz
Modified: 2016-04-22 08:36 UTC (History)
2 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Johannes Segitz 2016-04-13 08:17:32 UTC
CVE-2016-4003

Cross-site scripting (XSS) vulnerability in the URLDecoder function in JRE
before 1.8, as used in Apache Struts 2.x before 2.3.28, when using a single byte
page encoding, allows remote attackers to inject arbitrary web script or HTML
via multi-byte characters in a url-encoded parameter.

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2016-4003
https://issues.apache.org/jira/browse/WW-4507
http://www.securitytracker.com/id/1035268
http://struts.apache.org/docs/s2-028.html
Comment 3 Swamp Workflow Management 2016-04-13 22:00:14 UTC
bugbot adjusting priority
Comment 4 Johannes Segitz 2016-04-22 08:36:27 UTC
so since there are not calls to those functions the package is not affected by this CVE (still could be vulnerable)