Bug 989033 - Plasma 5 reboot attempt takes me to login screen
Plasma 5 reboot attempt takes me to login screen
Status: RESOLVED DUPLICATE of bug 983078
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: KDE Workspace (Plasma)
Leap 42.1
x86-64 openSUSE 42.1
: P5 - None : Major (vote)
: ---
Assigned To: E-Mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-07-14 18:25 UTC by Deleted Name
Modified: 2016-07-18 15:26 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
here is the output of both commands (1.41 KB, text/plain)
2016-07-18 13:16 UTC, Deleted Name
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Deleted Name 2016-07-14 18:25:42 UTC
I have recently reinstalled Leap 42.1 (without formatting my home partition).

However I notice something strange in Plasma 5. When I click the Reboot button, I am simply logged out and taken to the Breeze login screen and the system does not reboot.

Before reinstalling I never had this problem.

I tried creating a new user and tested with it - same result.

I ran 'journalctl -f' as root in first console and recorded what happens when I try to reboot:

http://paste.opensuse.org/29c91650

However I have no idea what all this means.

The system and all packages are up to date.
Comment 1 Deleted Name 2016-07-17 19:18:30 UTC
Update:

I installed kdm and switched to it according to this article:

https://en.opensuse.org/Change_Display_Manager

With kdm reboot works fine. So it seems there might be a bug in sddm.
Comment 2 Wolfgang Bauer 2016-07-18 09:56:48 UTC
Sounds like a duplicate of bug#983078.

What are your security and polkit settings?
egrep "SECURITY|POLKIT" /etc/sysconfig/security
grep reboot /etc/polkit-*
Comment 3 Deleted Name 2016-07-18 13:16:29 UTC
Created attachment 684546 [details]
here is the output of both commands
Comment 4 Wolfgang Bauer 2016-07-18 13:32:40 UTC
Right, you use "secure" permissions:
# egrep "SECURITY|POLKIT" /etc/sysconfig/security
PERMISSION_SECURITY="secure local"

That means that rebooting requires the root password, and that apparently doesn't work currently with sddm, see the other bug report.

Set the security level back to easy to "fix" it.

If you want to keep "secure", you could override the reboot permission manually as a workaround, to allow rebooting without root password.
Add this line to /etc/polkit-default-privs.local:
org.freedesktop.login1.reboot yes

And run "sudo polkit_set_default_privs" afterwards to apply the change.

For shutdown, you'd need this in addition:
org.freedesktop.login1.power-off yes

*** This bug has been marked as a duplicate of bug 983078 ***
Comment 5 Deleted Name 2016-07-18 13:55:25 UTC
Thanks.
I can surely edit the file but before doing that, can you please explain:

1. If the issue is the polkit - Why I am being logged out instead of being asked for root password?

2. Why with this same settings you are looking at (but using kdm instead of sddm)  I can reboot without problems?

3. Do you actually recommend switching back to sddm with "fixed" polkit rules? Is there any disadvantage in staying with kdm?
Comment 6 Wolfgang Bauer 2016-07-18 14:58:55 UTC
(In reply to Name Deleted from comment #5)
> 1. If the issue is the polkit - Why I am being logged out instead of being
> asked for root password?

See the other bug report.

The problem seems to be that when you would be asked for the root password, the KDE session is already closed.
So the reboot fails (because you didn't provide the root password) and the system stays at the login screen.

It's not an issue with polkit per se.

> 2. Why with this same settings you are looking at (but using kdm instead of
> sddm)  I can reboot without problems?

kdm has its own settings for this and doesn't use polkit or its rules.
See /etc/sysconfig/displaymanager (DISPLAYMANAGER_SHUTDOWN).

I don't know currently whether kdm will correctly show a root password dialog on Leap (with Plasma5) if that's configured (need to check), it did work fine in 13.2 with KDE4 though.

> 3. Do you actually recommend switching back to sddm with "fixed" polkit
> rules? Is there any disadvantage in staying with kdm?

Depends on what you prefer.
The changed polkit rules implicate that *every* user can shut down/reboot the system, without having to enter the root password.

kdm is old and meanwhile unmaintained, but it works.

But just to be clear: changing the polkit rules is no "fix", only a workaround.

And please, this is a bug tracker, not a user support forum.
Comment 7 Deleted Name 2016-07-18 15:26:39 UTC
Thank you.