Bug 990191 - (CVE-2016-6263) VUL-1: CVE-2016-6263: libidn: stringprep_utf8_nfkc_normalize reject invalid UTF-8
(CVE-2016-6263)
VUL-1: CVE-2016-6263: libidn: stringprep_utf8_nfkc_normalize reject invalid U...
Status: RESOLVED FIXED
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P4 - Low : Minor
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/171217/
CVSSv2:SUSE:CVE-2016-6263:4.3:(AV:N/A...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-07-22 08:14 UTC by Andreas Stieger
Modified: 2017-07-13 14:56 UTC (History)
2 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Stieger 2016-07-22 08:14:15 UTC
http://seclists.org/oss-sec/2016/q3/124

    The GNU libidn 1.33 release was announced with the following:

    https://lists.gnu.org/archive/html/help-libidn/2016-07/msg00009.html
[...]

    ** libidn: stringprep_utf8_nfkc_normalize reject invalid UTF-8.
    It was always documented to only accept UTF-8 data, but now it doesn't
    crash when presented with such data. Reported by Hanno Boeck.


    Test / Fix:
    http://git.savannah.gnu.org/cgit/libidn.git/commit/?id=1fbee57ef3c72db2206dd87e4162108b2f425555
    Changelog:
    http://git.savannah.gnu.org/cgit/libidn.git/commit/?id=1d2413555dcd1fef26b80445a00a4637965a2df0


    lib/nfkc.c


Use CVE-2016-6263.




The reproducer is in the test code.


References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2016-6263
http://seclists.org/oss-sec/2016/q3/124
http://people.canonical.com/~ubuntu-security/cve/2016/CVE-2016-6263.html
Comment 1 Bernhard Wiedemann 2016-07-22 10:01:10 UTC
This is an autogenerated message for OBS integration:
This bug (990191) was mentioned in
https://build.opensuse.org/request/show/412739 Factory / libidn
https://build.opensuse.org/request/show/412740 13.2 / libidn
Comment 3 Swamp Workflow Management 2016-07-22 22:00:45 UTC
bugbot adjusting priority
Comment 6 Swamp Workflow Management 2016-08-01 03:11:14 UTC
openSUSE-SU-2016:1924-1: An update that fixes three vulnerabilities is now available.

Category: security (moderate)
Bug References: 990189,990191
CVE References: CVE-2015-8948,CVE-2016-6262,CVE-2016-6263
Sources used:
openSUSE 13.2 (src):    libidn-1.33-3.6.1
Comment 7 Swamp Workflow Management 2016-08-16 11:09:46 UTC
SUSE-SU-2016:2079-1: An update that fixes 5 vulnerabilities is now available.

Category: security (moderate)
Bug References: 923241,990189,990190,990191
CVE References: CVE-2015-2059,CVE-2015-8948,CVE-2016-6261,CVE-2016-6262,CVE-2016-6263
Sources used:
SUSE Linux Enterprise Software Development Kit 12-SP1 (src):    libidn-1.28-4.1
SUSE Linux Enterprise Server 12-SP1 (src):    libidn-1.28-4.1
SUSE Linux Enterprise Desktop 12-SP1 (src):    libidn-1.28-4.1
Comment 8 Swamp Workflow Management 2016-08-23 15:09:28 UTC
openSUSE-SU-2016:2135-1: An update that fixes 5 vulnerabilities is now available.

Category: security (moderate)
Bug References: 923241,990189,990190,990191
CVE References: CVE-2015-2059,CVE-2015-8948,CVE-2016-6261,CVE-2016-6262,CVE-2016-6263
Sources used:
openSUSE Leap 42.1 (src):    libidn-1.28-6.1
Comment 9 Swamp Workflow Management 2016-09-12 13:10:51 UTC
SUSE-SU-2016:2291-1: An update that fixes 5 vulnerabilities is now available.

Category: security (moderate)
Bug References: 923241,990189,990190,990191
CVE References: CVE-2015-2059,CVE-2015-8948,CVE-2016-6261,CVE-2016-6262,CVE-2016-6263
Sources used:
SUSE Linux Enterprise Software Development Kit 11-SP4 (src):    libidn-1.10-6.1
SUSE Linux Enterprise Server 11-SP4 (src):    libidn-1.10-6.1
SUSE Linux Enterprise Debuginfo 11-SP4 (src):    libidn-1.10-6.1
Comment 10 Johannes Segitz 2017-07-13 08:27:47 UTC
fixed