Bug 995921 - 32-bit Install image contains 64-bit programs "openSUSE42_2_xxx.exe"
32-bit Install image contains 64-bit programs "openSUSE42_2_xxx.exe"
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Installation
Current
i586 Windows 7
: P5 - None : Normal (vote)
: ---
Assigned To: Yasuhiko Kamata
Jiri Srain
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-08-27 16:21 UTC by Peter Kimmel
Modified: 2016-09-01 23:11 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Kimmel 2016-08-27 16:21:49 UTC
I have an older 32-bit laptop running with a Windows partition on which I want to install openSUSE 32-bit Tumbleweed, version 20160822,
from USB stick, as burning the DVD continues to give problems.
And the old laptop can not boot directly from USB.

In January this still worked: from USB, to install a temporary boot loader, using these former EXE files in the image, called:  openSUSE42_1_LOCAL.exe and openSUSE42_1_NET.exe.

But now these two files have been changed, they are called openSUSE42_2_LOCAL.exe and openSUSE42_2_NET.exe, and worse, they are 64-bit files.
So it is not possible anymore to use this function any longer, on a 32-bit hardware PC.

I think it does not make any sense to include any 64-bit software in the 32-bit Tumbleweed package. Please can we revert these files to their old earlier 32-bit versions, so that this function is reenabled again.
Comment 1 Martin Vidner 2016-08-30 12:55:17 UTC
Apparently that was a deliberate change, but I don't know the reasoning behind that:
https://build.opensuse.org/package/view_file/system:install:head/instlux/instlux.changes?expand=1

Hopefully the author of the change can explain

-------------------------------------------------------------------
Mon May 30 12:05:09 UTC 2016 - belphegor@belbel.or.jp

- adjusted labels 42.1 -> 42.2
- prevent i586 install for openSUSE Leap 42.1 or later
Comment 2 Yasuhiko Kamata 2016-08-30 23:13:08 UTC
> - prevent i586 install for openSUSE Leap 42.1 or later

As the file name indicates, "openSUSE42_2_xxx.exe" is an EXE file for installing openSUSE (Leap) 42.2.
But since openSUSE Leap 42.1, 32-bit version was dropped from public release.
So this EXE file caused an error (File Not Found (404)) if 32-bit was selected during wizard (because kernel and initrd are downloaded from public source).
This fix is an solution for this bug.

So this problem can be solved by creating Tumbleweed version of this EXE,
but not available yet. Please wait for now.
Comment 3 Yasuhiko Kamata 2016-08-31 12:18:41 UTC
Ok, Tumbleweed version was created as follows:

http://download.opensuse.org/repositories/home:/belphegor_belbel:/instlux/openSUSE_Tumbleweed/i586/instlux-Tumbleweed_SVN62-7.1.i586.rpm

Due to a mechanism of openSUSE Build Service, I cannot provide a EXE file directly; can only provide .rpm file which contains EXE file.
So please use an archiving utility which supports RPM in order to extract.
7-zip (http://www.7-zip.org/) is one of famous utility which supports RPM.
Please be patient.

Please use /CD1/openSUSETumbleweed_NET.exe in this RPM.
Comment 4 Yasuhiko Kamata 2016-09-01 23:11:27 UTC
Just submitted to Tumbleweed as OBS submit request #424344:
https://build.opensuse.org/request/show/424344.

Tumbleweed repository (http://download.opensuse.org/tumbleweed/repo/oss/)
will be updated after acceptance of this request.

BTW, URL which mentioned comment#3 was changed due to update,
check instlux-Tumbleweed_SVN62-*.i586.rpm in the following URL in future:
http://download.opensuse.org/repositories/home:/belphegor_belbel:/instlux/openSUSE_Tumbleweed/i586/