Bug 997172 - please backport hwmon module ftsteutates
please backport hwmon module ftsteutates
Status: RESOLVED WONTFIX
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Kernel
Leap 42.2
Other Other
: P5 - None : Enhancement (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-09-03 09:13 UTC by Ruediger Meier
Modified: 2019-01-18 07:49 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ruediger Meier 2016-09-03 09:13:41 UTC
Hi,

Currently I'm trying to submit an ftsteutates-kmp packages to Factory because finally I'd really like to see that module in Leap 42.2, see
https://build.opensuse.org/request/show/424539

Now I've noticed that the module made in into kernel upstream (v4.7-rc5-34-g08426ed)

So I guess it could be less painful to backport this module into the official Leap kernel, and there is no reason to introduce this kmp package to Factory.

Please consider backporting this module to Leap 42.2.
Comment 1 Martin Pluskal 2016-09-04 06:36:34 UTC
That is afaik not much likely to happen, but once package is accepted to Factory, you can submit is as maintenance update:
# osc branch -M -N openSUSE:Leap:42.2:Update/ftsteutates
# osc copypac -e -K hardware/ftsteutates home:RuedigerMeier/branches:openSUSE:Leap:42.2/ftsteutes.openSUSE:Leap:42.2:Update
# osc mr home:RuedigerMeier/branches:openSUSE:Leap..
While using this bug as reference

(process of creation of such update is same as for openSUSE:Bacports - see https://en.opensuse.org/openSUSE:Backports_Package_Submission_Process)
Comment 2 Takashi Iwai 2016-09-04 07:05:01 UTC
Sorry, this is no-go.  openSUSE-42.2 kernel shares the same code as SLE12-SP2 kernel, and SLE12-SP2 already reached RC2, the code was basically frozen.
And, such a request should be processed through FATE, in anyway.

Please go ahead with the KMP.  For TW kernel package, we'll add a proper "Obsoletes" tag in kernel package itself.
Comment 3 Bernhard Wiedemann 2016-09-21 20:00:43 UTC
This is an autogenerated message for OBS integration:
This bug (997172) was mentioned in
https://build.opensuse.org/request/show/429362 42.2 / ftsteutates
Comment 4 Bernhard Wiedemann 2016-09-22 12:00:51 UTC
This is an autogenerated message for OBS integration:
This bug (997172) was mentioned in
https://build.opensuse.org/request/show/429446 42.2 / ftsteutates
Comment 5 Andreas Stieger 2016-09-24 13:40:58 UTC
So ftsteutates is in 42.2 now.
Comment 6 Takashi Iwai 2016-12-28 19:53:36 UTC
OK, I sent the pull requests to kernel git master and stable branches to add obsoletes of ftsteutates KMP.  Also I did SR for ftsteutates package for TW to drop the KMP build, too.
Comment 9 Swamp Workflow Management 2018-11-06 15:45:46 UTC
This is an autogenerated message for OBS integration:
This bug (997172) was mentioned in
https://build.opensuse.org/request/show/646686 42.3 / kernel-source
Comment 11 Swamp Workflow Management 2018-11-09 20:46:19 UTC
SUSE-SU-2018:3688-1: An update that solves 6 vulnerabilities and has 100 fixes is now available.

Category: security (important)
Bug References: 1011920,1012382,1012422,1020645,1031392,1035053,1042422,1043591,1048129,1050431,1050549,1053043,1054239,1057199,1065600,1065726,1067906,1073579,1076393,1078788,1079524,1082519,1083215,1083527,1084760,1089343,1091158,1093118,1094244,1094825,1095805,1096052,1098050,1098996,1099597,1101555,1103308,1103405,1104124,1105025,1105428,1105795,1105931,1106105,1106110,1106240,1106293,1106359,1106434,1106594,1106913,1106929,1107060,1107299,1107318,1107535,1107829,1107870,1108315,1108377,1108498,1109158,1109333,1109772,1109784,1109806,1109818,1109907,1109919,1109923,1110006,1110363,1110468,1110600,1110601,1110602,1110603,1110604,1110605,1110606,1110611,1110612,1110613,1110614,1110615,1110616,1110618,1110619,1111363,1111516,1111870,1112007,1112262,1112263,1112894,1112902,1112903,1112905,1113667,1113751,1113769,1114178,1114229,1114648,981083,997172
CVE References: CVE-2018-14633,CVE-2018-18281,CVE-2018-18386,CVE-2018-18690,CVE-2018-18710,CVE-2018-9516
Sources used:
SUSE Linux Enterprise Live Patching 12-SP3 (src):    kgraft-patch-SLE12-SP3_Update_21-1-4.5.2
Comment 12 Swamp Workflow Management 2018-11-12 22:06:24 UTC
This is an autogenerated message for OBS integration:
This bug (997172) was mentioned in
https://build.opensuse.org/request/show/648620 42.3 / kernel-source
Comment 13 Swamp Workflow Management 2018-11-20 20:20:46 UTC
openSUSE-SU-2018:3817-1: An update that solves 5 vulnerabilities and has 66 fixes is now available.

Category: security (important)
Bug References: 1011920,1012382,1012422,1020645,1031392,1035053,1042422,1043591,1048129,1050431,1053043,1054239,1057199,1062303,1065600,1065726,1067906,1073579,1076393,1078788,1079524,1083215,1083527,1084760,1091158,1093118,1094825,1095805,1098050,1098996,1101555,1104124,1105025,1105931,1106110,1106359,1106594,1106913,1106929,1107060,1107299,1107535,1107870,1108377,1108498,1109158,1109772,1109784,1109818,1109907,1109919,1109923,1110006,1111516,1111870,1112007,1112262,1112263,1112894,1112902,1112903,1112905,1113667,1113751,1113769,1114178,1114229,1114648,1115587,981083,997172
CVE References: CVE-2018-18281,CVE-2018-18386,CVE-2018-18690,CVE-2018-18710,CVE-2018-9516
Sources used:
openSUSE Leap 42.3 (src):    kernel-debug-4.4.162-78.1, kernel-default-4.4.162-78.1, kernel-docs-4.4.162-78.1, kernel-obs-build-4.4.162-78.1, kernel-obs-qa-4.4.162-78.1, kernel-source-4.4.162-78.1, kernel-syms-4.4.162-78.1, kernel-vanilla-4.4.162-78.1
Comment 16 Swamp Workflow Management 2019-01-16 08:07:31 UTC
SUSE-SU-2019:0095-1: An update that solves 13 vulnerabilities and has 140 fixes is now available.

Category: security (important)
Bug References: 1011920,1012382,1012422,1020645,1031392,1035053,1042422,1043591,1044189,1048129,1050431,1050549,1053043,1054239,1057199,1062303,1063026,1065600,1065726,1066223,1067906,1073579,1076393,1078788,1079524,1082519,1082863,1082979,1083215,1083527,1084427,1084536,1084760,1087209,1088087,1089343,1090535,1091158,1093118,1094244,1094555,1094562,1094825,1095344,1095753,1095805,1096052,1096547,1098050,1098996,1099597,1099810,1101555,1102495,1102715,1102870,1102875,1102877,1102879,1102882,1102896,1103156,1103269,1103308,1103405,1104124,1105025,1105428,1105795,1105931,1106095,1106105,1106110,1106240,1106293,1106359,1106434,1106512,1106594,1106913,1106929,1106934,1107060,1107299,1107318,1107535,1107829,1107870,1107924,1108096,1108170,1108240,1108281,1108315,1108377,1108399,1108498,1108803,1108823,1109038,1109158,1109333,1109336,1109337,1109441,1109772,1109784,1109806,1109818,1109907,1109919,1109923,1110006,1110297,1110337,1110363,1110468,1110600,1110601,1110602,1110603,1110604,1110605,1110606,1110611,1110612,1110613,1110614,1110615,1110616,1110618,1110619,1110930,1111363,1111516,1111870,1112007,1112262,1112263,1112894,1112902,1112903,1112905,1113667,1113751,1113766,1113769,1114178,1114229,1114648,1115593,981083,997172
CVE References: CVE-2018-14613,CVE-2018-14617,CVE-2018-14633,CVE-2018-16276,CVE-2018-16597,CVE-2018-17182,CVE-2018-18281,CVE-2018-18386,CVE-2018-18690,CVE-2018-18710,CVE-2018-7480,CVE-2018-7757,CVE-2018-9516
Sources used:
SUSE Linux Enterprise Server 12-SP3 (src):    kernel-azure-4.4.162-4.19.2, kernel-source-azure-4.4.162-4.19.1, kernel-syms-azure-4.4.162-4.19.1