Bug 827265 - (CVE-2013-4073) VUL-0: ruby: CVE-2013-4073: Hostname check bypassing vulnerability in SSL client
(CVE-2013-4073)
VUL-0: ruby: CVE-2013-4073: Hostname check bypassing vulnerability in SSL client
Status: RESOLVED FIXED
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Normal
: ---
Assigned To: Jordi Massaguer
Security Team bot
maint:released:sle11-sp2:53494 maint:...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-28 03:46 UTC by Alexander Bergmann
Modified: 2018-10-19 18:18 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Bergmann 2013-06-28 03:46:49 UTC
Public via ruby-lang.org:

http://www.ruby-lang.org/en/news/2013/06/27/hostname-check-bypassing-vulnerability-in-openssl-client-cve-2013-4073/

A vulnerability in Ruby’s SSL client that could allow man-in-the-middle attackers to spoof SSL servers via valid certificate issued by a trusted certification authority.

This vulnerability has been assigned the CVE identifier CVE-2013-4073.

Summary
-------
Ruby’s SSL client implements hostname identity check but it does not properly handle hostnames in the certificate that contain null bytes.
Comment 1 Alexander Bergmann 2013-06-28 03:52:20 UTC
Affected ruby versions:

    All ruby 1.8 versions prior to ruby 1.8.7 patchlevel 374
    All ruby 1.9 versions prior to ruby 1.9.3 patchlevel 448
    All ruby 2.0 versions prior to ruby 2.0.0 patchlevel 247
    prior to trunk revision 41671

Affected openSUSE/SLE versions:

sle11/SP1-UPDATES             : 1.8.7.p357
openSUSE:12.2                 :      1.9.3
openSUSE:12.3                 :      1.9.3
Comment 2 Swamp Workflow Management 2013-06-28 22:00:16 UTC
bugbot adjusting priority
Comment 5 Swamp Workflow Management 2013-07-02 09:11:34 UTC
The SWAMPID for this issue is 53373.
This issue was rated as moderate.
Please submit fixed packages until 2013-07-16.
When done, please reassign the bug to security-team@suse.de.
Patchinfo will be handled by security team.
Comment 8 Bernhard Wiedemann 2013-07-02 15:00:14 UTC
This is an autogenerated message for OBS integration:
This bug (827265) was mentioned in
https://build.opensuse.org/request/show/181776 Maintenance /
Comment 9 Bernhard Wiedemann 2013-07-02 16:00:10 UTC
This is an autogenerated message for OBS integration:
This bug (827265) was mentioned in
https://build.opensuse.org/request/show/181783 Maintenance /
Comment 13 Bernhard Wiedemann 2013-07-03 11:00:18 UTC
This is an autogenerated message for OBS integration:
This bug (827265) was mentioned in
https://build.opensuse.org/request/show/181844 Maintenance / 
https://build.opensuse.org/request/show/181845 Maintenance /
Comment 26 Bernhard Wiedemann 2013-07-05 16:00:09 UTC
This is an autogenerated message for OBS integration:
This bug (827265) was mentioned in
https://build.opensuse.org/request/show/182322 Maintenance / 
https://build.opensuse.org/request/show/182323 Maintenance /
Comment 28 Bernhard Wiedemann 2013-07-08 13:00:09 UTC
This is an autogenerated message for OBS integration:
This bug (827265) was mentioned in
https://build.opensuse.org/request/show/182495 Maintenance /
Comment 32 Swamp Workflow Management 2013-07-11 06:04:36 UTC
openSUSE-SU-2013:1179-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 827265
CVE References: CVE-2013-4073
Sources used:
openSUSE 12.2 (src):    ruby19-1.9.3.p392-3.26.1
Comment 33 Bernhard Wiedemann 2013-07-11 07:00:25 UTC
This is an autogenerated message for OBS integration:
This bug (827265) was mentioned in
https://build.opensuse.org/request/show/182788 Evergreen:11.2 / ruby
Comment 35 Swamp Workflow Management 2013-07-11 08:04:18 UTC
openSUSE-SU-2013:1181-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 827265
CVE References: CVE-2013-4073
Sources used:
openSUSE 12.3 (src):    ruby19-1.9.3.p392-1.9.1
Comment 36 Swamp Workflow Management 2013-07-12 07:04:41 UTC
openSUSE-SU-2013:1186-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 827265
CVE References: CVE-2013-4073
Sources used:
openSUSE 11.4 (src):    ruby-1.8.7.p357-0.36.1
Comment 37 Bernhard Wiedemann 2013-07-15 11:00:16 UTC
This is an autogenerated message for OBS integration:
This bug (827265) was mentioned in
https://build.opensuse.org/request/show/183059 Evergreen:11.2 / ruby
Comment 39 Swamp Workflow Management 2013-07-26 14:46:01 UTC
Update released for: ruby19, ruby19-debuginfo, ruby19-debugsource, ruby19-devel, ruby19-devel-extra, ruby19-doc-ri, ruby19-tk
Products:
SLE-STUDIOONSITE 1.3 (x86_64)
Comment 42 Swamp Workflow Management 2013-07-30 12:04:16 UTC
Update released for: ruby, ruby-debuginfo, ruby-debugsource, ruby-devel, ruby-doc-html, ruby-doc-ri, ruby-examples, ruby-test-suite, ruby-tk
Products:
SLE-SERVER 11-SP1-TERADATA (x86_64)
Comment 43 Swamp Workflow Management 2013-07-30 14:52:52 UTC
Update released for: ruby, ruby-debuginfo, ruby-debugsource, ruby-devel, ruby-doc-html, ruby-doc-ri, ruby-examples, ruby-test-suite, ruby-tk
Products:
SLE-DEBUGINFO 11-SP3 (i386, ia64, ppc64, s390x, x86_64)
SLE-DESKTOP 11-SP3 (i386, x86_64)
SLE-SDK 11-SP3 (i386, ia64, ppc64, s390x, x86_64)
SLE-SERVER 11-SP3 (i386, ia64, ppc64, s390x, x86_64)
SLES4VMWARE 11-SP3 (i386, x86_64)
Comment 44 Swamp Workflow Management 2013-07-30 15:03:06 UTC
Update released for: ruby, ruby-debuginfo, ruby-debugsource, ruby-devel, ruby-doc-html, ruby-doc-ri, ruby-examples, ruby-test-suite, ruby-tk
Products:
SLE-DEBUGINFO 11-SP2 (i386, ia64, ppc64, s390x, x86_64)
SLE-DESKTOP 11-SP2 (i386, x86_64)
SLE-SDK 11-SP2 (i386, ia64, ppc64, s390x, x86_64)
SLE-SERVER 11-SP2 (i386, ia64, ppc64, s390x, x86_64)
SLE-SLMS 1.3 (x86_64)
SLE-WEBYAST 1.3 (i386, ia64, ppc64, s390x, x86_64)
SLES4VMWARE 11-SP2 (i386, x86_64)
Comment 45 Matthias Weckbecker 2013-08-06 12:34:03 UTC
I think this can be closed. Fixed RPMs should be there. Freel free to reopen
if there's anything left.
Comment 46 Swamp Workflow Management 2014-06-25 13:47:37 UTC
Update released for: ruby, ruby-debuginfo, ruby-debugsource, ruby-devel, ruby-doc-html, ruby-doc-ri, ruby-examples, ruby-test-suite, ruby-tk
Products:
SLE-DEBUGINFO 11-SP1 (i386, s390x, x86_64)
SLE-SERVER 11-SP1-LTSS (i386, s390x, x86_64)
Comment 47 Swamp Workflow Management 2014-06-25 13:48:52 UTC
Update released for: ruby, ruby-debuginfo, ruby-debugsource, ruby-devel, ruby-doc-html, ruby-doc-ri, ruby-examples, ruby-test-suite, ruby-tk
Products:
SLE-DEBUGINFO 11-SP2 (i386, s390x, x86_64)
SLE-SERVER 11-SP2-LTSS (i386, s390x, x86_64)
Comment 48 Swamp Workflow Management 2014-06-25 17:04:39 UTC
SUSE-SU-2014:0843-1: An update that fixes three vulnerabilities is now available.

Category: security (moderate)
Bug References: 808137,827265,851803
CVE References: CVE-2013-1821,CVE-2013-4073,CVE-2013-4164
Sources used:
SUSE Linux Enterprise Server 11 SP2 LTSS (src):    ruby-1.8.7.p357-0.9.15.6
Comment 49 Swamp Workflow Management 2014-06-25 17:05:33 UTC
SUSE-SU-2014:0844-1: An update that fixes four vulnerabilities is now available.

Category: security (moderate)
Bug References: 783525,808137,827265,851803
CVE References: CVE-2012-4481,CVE-2013-1821,CVE-2013-4073,CVE-2013-4164
Sources used:
SUSE Linux Enterprise Server 11 SP1 LTSS (src):    ruby-1.8.7.p357-0.9.15.6