Bug 989723 - (CVE-2016-3598) VUL-0: CVE-2016-3598: java-1_8_0-openjdk: incorrect handling of MethodHandles.dropArguments() argument (Libraries, 8155985)
(CVE-2016-3598)
VUL-0: CVE-2016-3598: java-1_8_0-openjdk: incorrect handling of MethodHandles...
Status: RESOLVED FIXED
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Critical
: ---
Assigned To: Fridrich Strba
Security Team bot
CVSSv2:RedHat:CVE-2016-3598:6.8:(AV:N...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-07-20 10:30 UTC by Andreas Stieger
Modified: 2016-10-14 06:49 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Stieger 2016-07-20 10:30:58 UTC
Oracle July 2016 Patch Day.
http://www.oracle.com/technetwork/security-advisory/cpujul2016-2881720.html#AppendixJAVA
http://www.oracle.com/technetwork/topics/security/cpujul2016verbose-2881721.html#JAVA

Vulnerability in the Java SE, Java SE Embedded component of Oracle Java SE (subcomponent: Libraries). The supported version that is affected is Java SE: 8u92; Java SE Embedded: 8u91. Easily exploitable vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Java SE, Java SE Embedded. Successful attacks require human interaction from a person other than the attacker and while the vulnerability is in Java SE, Java SE Embedded, attacks may significantly impact additional products. Successful attacks of this vulnerability can result in takeover of Java SE, Java SE Embedded.

Note: This vulnerability applies to Java deployments, typically in clients running sandboxed Java Web Start applications or sandboxed Java applets, that load and run untrusted code (e.g., code that comes from the internet) and rely on the Java sandbox for security. This vulnerability does not apply to Java deployments, typically in servers, that load and run only trusted code (e.g., code installed by an administrator).

CVSS v3.0 Base Score 9.6 (Confidentiality, Integrity and Availability impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H).  CVSS v2 Vector (AV:N/AC:M/Au:N/C:C/I:C/A:C)
Comment 1 Swamp Workflow Management 2016-07-20 22:00:52 UTC
bugbot adjusting priority
Comment 2 Swamp Workflow Management 2016-08-05 22:12:59 UTC
openSUSE-SU-2016:1979-1: An update that solves 13 vulnerabilities and has two fixes is now available.

Category: security (moderate)
Bug References: 984684,987895,989721,989722,989723,989725,989726,989727,989728,989729,989730,989731,989732,989733,989734
CVE References: CVE-2016-3458,CVE-2016-3485,CVE-2016-3498,CVE-2016-3500,CVE-2016-3503,CVE-2016-3508,CVE-2016-3511,CVE-2016-3550,CVE-2016-3552,CVE-2016-3587,CVE-2016-3598,CVE-2016-3606,CVE-2016-3610
Sources used:
openSUSE 13.2 (src):    java-1_8_0-openjdk-1.8.0.101-30.2
Comment 3 Swamp Workflow Management 2016-08-09 15:16:15 UTC
SUSE-SU-2016:1997-1: An update that solves 11 vulnerabilities and has three fixes is now available.

Category: security (important)
Bug References: 982366,984684,988651,989722,989723,989725,989727,989728,989729,989730,989731,989732,989733,989734
CVE References: CVE-2016-3458,CVE-2016-3485,CVE-2016-3498,CVE-2016-3500,CVE-2016-3503,CVE-2016-3508,CVE-2016-3511,CVE-2016-3550,CVE-2016-3598,CVE-2016-3606,CVE-2016-3610
Sources used:
SUSE Linux Enterprise Server 12-SP1 (src):    java-1_7_0-openjdk-1.7.0.111-33.1
SUSE Linux Enterprise Desktop 12-SP1 (src):    java-1_7_0-openjdk-1.7.0.111-33.1
Comment 4 Swamp Workflow Management 2016-08-09 15:36:16 UTC
SUSE-SU-2016:2012-1: An update that solves 13 vulnerabilities and has three fixes is now available.

Category: security (important)
Bug References: 984684,987895,988651,989721,989722,989723,989725,989726,989727,989728,989729,989730,989731,989732,989733,989734
CVE References: CVE-2016-3458,CVE-2016-3485,CVE-2016-3498,CVE-2016-3500,CVE-2016-3503,CVE-2016-3508,CVE-2016-3511,CVE-2016-3550,CVE-2016-3552,CVE-2016-3587,CVE-2016-3598,CVE-2016-3606,CVE-2016-3610
Sources used:
SUSE Linux Enterprise Server 12-SP1 (src):    java-1_8_0-openjdk-1.8.0.101-14.3
SUSE Linux Enterprise Desktop 12-SP1 (src):    java-1_8_0-openjdk-1.8.0.101-14.3
Comment 5 Andreas Stieger 2016-08-11 17:27:00 UTC
All done, closing
Comment 6 Swamp Workflow Management 2016-08-11 21:09:23 UTC
openSUSE-SU-2016:2050-1: An update that solves 11 vulnerabilities and has one errata is now available.

Category: security (important)
Bug References: 988651,989722,989723,989725,989727,989728,989729,989730,989731,989732,989733,989734
CVE References: CVE-2016-3458,CVE-2016-3485,CVE-2016-3498,CVE-2016-3500,CVE-2016-3503,CVE-2016-3508,CVE-2016-3511,CVE-2016-3550,CVE-2016-3598,CVE-2016-3606,CVE-2016-3610
Sources used:
openSUSE 13.2 (src):    java-1_7_0-openjdk-1.7.0.111-25.1, java-1_7_0-openjdk-bootstrap-1.7.0.111-25.1
Comment 7 Swamp Workflow Management 2016-08-11 21:11:42 UTC
openSUSE-SU-2016:2051-1: An update that solves 13 vulnerabilities and has three fixes is now available.

Category: security (important)
Bug References: 984684,987895,988651,989721,989722,989723,989725,989726,989727,989728,989729,989730,989731,989732,989733,989734
CVE References: CVE-2016-3458,CVE-2016-3485,CVE-2016-3498,CVE-2016-3500,CVE-2016-3503,CVE-2016-3508,CVE-2016-3511,CVE-2016-3550,CVE-2016-3552,CVE-2016-3587,CVE-2016-3598,CVE-2016-3606,CVE-2016-3610
Sources used:
openSUSE Leap 42.1 (src):    java-1_8_0-openjdk-1.8.0.101-15.1
Comment 8 Swamp Workflow Management 2016-08-11 21:13:49 UTC
openSUSE-SU-2016:2052-1: An update that solves 11 vulnerabilities and has three fixes is now available.

Category: security (important)
Bug References: 982366,984684,988651,989722,989723,989725,989727,989728,989729,989730,989731,989732,989733,989734
CVE References: CVE-2016-3458,CVE-2016-3485,CVE-2016-3498,CVE-2016-3500,CVE-2016-3503,CVE-2016-3508,CVE-2016-3511,CVE-2016-3550,CVE-2016-3598,CVE-2016-3606,CVE-2016-3610
Sources used:
openSUSE Leap 42.1 (src):    java-1_7_0-openjdk-1.7.0.111-34.1, java-1_7_0-openjdk-bootstrap-1.7.0.111-34.1
Comment 9 Swamp Workflow Management 2016-08-12 10:08:25 UTC
openSUSE-SU-2016:2058-1: An update that solves 11 vulnerabilities and has one errata is now available.

Category: security (important)
Bug References: 988651,989722,989723,989725,989727,989728,989729,989730,989731,989732,989733,989734
CVE References: CVE-2016-3458,CVE-2016-3485,CVE-2016-3498,CVE-2016-3500,CVE-2016-3503,CVE-2016-3508,CVE-2016-3511,CVE-2016-3550,CVE-2016-3598,CVE-2016-3606,CVE-2016-3610
Sources used:
openSUSE 13.1 (src):    java-1_7_0-openjdk-1.7.0.111-24.39.1